summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-01-14 18:20:45 +0000
committerThilo Bangert <bangert@gentoo.org>2010-01-14 18:20:45 +0000
commita777888c51214dbbb6136e26f9b7e547a0eaaf53 (patch)
treea84198132c1d911f56e65671351e52c8f7839c91 /sys-apps/ucspi-unix
parentadd trailing slash for HOMEPAGE (diff)
downloadgentoo-2-a777888c51214dbbb6136e26f9b7e547a0eaaf53.tar.gz
gentoo-2-a777888c51214dbbb6136e26f9b7e547a0eaaf53.tar.bz2
gentoo-2-a777888c51214dbbb6136e26f9b7e547a0eaaf53.zip
EAPI2 - multilib ready - use local var - use newstyle bglibs paths - fix parallel build (bug #297986)
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'sys-apps/ucspi-unix')
-rw-r--r--sys-apps/ucspi-unix/ChangeLog12
-rw-r--r--sys-apps/ucspi-unix/files/ucspi-unix-0.36-fix-parallel-build.patch19
-rw-r--r--sys-apps/ucspi-unix/ucspi-unix-0.36-r4.ebuild38
3 files changed, 67 insertions, 2 deletions
diff --git a/sys-apps/ucspi-unix/ChangeLog b/sys-apps/ucspi-unix/ChangeLog
index e2cb962a9eb4..97af75b867c8 100644
--- a/sys-apps/ucspi-unix/ChangeLog
+++ b/sys-apps/ucspi-unix/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/ucspi-unix
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ucspi-unix/ChangeLog,v 1.23 2009/12/22 21:45:32 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ucspi-unix/ChangeLog,v 1.24 2010/01/14 18:20:45 bangert Exp $
+
+*ucspi-unix-0.36-r4 (14 Jan 2010)
+
+ 14 Jan 2010; Thilo Bangert <bangert@gentoo.org>
+ +ucspi-unix-0.36-r4.ebuild,
+ +files/ucspi-unix-0.36-fix-parallel-build.patch:
+ EAPI2 - multilib ready - use local var - use newstyle bglibs paths - fix
+ parallel build (bug #297986)
22 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
ucspi-unix-0.36-r3.ebuild:
diff --git a/sys-apps/ucspi-unix/files/ucspi-unix-0.36-fix-parallel-build.patch b/sys-apps/ucspi-unix/files/ucspi-unix-0.36-fix-parallel-build.patch
new file mode 100644
index 000000000000..94fc07cb0022
--- /dev/null
+++ b/sys-apps/ucspi-unix/files/ucspi-unix-0.36-fix-parallel-build.patch
@@ -0,0 +1,19 @@
+--- Makefile.orig 2010-01-14 14:42:14.000000000 +0100
++++ Makefile 2010-01-14 14:42:42.000000000 +0100
+@@ -41,14 +41,14 @@
+ ./load insthier -linstaller
+ mv insthier installer
+
+-instcheck: load insthier.o
++instcheck: load insthier.o installer instshow
+ ./load insthier -linstcheck
+ mv insthier instcheck
+
+ insthier.o: compile insthier.c conf_bin.c conf_man.c
+ ./compile insthier.c
+
+-instshow: load insthier.o
++instshow: load insthier.o installer
+ ./load insthier -linstshow
+ mv insthier instshow
+
diff --git a/sys-apps/ucspi-unix/ucspi-unix-0.36-r4.ebuild b/sys-apps/ucspi-unix/ucspi-unix-0.36-r4.ebuild
new file mode 100644
index 000000000000..89a459475a50
--- /dev/null
+++ b/sys-apps/ucspi-unix/ucspi-unix-0.36-r4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ucspi-unix/ucspi-unix-0.36-r4.ebuild,v 1.1 2010/01/14 18:20:45 bangert Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="A ucspi implementation for unix sockets"
+HOMEPAGE="http://untroubled.org/ucspi-unix/"
+SRC_URI="http://untroubled.org/ucspi-unix/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/bglibs-1.106"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-gentoo-head.patch
+ epatch "${FILESDIR}"/${P}-include-sys_socket.h.patch
+ epatch "${FILESDIR}"/${P}-fix-parallel-build.patch
+}
+
+src_configure() {
+ local has_peercred
+ use kernel_linux && has_peercred="-DHASPEERCRED=1"
+
+ echo "$(tc-getCC) ${CFLAGS} -I/usr/include/bglibs ${has_peercred} -D_GNU_SOURCE" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS} -L/usr/$(get_libdir)/bglibs" > conf-ld
+}
+
+src_install() {
+ dobin unixserver unixclient unixcat || die
+ doman unixserver.1 unixclient.1
+ dodoc ANNOUNCEMENT NEWS PROTOCOL README TODO
+}