summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-09-25 15:20:39 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-09-25 15:20:39 +0000
commitd3632e7ffe59e2daf972e94fb40718ea35be60b2 (patch)
tree4d10ee9a32da0390565b37f2648d5b87edffb29d /sys-apps/textutils/textutils-2.1.ebuild
parentadded mask for =courier-imap-1.5.3 (diff)
downloadgentoo-2-d3632e7ffe59e2daf972e94fb40718ea35be60b2.tar.gz
gentoo-2-d3632e7ffe59e2daf972e94fb40718ea35be60b2.tar.bz2
gentoo-2-d3632e7ffe59e2daf972e94fb40718ea35be60b2.zip
new version
Diffstat (limited to 'sys-apps/textutils/textutils-2.1.ebuild')
-rw-r--r--sys-apps/textutils/textutils-2.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/textutils/textutils-2.1.ebuild b/sys-apps/textutils/textutils-2.1.ebuild
new file mode 100644
index 000000000000..24905aad8929
--- /dev/null
+++ b/sys-apps/textutils/textutils-2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/textutils/textutils-2.1.ebuild,v 1.1 2002/09/25 15:20:39 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU text utilities"
+SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/textutils/"
+
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+
+src_compile() {
+ local myconf=""
+ use nls || myconf="--disable-nls"
+
+ econf \
+ --build=${CHOST} \
+ --without-included-regex \
+ ${myconf} || die
+
+ if [ "`use static`" ]
+ then
+ emake LDFLAGS=-static || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+ einstall || die
+
+ dodir /bin
+ mv ${D}/usr/bin/cat ${D}/bin
+ dosym /bin/cat /usr/bin/cat
+ # For baselayout
+ mv ${D}/usr/bin/wc ${D}/bin
+ dosym /bin/wc /usr/bin/wc
+
+ rmdir ${D}/usr/lib
+
+ if [ -z "`use build`" ]
+ then
+ dodoc AUTHORS COPYING ChangeLog NEWS README* THANKS TODO
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+