summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2009-02-24 07:59:12 +0000
committerJoshua Kinard <kumba@gentoo.org>2009-02-24 07:59:12 +0000
commit52d1c46f81a481a71ec8f59ab8cc5bce8469a684 (patch)
tree2df7c1778d8bfa8c8c312eb38e6dbd27456a2e2d /sys-apps/texinfo
parentAnd now the fribidi/readsector patches have been merged upstream. (diff)
downloadgentoo-2-52d1c46f81a481a71ec8f59ab8cc5bce8469a684.tar.gz
gentoo-2-52d1c46f81a481a71ec8f59ab8cc5bce8469a684.tar.bz2
gentoo-2-52d1c46f81a481a71ec8f59ab8cc5bce8469a684.zip
Make texinfo cross-compiler safe (#196041)
(Portage version: 2.1.6.7/cvs/Linux mips64)
Diffstat (limited to 'sys-apps/texinfo')
-rw-r--r--sys-apps/texinfo/ChangeLog5
-rw-r--r--sys-apps/texinfo/texinfo-4.13.ebuild8
2 files changed, 11 insertions, 2 deletions
diff --git a/sys-apps/texinfo/ChangeLog b/sys-apps/texinfo/ChangeLog
index 104c5c91522b..332021fbadcc 100644
--- a/sys-apps/texinfo/ChangeLog
+++ b/sys-apps/texinfo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/texinfo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.105 2009/02/22 14:38:04 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.106 2009/02/24 07:59:12 kumba Exp $
+
+ 24 Feb 2009; Joshua Kinard <kumba@gentoo.org> texinfo-4.13.ebuild:
+ Make texinfo cross-compiler safe (#196041)
22 Feb 2009; Tobias Klausmann <klausman@gentoo.org> texinfo-4.13.ebuild:
Stable on alpha, bug #259121
diff --git a/sys-apps/texinfo/texinfo-4.13.ebuild b/sys-apps/texinfo/texinfo-4.13.ebuild
index c4a0521d07fb..9ac784b5065a 100644
--- a/sys-apps/texinfo/texinfo-4.13.ebuild
+++ b/sys-apps/texinfo/texinfo-4.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/texinfo-4.13.ebuild,v 1.6 2009/02/22 14:38:04 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/texinfo-4.13.ebuild,v 1.7 2009/02/24 07:59:12 kumba Exp $
inherit flag-o-matic
@@ -23,6 +23,12 @@ DEPEND="${RDEPEND}
src_compile() {
use static && append-ldflags -static
econf $(use_enable nls) || die
+
+ # Make cross-compiler safe (#196041)
+ if tc-is-cross-compiler; then
+ emake -C tools/gnulib/lib || die "emake -C tools/gnulib/lib"
+ fi
+
emake || die "emake"
}