summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-03-28 01:59:58 +0000
committerJoshua Brindle <method@gentoo.org>2003-03-28 01:59:58 +0000
commit89ccb5e922debe6f7bcd503cbd135e763bdb3270 (patch)
treee2376fa622e41db3061fac08c1490936179b4219 /sys-apps/systrace
parentAdded building of include/asm/offset.h on hppa. (diff)
downloadgentoo-2-89ccb5e922debe6f7bcd503cbd135e763bdb3270.tar.gz
gentoo-2-89ccb5e922debe6f7bcd503cbd135e763bdb3270.tar.bz2
gentoo-2-89ccb5e922debe6f7bcd503cbd135e763bdb3270.zip
fixed header dealy
Diffstat (limited to 'sys-apps/systrace')
-rw-r--r--sys-apps/systrace/systrace-1.0-r1.ebuild31
1 files changed, 23 insertions, 8 deletions
diff --git a/sys-apps/systrace/systrace-1.0-r1.ebuild b/sys-apps/systrace/systrace-1.0-r1.ebuild
index 5d7668a2dd95..9afadbe63df7 100644
--- a/sys-apps/systrace/systrace-1.0-r1.ebuild
+++ b/sys-apps/systrace/systrace-1.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# $Header:
@@ -9,35 +9,50 @@ SRC_URI="http://www.citi.umich.edu/u/provos/systrace/usr-systrace-2003-01-26.tar
http://natey.com/gentoo/systrace/patches/systrace.c-no_x11-1.0.patch.gz"
SLOT="0"
LICENSE="GPL-2"
-KERNEL="linux-2.4.20-systrace-r2"
PATCH1="systrace.c-no_x11-1.0.patch"
+INCLUDE0="/usr/src/linux/include/linux/systrace.h"
+INCLUDE1="/usr/include/linux/systrace.h"
S="${WORKDIR}/${P}"
KEYWORDS="~x86"
IUSE="gtk"
DEPEND="gtk? ( =x11-libs/gtk+-1.2* =dev-libs/glib-1.2* )"
+pkg_setup() {
+ if ! [ -f ${INCLUDE0} ] || ! [ -f ${INCLUDE1} ] ;
+ then
+ einfo
+ einfo "ERROR: It does not look like you have a systrace capable kernel. If"
+ einfo "this is incorrect, please copy /usr/src/linux/include/linux/systrace.h"
+ einfo "to /usr/include/linux/ and restart the build."
+ einfo
+ einfo "The latest systrace Linux kernel patches can be found at:"
+ einfo
+ einfo "http://www.citi.umich.edu/u/provos/systrace/linux.html"
+ einfo
+ exit 1
+ fi
+}
+
src_compile() {
- cp /usr/src/${KERNEL}/include/linux/systrace.h /usr/include/linux/ || die
if [ "`use gtk`" ]
then
einfo
einfo "You are building systrace with gtk support; this version will not"
einfo "function without the sys-apps/gtk-systrace package installed. Please"
- einfo "unset the gtk USE variable to build the non-gui capable version of"
- einfo "systrace."
+ einfo "set the USE=\"-gtk\" to build the non-gui capable version of systrace."
einfo
sleep 7
./configure --host=${CHOST} || die
elif [ -z "`use gtk`" ]
then
einfo
- einfo "You are building systrace without gtk support; please set the gtk USE"
- einfo "variable to build the gui capable version of systrace."
+ einfo "You are building systrace without gtk support; please set USE=\"gtk\""
+ einfo "to build the gui capable version of systrace."
einfo
sleep 7
cd ${S}
- patch < ../${PATCH1} || die
+ epatch ../${PATCH1} || die
./configure --host=${CHOST} || die
fi