summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2013-03-14 18:24:35 +0000
committerFabio Erculiani <lxnay@gentoo.org>2013-03-14 18:24:35 +0000
commit54f5827ea3a775624f5b7943342717aca897049f (patch)
treeb5fc2ec5991b4883b10cf967789c687296f5ff82 /sys-apps/rigo-daemon
parentversion bump (diff)
downloadgentoo-2-54f5827ea3a775624f5b7943342717aca897049f.tar.gz
gentoo-2-54f5827ea3a775624f5b7943342717aca897049f.tar.bz2
gentoo-2-54f5827ea3a775624f5b7943342717aca897049f.zip
version bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key ADC916E5)
Diffstat (limited to 'sys-apps/rigo-daemon')
-rw-r--r--sys-apps/rigo-daemon/ChangeLog9
-rw-r--r--sys-apps/rigo-daemon/rigo-daemon-183.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/sys-apps/rigo-daemon/ChangeLog b/sys-apps/rigo-daemon/ChangeLog
index f58b21813ea1..d1429c219563 100644
--- a/sys-apps/rigo-daemon/ChangeLog
+++ b/sys-apps/rigo-daemon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/rigo-daemon
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rigo-daemon/ChangeLog,v 1.4 2012/09/27 11:01:26 lxnay Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rigo-daemon/ChangeLog,v 1.5 2013/03/14 18:24:35 lxnay Exp $
+
+*rigo-daemon-183 (14 Mar 2013)
+
+ 14 Mar 2013; Fabio Erculiani <lxnay@gentoo.org> +rigo-daemon-183.ebuild:
+ version bump
*rigo-daemon-144 (27 Sep 2012)
diff --git a/sys-apps/rigo-daemon/rigo-daemon-183.ebuild b/sys-apps/rigo-daemon/rigo-daemon-183.ebuild
new file mode 100644
index 000000000000..320f56bc5a9b
--- /dev/null
+++ b/sys-apps/rigo-daemon/rigo-daemon-183.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rigo-daemon/rigo-daemon-183.ebuild,v 1.1 2013/03/14 18:24:35 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python
+
+MY_PN="RigoDaemon"
+DESCRIPTION="Entropy Client DBus Services, aka RigoDaemon"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}/rigo/${MY_PN}"
+
+DEPEND=""
+RDEPEND="dev-python/dbus-python
+ dev-python/pygobject:3
+ ~sys-apps/entropy-${PV}
+ sys-auth/polkit[introspection]
+ sys-devel/gettext"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+}
+
+pkg_preinst() {
+ # ask RigoDaemon to shutdown, if running
+ # TODO: this will be removed in future
+ local shutdown_exec=${EROOT}/usr/lib/rigo/${MY_PN}/shutdown.py
+ [[ -x "${shutdown_exec}" ]] && "${shutdown_exec}"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/rigo/${MY_PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/rigo/${MY_PN}"
+}