summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2010-12-07 13:47:02 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2010-12-07 13:47:02 +0000
commitbbc7935ec8436620d9a7795a5c274ea5fe480f2e (patch)
treed3485f22d188db812e405f9da3856f47cd46cb08 /sys-apps/qingy
parentVersion Bump, which fixes the LDFLAGS repect, #335963 (diff)
downloadgentoo-2-bbc7935ec8436620d9a7795a5c274ea5fe480f2e.tar.gz
gentoo-2-bbc7935ec8436620d9a7795a5c274ea5fe480f2e.tar.bz2
gentoo-2-bbc7935ec8436620d9a7795a5c274ea5fe480f2e.zip
Version bump. Closes bug #345135.
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'sys-apps/qingy')
-rw-r--r--sys-apps/qingy/ChangeLog7
-rw-r--r--sys-apps/qingy/qingy-1.0.0.ebuild122
2 files changed, 128 insertions, 1 deletions
diff --git a/sys-apps/qingy/ChangeLog b/sys-apps/qingy/ChangeLog
index 60c11525e6d7..780a0feffb30 100644
--- a/sys-apps/qingy/ChangeLog
+++ b/sys-apps/qingy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/qingy
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.62 2010/09/06 08:46:11 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.63 2010/12/07 13:47:02 s4t4n Exp $
+
+*qingy-1.0.0 (7 Dec 2010)
+
+ 7 Dec 2010; Michele Noberasco <s4t4n@gentoo.org> +qingy-1.0.0.ebuild:
+ Version bump. Closes bug #345135.
06 Sep 2010; Michele Noberasco <s4t4n@gentoo.org> qingy-*.ebuild:
Small change to fix bug 336117.
diff --git a/sys-apps/qingy/qingy-1.0.0.ebuild b/sys-apps/qingy/qingy-1.0.0.ebuild
new file mode 100644
index 000000000000..2282b336ea9e
--- /dev/null
+++ b/sys-apps/qingy/qingy-1.0.0.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-1.0.0.ebuild,v 1.1 2010/12/07 13:47:02 s4t4n Exp $
+
+EAPI="2"
+
+inherit elisp-common eutils pam
+
+GENTOO_THEME_VERSION="2.1"
+
+DESCRIPTION="a DirectFB getty replacement"
+HOMEPAGE="http://qingy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://gentoo/${PN}-gentoo-theme-${GENTOO_THEME_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="crypt directfb emacs gpm opensslcrypt pam static X"
+
+RDEPEND=">=sys-libs/ncurses-5.4-r6
+ opensslcrypt? ( >=dev-libs/openssl-0.9.7e )
+ crypt? ( >=dev-libs/libgcrypt-1.2.1 )
+ directfb? ( >=dev-libs/DirectFB-1.4.2[fbcon,jpeg,png,truetype] )
+ emacs? ( virtual/emacs )
+ pam? ( >=sys-libs/pam-0.75-r11 )
+ X? ( x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-proto/scrnsaverproto )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ >=sys-apps/sed-4.1.4-r1"
+RDEPEND="${RDEPEND}
+ pam? ( sys-auth/pambase )"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_configure()
+{
+ local crypto_support="--disable-crypto"
+ local emacs_support="--disable-emacs --without-lispdir"
+
+ if use crypt && use opensslcrypt; then
+ echo
+ ewarn "You can have openssl or libgcrypt as a crypto library, not both."
+ ewarn "Using libgcrypt now..."
+ echo
+ fi
+
+ use emacs && emacs_support="--enable-emacs --with-lispdir=${SITELISP}/${PN}"
+ use opensslcrypt && crypto_support="--enable-crypto=openssl"
+ use crypt && crypto_support="--enable-crypto=libgcrypt"
+ econf \
+ --sbindir=/sbin \
+ --disable-optimizations \
+ `use_enable pam` \
+ `use_enable static static-build` \
+ `use_enable gpm gpm-lock` \
+ `use_enable X x-support` \
+ `use_enable directfb DirectFB-support` \
+ ${crypto_support} \
+ ${emacs_support} \
+ || die "Configuration failed"
+}
+
+src_install()
+{
+ # Copy documentation manually as make install only installs info files
+ # INSTALL is left because it contains also configuration informations
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS TODO
+
+ # Install the program
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ # Set the settings file umask to 600, in case somebody
+ # wants to make use of the autologin feature
+ /bin/chmod 600 "${D}/etc/qingy/settings"
+
+ # Install Gentoo theme
+ dodir /usr/share/${PN}/themes/gentoo
+ cp "${WORKDIR}"/gentoo/* "${D}/usr/share/${PN}/themes/gentoo" \
+ || die "Gentoo theme installation failed"
+
+ # Alter config file so that it uses our theme
+ sed -i 's/theme = "default"/theme = "gentoo"/' "${D}/etc/${PN}/settings"
+
+ # Install log rotation policy
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}-logrotate" ${PN} || die "Log rotation policy installation failed"
+
+ use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ rm "${D}/etc/pam.d/qingy"
+ pamd_mimic system-local-login qingy auth account password session
+}
+
+pkg_postinst()
+{
+ einfo "In order to use qingy you must first edit your /etc/inittab"
+ einfo "Check the documentation at ${HOMEPAGE}"
+ einfo "for instructions on how to do that."
+ echo
+ einfo "Also, make sure to adjust qingy settings file (/etc/qingy/settings)"
+ einfo "to your preferences/machine configuration..."
+
+ if use crypt; then
+ echo
+ einfo "You will have to create a key pair using 'qingy-keygen'"
+ echo
+ ewarn "Note that sometimes a generated key-pair may pass the internal tests"
+ ewarn "but fail to work properly. You will get a 'regenerate your keys'"
+ ewarn "message. If this is your case, please remove /etc/qingy/public_key"
+ ewarn "and /etc/qingy/private_key and run qingy-keygen again..."
+ fi
+
+ use emacs && echo && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}