summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-12-13 17:49:38 +0000
committerJeroen Roovers <jer@gentoo.org>2012-12-13 17:49:38 +0000
commitb0d44ee99317b605636292b63cae57c7e43ea267 (patch)
treee5f41f0303b26222dea65aeb18b50a5758ef4713 /sys-apps/pv
parentAdd check for kernel version, wrt bug #447092 (diff)
downloadgentoo-2-b0d44ee99317b605636292b63cae57c7e43ea267.tar.gz
gentoo-2-b0d44ee99317b605636292b63cae57c7e43ea267.tar.bz2
gentoo-2-b0d44ee99317b605636292b63cae57c7e43ea267.zip
Add IUSE=debug.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'sys-apps/pv')
-rw-r--r--sys-apps/pv/ChangeLog5
-rw-r--r--sys-apps/pv/pv-1.4.4.ebuild13
2 files changed, 12 insertions, 6 deletions
diff --git a/sys-apps/pv/ChangeLog b/sys-apps/pv/ChangeLog
index 3aff9a8f543a..3239b96c6e46 100644
--- a/sys-apps/pv/ChangeLog
+++ b/sys-apps/pv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/pv
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/ChangeLog,v 1.47 2012/12/13 11:25:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/ChangeLog,v 1.48 2012/12/13 17:49:38 jer Exp $
+
+ 13 Dec 2012; Jeroen Roovers <jer@gentoo.org> pv-1.4.4.ebuild:
+ Add IUSE=debug.
*pv-1.4.4 (13 Dec 2012)
diff --git a/sys-apps/pv/pv-1.4.4.ebuild b/sys-apps/pv/pv-1.4.4.ebuild
index 3b28bcced046..10a5ef6a3f31 100644
--- a/sys-apps/pv/pv-1.4.4.ebuild
+++ b/sys-apps/pv/pv-1.4.4.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/pv-1.4.4.ebuild,v 1.1 2012/12/13 11:25:13 jlec Exp $
-
-EAPI="4"
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/pv-1.4.4.ebuild,v 1.2 2012/12/13 17:49:38 jer Exp $
+EAPI=4
inherit toolchain-funcs
DESCRIPTION="Pipe Viewer: a tool for monitoring the progress of data through a pipe"
@@ -14,7 +13,7 @@ LICENSE="Artistic-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris ~x86-solaris"
-IUSE="nls"
+IUSE="debug nls"
PV_LINGUAS="de fr pl pt"
for lingua in ${PV_LINGUAS}; do
IUSE+=" linguas_${lingua}"
@@ -22,6 +21,10 @@ done
DOCS=( README doc/NEWS doc/TODO )
+src_prepare() {
+ sed -i configure -e 's|CFLAGS="-g -Wall"|:|g' || die
+}
+
src_configure() {
local lingua
for lingua in ${PV_LINGUAS}; do
@@ -29,7 +32,7 @@ src_configure() {
sed -i configure -e "/ALL_LINGUAS=/s:${lingua}::g" || die
fi
done
- econf $(use_enable nls)
+ econf $(use_enable debug debugging) $(use_enable nls)
}
src_test() {