summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-08-25 16:07:09 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-08-25 16:07:09 +0000
commit2e99dcdf769126ccd3940b0a5fbb8e9d1513b0df (patch)
tree895eda129757b091956afbd25f6cbc99eee353b5 /sys-apps/pmount
parentupdated vim7 snapshot (diff)
downloadgentoo-2-2e99dcdf769126ccd3940b0a5fbb8e9d1513b0df.tar.gz
gentoo-2-2e99dcdf769126ccd3940b0a5fbb8e9d1513b0df.tar.bz2
gentoo-2-2e99dcdf769126ccd3940b0a5fbb8e9d1513b0df.zip
cleaned up ebuild with suggestions from Betelgeuse
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps/pmount')
-rw-r--r--sys-apps/pmount/ChangeLog8
-rw-r--r--sys-apps/pmount/files/digest-pmount-0.9.3-r1 (renamed from sys-apps/pmount/files/digest-pmount-0.9.3)0
-rw-r--r--sys-apps/pmount/pmount-0.9.3-r1.ebuild (renamed from sys-apps/pmount/pmount-0.9.3.ebuild)35
3 files changed, 34 insertions, 9 deletions
diff --git a/sys-apps/pmount/ChangeLog b/sys-apps/pmount/ChangeLog
index 2e75691ab50f..011675e7178f 100644
--- a/sys-apps/pmount/ChangeLog
+++ b/sys-apps/pmount/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pmount
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.4 2005/08/24 06:22:11 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.5 2005/08/25 16:07:09 cardoe Exp $
+
+*pmount-0.9.3-r1 (25 Aug 2005)
+
+ 25 Aug 2005; Doug Goldstein <cardoe@gentoo.org> -pmount-0.9.3.ebuild,
+ +pmount-0.9.3-r1.ebuild:
+ cleaned up ebuild with suggestions from Betelgeuse
*pmount-0.9.3 (24 Aug 2005)
diff --git a/sys-apps/pmount/files/digest-pmount-0.9.3 b/sys-apps/pmount/files/digest-pmount-0.9.3-r1
index a4de0c2c4b23..a4de0c2c4b23 100644
--- a/sys-apps/pmount/files/digest-pmount-0.9.3
+++ b/sys-apps/pmount/files/digest-pmount-0.9.3-r1
diff --git a/sys-apps/pmount/pmount-0.9.3.ebuild b/sys-apps/pmount/pmount-0.9.3-r1.ebuild
index eec80a4b35a5..42a04d966d03 100644
--- a/sys-apps/pmount/pmount-0.9.3.ebuild
+++ b/sys-apps/pmount/pmount-0.9.3-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.3.ebuild,v 1.1 2005/08/24 06:22:11 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.3-r1.ebuild,v 1.1 2005/08/25 16:07:09 cardoe Exp $
inherit eutils
-DESCRIPTION="Mount removable devices as a normal user"
+DESCRIPTION="Policy based mounter that gives the ability to mount removable devices as a user"
SRC_URI="http://www.piware.de/projects/${P}.tar.gz"
HOMEPAGE="http://www.piware.de/projects.shtml"
LICENSE="GPL-2"
@@ -16,7 +16,7 @@ IUSE="crypt"
RDEPEND=">=sys-apps/dbus-0.33
>=sys-apps/hal-0.5.1
>=sys-fs/sysfsutils-1.0
- crypt? ( sys-fs/cryptsetup )"
+ crypt? ( sys-fs/cryptsetup-luks )"
DEPEND=${RDEPEND}
@@ -26,15 +26,34 @@ pkg_setup() {
enewgroup plugdev || die "Error creating plugdev group"
}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e 's:/sbin/cryptsetup:/bin/cryptsetup:' -i policy.h
+}
+
src_install () {
- dobin pmount-hal pmount pumount
- dodoc AUTHORS CHANGES
+ #this is where we mount stuff
+ dodir /media
+
+ # HAL informed mounter, used by Gnome/KDE
+ dobin pmount-hal
+
+ # Must be run SETUID
+ exeinto /usr/bin
+ exeopts -m 4770
+ doexe pmount pumount
+ fowners -1:plugdev /usr/bin/pmount
+ fowners -1:plugdev /usr/bin/pumount
+
+ dodoc AUTHORS CHANGES TODO
+ doman pmount.1 pumount.1
+
+ insinto /etc
+ doins pmount.allow
}
pkg_postinst() {
- chown root:plugdev /usr/bin/pmount /usr/bin/pumount
- chmod 4770 /usr/bin/pmount /usr/bin/pumount
-
einfo
einfo "This package has been installed setuid. The permissions are as such that"
einfo "only users that belong to the plugdev group are allowed to run this."