summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2005-06-30 09:43:50 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2005-06-30 09:43:50 +0000
commit5355a54cd1214ffcfd3e614333b09e50d3b0333f (patch)
tree72ff1a7ef020cb727d2461cb82e17f2b2615cab0 /sys-apps/pcmcia-cs-cis/pcmcia-cs-cis-3.2.8-r1.ebuild
parentunmasked dhcpcd (diff)
downloadgentoo-2-5355a54cd1214ffcfd3e614333b09e50d3b0333f.tar.gz
gentoo-2-5355a54cd1214ffcfd3e614333b09e50d3b0333f.tar.bz2
gentoo-2-5355a54cd1214ffcfd3e614333b09e50d3b0333f.zip
The kernel expects files ending in .cis, not .dat - thanks to Dominik Brodowski for the heads up.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-apps/pcmcia-cs-cis/pcmcia-cs-cis-3.2.8-r1.ebuild')
-rw-r--r--sys-apps/pcmcia-cs-cis/pcmcia-cs-cis-3.2.8-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/pcmcia-cs-cis/pcmcia-cs-cis-3.2.8-r1.ebuild b/sys-apps/pcmcia-cs-cis/pcmcia-cs-cis-3.2.8-r1.ebuild
new file mode 100644
index 000000000000..76e6dcc73166
--- /dev/null
+++ b/sys-apps/pcmcia-cs-cis/pcmcia-cs-cis-3.2.8-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs-cis/pcmcia-cs-cis-3.2.8-r1.ebuild,v 1.1 2005/06/30 09:43:49 brix Exp $
+
+inherit linux-info
+
+MY_P=${P/-cis/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="PCMCIA CIS files for use with pcmciautils"
+HOMEPAGE="http://pcmcia-cs.sourceforge.net"
+SRC_URI="mirror://sourceforge/pcmcia-cs/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+DEPEND=">=sys-apps/hotplug-20040920
+ !sys-apps/pcmcia-cs"
+
+CONFIG_CHECK="PCMCIA_LOAD_CIS"
+ERROR_PCMCIA_LOAD_CIS="${P} requires support for loading CIS updates from userspace (CONFIG_PCMCIA_LOAD_CIS)"
+
+src_compile () {
+ einfo "No compilation necessary."
+}
+
+src_install () {
+ insinto /lib/firmware
+
+ cd ${S}/etc/cis
+ for file in *.dat; do
+ newins ${file} ${file/.dat/.cis}
+ done
+}