summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-08-23 09:35:36 +0000
committerMike Frysinger <vapier@gentoo.org>2009-08-23 09:35:36 +0000
commit9c7f9c0f38fdb3f75ba19e9ed500c65146f54adc (patch)
tree03caf7663031b146c69a1b475242d467b1297811 /sys-apps/pciutils
parentppc stable #280617 (diff)
downloadgentoo-2-9c7f9c0f38fdb3f75ba19e9ed500c65146f54adc.tar.gz
gentoo-2-9c7f9c0f38fdb3f75ba19e9ed500c65146f54adc.tar.bz2
gentoo-2-9c7f9c0f38fdb3f75ba19e9ed500c65146f54adc.zip
Version bump #276540 by Lars Wendler.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/pciutils')
-rw-r--r--sys-apps/pciutils/ChangeLog7
-rw-r--r--sys-apps/pciutils/pciutils-3.1.4.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index 80d37e39215a..ce483a4cf873 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pciutils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.164 2009/04/05 03:21:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.165 2009/08/23 09:35:36 vapier Exp $
+
+*pciutils-3.1.4 (23 Aug 2009)
+
+ 23 Aug 2009; Mike Frysinger <vapier@gentoo.org> +pciutils-3.1.4.ebuild:
+ Version bump #276540 by Lars Wendler.
05 Apr 2009; Mike Frysinger <vapier@gentoo.org>
files/pciutils-2.2.7-update-pciids-both-forms.patch:
diff --git a/sys-apps/pciutils/pciutils-3.1.4.ebuild b/sys-apps/pciutils/pciutils-3.1.4.ebuild
new file mode 100644
index 000000000000..7b7869597df4
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-3.1.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-3.1.4.ebuild,v 1.1 2009/08/23 09:35:36 vapier Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Various utilities dealing with the PCI bus"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="network-cron zlib"
+
+DEPEND="zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.2.7-update-pciids-both-forms.patch
+ sed -i -e "/^LIBDIR=/s:/lib:/$(get_libdir):" Makefile
+}
+
+uyesno() { use $1 && echo yes || echo no ; }
+pemake() {
+ emake \
+ HOST="${CHOST}" \
+ CROSS_COMPILE="${CHOST}-" \
+ DNS="yes" \
+ IDSDIR="/usr/share/misc" \
+ MANDIR="/usr/share/man" \
+ PREFIX="/usr" \
+ SHARED="yes" \
+ STRIP="" \
+ ZLIB=$(uyesno zlib) \
+ "$@"
+}
+
+src_compile() {
+ pemake OPT="${CFLAGS}" all || die
+}
+
+src_install() {
+ pemake DESTDIR="${D}" install || die
+ dodoc ChangeLog README TODO
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/pciutils.cron update-pciids \
+ || die "Failed to install update cronjob"
+ fi
+
+ # Install both forms until HAL has migrated
+ if use zlib ; then
+ local sharedir="${D}/usr/share/misc"
+ elog "Providing a backwards compatibility non-compressed pci.ids"
+ gzip -d <"${sharedir}"/pci.ids.gz >"${sharedir}"/pci.ids
+ fi
+
+ newinitd "${FILESDIR}"/init.d-pciparm pciparm
+ newconfd "${FILESDIR}"/conf.d-pciparm pciparm
+}
+
+pkg_postinst() {
+ elog "The 'pcimodules' program has been replaced by 'lspci -k'"
+}