summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-02-20 00:50:09 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-02-20 00:50:09 +0000
commit158d50f7b49f8c5bb988bf285ecaf7879022d46b (patch)
tree458b1d7d5ea850c21ee94c961cfdad92c8cf2093 /sys-apps/paxctl
parentRemove old (diff)
downloadgentoo-2-158d50f7b49f8c5bb988bf285ecaf7879022d46b.tar.gz
gentoo-2-158d50f7b49f8c5bb988bf285ecaf7879022d46b.tar.bz2
gentoo-2-158d50f7b49f8c5bb988bf285ecaf7879022d46b.zip
Version bump
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/paxctl')
-rw-r--r--sys-apps/paxctl/ChangeLog9
-rw-r--r--sys-apps/paxctl/paxctl-0.6.ebuild26
2 files changed, 33 insertions, 2 deletions
diff --git a/sys-apps/paxctl/ChangeLog b/sys-apps/paxctl/ChangeLog
index 50545cfbb2b2..265400ae84b4 100644
--- a/sys-apps/paxctl/ChangeLog
+++ b/sys-apps/paxctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/paxctl
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/ChangeLog,v 1.30 2011/04/16 23:24:52 blueness Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/ChangeLog,v 1.31 2012/02/20 00:50:09 blueness Exp $
+
+*paxctl-0.6 (20 Feb 2012)
+
+ 20 Feb 2012; Anthony G. Basile <blueness@gentoo.org> +paxctl-0.6.ebuild:
+ Version bump
16 Apr 2011; Anthony G. Basile <blueness@gentoo.org> metadata.xml:
Updated metadata info.
diff --git a/sys-apps/paxctl/paxctl-0.6.ebuild b/sys-apps/paxctl/paxctl-0.6.ebuild
new file mode 100644
index 000000000000..24d73aa11edd
--- /dev/null
+++ b/sys-apps/paxctl/paxctl-0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/paxctl-0.6.ebuild,v 1.1 2012/02/20 00:50:09 blueness Exp $
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Manages various PaX related program header flags for Elf32, Elf64, binaries."
+SRC_URI="http://pax.grsecurity.net/paxctl-${PV}.tar.gz"
+HOMEPAGE="http://pax.grsecurity.net"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-devel/binutils-2.14.90.0.8-r1"
+RDEPEND=""
+
+src_compile() {
+ tc-export CC
+ emake CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ einstall DESTDIR="${D}"
+ dodoc README ChangeLog
+}