summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2003-05-20 08:00:29 +0000
committerJoshua Kinard <kumba@gentoo.org>2003-05-20 08:00:29 +0000
commit5e4b683e37898d6091b63369b7de8f4aea3368b8 (patch)
tree2e4db23b8fb2454b91631f226495903579f4be4d /sys-apps/pam-login
parentAdded gnuconfig eclass to support linux-mips targets (diff)
downloadgentoo-2-5e4b683e37898d6091b63369b7de8f4aea3368b8.tar.gz
gentoo-2-5e4b683e37898d6091b63369b7de8f4aea3368b8.tar.bz2
gentoo-2-5e4b683e37898d6091b63369b7de8f4aea3368b8.zip
Added gnuconfig eclass to support linux-mips targets
Diffstat (limited to 'sys-apps/pam-login')
-rw-r--r--sys-apps/pam-login/ChangeLog6
-rw-r--r--sys-apps/pam-login/Manifest4
-rw-r--r--sys-apps/pam-login/pam-login-3.11.ebuild10
3 files changed, 16 insertions, 4 deletions
diff --git a/sys-apps/pam-login/ChangeLog b/sys-apps/pam-login/ChangeLog
index 6b9f8d46ed66..4bac667f0293 100644
--- a/sys-apps/pam-login/ChangeLog
+++ b/sys-apps/pam-login/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for sys-apps/pam-login
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pam-login/ChangeLog,v 1.15 2003/05/18 23:50:52 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pam-login/ChangeLog,v 1.16 2003/05/20 08:00:11 kumba Exp $
+
*pam-login-3.11 (19 May 2003)
+ 20 May 2003; Joshua Kinard <kumba@gentoo.org> pam-login-3.11.ebuild:
+ Added gnuconfig eclass to support linux-mips targets
+
19 May 2003; Martin Schlemmer <azarah@gentoo.org> pam-login-3.11.ebuild:
Fix gcc-3.3 compile issues, bug #21213.
diff --git a/sys-apps/pam-login/Manifest b/sys-apps/pam-login/Manifest
index 362bda229a31..2167dd6ab806 100644
--- a/sys-apps/pam-login/Manifest
+++ b/sys-apps/pam-login/Manifest
@@ -1,9 +1,9 @@
-MD5 2b7779ea67fd22b974b86d54d897d7c3 ChangeLog 2138
+MD5 b204c5fdcb0e3bc51e5fee29b2d5789b ChangeLog 2137
MD5 7af49aad99179b74a5d5ea72879ab2ed pam-login-3.10.ebuild 1984
MD5 4252dabdab49bb4d709610a75dae72b4 pam-login-3.6-r1.ebuild 1824
MD5 a06af999a15ab19e9478fecdca3ee477 pam-login-3.6-r2.ebuild 1931
MD5 e1eee071c059786d7d32c969c2264dec pam-login-3.7.ebuild 1977
-MD5 bd3321bd0e0af9a6b353200407a58da8 pam-login-3.11.ebuild 2126
+MD5 caa7068136f7b936ba3ed5fe90d54147 pam-login-3.11.ebuild 2125
MD5 a5e9be8a38e1b8f784d3cf558cff7a6b files/digest-pam-login-3.10 67
MD5 918ba376dc33a5a1c9f9b0bd048b484b files/digest-pam-login-3.6-r1 66
MD5 918ba376dc33a5a1c9f9b0bd048b484b files/digest-pam-login-3.6-r2 66
diff --git a/sys-apps/pam-login/pam-login-3.11.ebuild b/sys-apps/pam-login/pam-login-3.11.ebuild
index 8de5703ea7ec..5dd1f4eec7f5 100644
--- a/sys-apps/pam-login/pam-login-3.11.ebuild
+++ b/sys-apps/pam-login/pam-login-3.11.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pam-login/pam-login-3.11.ebuild,v 1.1 2003/05/18 23:50:52 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pam-login/pam-login-3.11.ebuild,v 1.2 2003/05/20 08:00:11 kumba Exp $
+
+
+inherit gnuconfig
# Do we want to backup an old login.defs, and forcefully
# install a new version?
@@ -21,6 +24,11 @@ DEPEND="virtual/glibc
>=sys-apps/shadow-4.0.2-r5"
src_compile() {
+
+ # Fix configure scripts to recognize linux-mips
+ # (imports updated config.sub and config.guess)
+ gnuconfig_update
+
local myconf=""
use nls ||myconf="--disable-nls"