summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-10-20 07:10:02 +0000
committerMichał Górny <mgorny@gentoo.org>2013-10-20 07:10:02 +0000
commitdddde5ba58c842f669280a43b3ef00c8958c7ac1 (patch)
treea7f269705c5704a2531cf7203dc4ea901d8305d2 /sys-apps/paludis
parentMask more ruby18-only packages. (diff)
downloadgentoo-2-dddde5ba58c842f669280a43b3ef00c8958c7ac1.tar.gz
gentoo-2-dddde5ba58c842f669280a43b3ef00c8958c7ac1.tar.bz2
gentoo-2-dddde5ba58c842f669280a43b3ef00c8958c7ac1.zip
Version bump, brings modern boost support and test suite fixes. Use new EAPI and new eclasses. Clean up bash syntax, reduce needless USE flags and use prebuilt documentation unconditionally.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-apps/paludis')
-rw-r--r--sys-apps/paludis/ChangeLog10
-rw-r--r--sys-apps/paludis/metadata.xml8
-rw-r--r--sys-apps/paludis/paludis-1.4.2.ebuild154
3 files changed, 169 insertions, 3 deletions
diff --git a/sys-apps/paludis/ChangeLog b/sys-apps/paludis/ChangeLog
index 4f45ebfcaee6..d0cd62484d05 100644
--- a/sys-apps/paludis/ChangeLog
+++ b/sys-apps/paludis/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/paludis
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/ChangeLog,v 1.235 2013/05/19 18:33:14 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/ChangeLog,v 1.236 2013/10/20 07:10:02 mgorny Exp $
+
+*paludis-1.4.2 (20 Oct 2013)
+
+ 20 Oct 2013; Michał Górny <mgorny@gentoo.org> +paludis-1.4.2.ebuild,
+ metadata.xml:
+ Version bump, brings modern boost support and test suite fixes. Use new EAPI
+ and new eclasses. Clean up bash syntax, reduce needless USE flags and use
+ prebuilt documentation unconditionally.
19 May 2013; Jeff Horelick <jdhore@gentoo.org> paludis-1.4.0.ebuild:
Require >=app-arch/libarchive-3.1.2 as it's the only version currently in the
diff --git a/sys-apps/paludis/metadata.xml b/sys-apps/paludis/metadata.xml
index 97208ce51f06..2c871a1e5587 100644
--- a/sys-apps/paludis/metadata.xml
+++ b/sys-apps/paludis/metadata.xml
@@ -2,8 +2,12 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
- <email>jdhore@gentoo.org</email>
- <name>Jeff Horelick</name>
+ <email>jdhore@gentoo.org</email>
+ <name>Jeff Horelick</name>
+ </maintainer>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
</maintainer>
<use>
<flag name="pbins">Enable binary package support. Adds dependency upon
diff --git a/sys-apps/paludis/paludis-1.4.2.ebuild b/sys-apps/paludis/paludis-1.4.2.ebuild
new file mode 100644
index 000000000000..e93013f17b0a
--- /dev/null
+++ b/sys-apps/paludis/paludis-1.4.2.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/paludis-1.4.2.ebuild,v 1.1 2013/10/20 07:10:02 mgorny Exp $
+
+EAPI=4
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit bash-completion-r1 eutils python-single-r1 user
+
+DESCRIPTION="paludis, the other package mangler"
+HOMEPAGE="http://paludis.exherbo.org/"
+SRC_URI="http://paludis.exherbo.org/download/${P}.tar.bz2"
+
+IUSE="doc pbins pink python ruby search-index test xml"
+LICENSE="GPL-2 vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=app-admin/eselect-1.2.13
+ >=app-shells/bash-3.2
+ >=sys-devel/gcc-4.4
+ dev-libs/libpcre[cxx]
+ sys-apps/file
+ pbins? ( >=app-arch/libarchive-3.1.2[xattr] )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-libs/boost-1.41.0[python,${PYTHON_USEDEP}] )
+ ruby? ( >=dev-lang/ruby-1.8 )
+ xml? ( >=dev-libs/libxml2-2.6 )
+ search-index? ( >=dev-db/sqlite-3 )"
+
+DEPEND="${COMMON_DEPEND}
+ doc? (
+ || ( >=app-doc/doxygen-1.5.3 <=app-doc/doxygen-1.5.1 )
+ media-gfx/imagemagick
+ python? (
+ dev-python/epydoc[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}] )
+ ruby? ( dev-ruby/syntax )
+ )
+ virtual/pkgconfig
+ test? ( >=dev-cpp/gtest-1.6.0-r1 )"
+
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/sandbox"
+
+# Keep syntax as a PDEPEND. It avoids issues when Paludis is used as the
+# default virtual/portage provider.
+PDEPEND="app-admin/eselect-package-manager"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ if id paludisbuild >/dev/null 2>/dev/null ; then
+ if ! groups paludisbuild | grep --quiet '\<tty\>' ; then
+ eerror "The 'paludisbuild' user is now expected to be a member of the"
+ eerror "'tty' group. You should add the user to this group before"
+ eerror "upgrading Paludis."
+ die "Please add paludisbuild to tty group"
+ fi
+ fi
+ fi
+
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if [[ $(gcc-major-version) -lt 4
+ || ( $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 4 ) ]]
+ then
+ eerror "Paludis requires at least gcc 4.4 to build. Please switch the active"
+ eerror "gcc version using gcc-config."
+ die "Paludis requires at least gcc 4.4"
+ fi
+ fi
+}
+
+pkg_setup() {
+ enewgroup "paludisbuild"
+ enewuser "paludisbuild" -1 -1 "/var/tmp/paludis" "paludisbuild,tty"
+
+ python-single-r1_pkg_setup
+}
+
+csep() {
+ local IFS=,
+ echo "${*}"
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc doxygen)
+ $(use_enable pbins)
+ $(use_enable pink)
+ $(use_enable ruby)
+ $(use ruby && use_enable doc ruby-doc)
+ $(use_enable python)
+ $(use python && use_enable doc python-doc)
+ $(use_enable xml)
+ $(use_enable search-index)
+ $(use_enable test gtest)
+ --enable-prebuilt-documentation
+ --enable-vim
+ --enable-visibility
+ --with-config-framework=eselect
+ --with-environments=default,portage
+ --with-vim-install-dir=/usr/share/vim/vimfiles
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ dobashcomp bash-completion/cave
+
+ insinto /usr/share/zsh/site-functions
+ doins zsh-completion/_cave
+}
+
+src_test() {
+ # Work around Portage bugs
+ local -x PALUDIS_DO_NOTHING_SANDBOXY="portage sucks"
+ local -x BASH_ENV=/dev/null
+
+ if [[ ${EUID} == 0 ]] ; then
+ # hate
+ local -x PALUDIS_REDUCED_UID=0
+ local -x PALUDIS_REDUCED_GID=0
+ fi
+
+ if ! nonfatal emake check ; then
+ eerror "Tests failed. Looking for files for you to add to your bug report..."
+ find "${S}" -type f -name '*.epicfail' -or -name '*.log' | while read a ; do
+ eerror " $a"
+ done
+ die "Make check failed"
+ fi
+}
+
+pkg_postinst() {
+ local pm
+ if [[ -f ${ROOT}/etc/env.d/50package-manager ]] ; then
+ pm=$( source "${ROOT}"/etc/env.d/50package-manager ; echo "${PACKAGE_MANAGER}" )
+ fi
+
+ if [[ ${pm} != paludis ]] ; then
+ elog "If you are using paludis or cave as your primary package manager,"
+ elog "you should consider running:"
+ elog " eselect package-manager set paludis"
+ fi
+}