summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-12-24 06:59:46 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-12-24 06:59:46 +0000
commit3ef2edf1045555e1f52f868a302f77e66274a4cf (patch)
tree33d6ff0cbd51ace1e7fc897733b0a42da1a17e82 /sys-apps/openrc
parentfix Manifest (diff)
downloadgentoo-2-3ef2edf1045555e1f52f868a302f77e66274a4cf.tar.gz
gentoo-2-3ef2edf1045555e1f52f868a302f77e66274a4cf.tar.bz2
gentoo-2-3ef2edf1045555e1f52f868a302f77e66274a4cf.zip
Fix patches directory, bug #252340. Update ebuild to match the old 0.4.0 ebuild.
(Portage version: 2.1.6.2/cvs/Linux 2.6.27-gentoo-r1 i686)
Diffstat (limited to 'sys-apps/openrc')
-rw-r--r--sys-apps/openrc/ChangeLog6
-rw-r--r--sys-apps/openrc/openrc-0.4.1.ebuild30
2 files changed, 32 insertions, 4 deletions
diff --git a/sys-apps/openrc/ChangeLog b/sys-apps/openrc/ChangeLog
index 7897c70fa93b..599d689dddbc 100644
--- a/sys-apps/openrc/ChangeLog
+++ b/sys-apps/openrc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/openrc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.51 2008/12/23 23:22:19 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.52 2008/12/24 06:59:46 zzam Exp $
+
+ 24 Dec 2008; Matthias Schwarzott <zzam@gentoo.org> openrc-0.4.1.ebuild:
+ Fix patches directory, bug #252340. Update ebuild to match the old 0.4.0
+ ebuild.
*openrc-0.4.1 (23 Dec 2008)
diff --git a/sys-apps/openrc/openrc-0.4.1.ebuild b/sys-apps/openrc/openrc-0.4.1.ebuild
index fb798ac4d421..a364894648da 100644
--- a/sys-apps/openrc/openrc-0.4.1.ebuild
+++ b/sys-apps/openrc/openrc-0.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.4.1.ebuild,v 1.1 2008/12/23 23:22:19 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.4.1.ebuild,v 1.2 2008/12/24 06:59:46 zzam Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -31,7 +31,7 @@ RDEPEND="virtual/init
pam? ( virtual/pam )
>=sys-apps/baselayout-2.0.0
!<sys-fs/udev-133
- !<sys-fs/sysvinit-2.86-r11"
+ !<sys-apps/sysvinit-2.86-r11"
DEPEND="${RDEPEND}
virtual/os-headers"
@@ -63,7 +63,7 @@ src_unpack() {
unpack ${A}
fi
cd "${S}"
- epatch "${FILESDIR}"/0.4.1/*.patch
+ epatch "${FILESDIR}"/0.4.0/*.patch
}
src_compile() {
@@ -174,6 +174,25 @@ pkg_preinst() {
# termencoding was added in 0.2.1 and needed in boot
has_version ">=sys-apps/openrc-0.2.1" || add_boot_init termencoding
+ # openrc-0.4.0 no longer loads the udev addon
+ enable_udev=0
+ if [[ ! -e "${ROOT}"/etc/runlevels/sysinit/udev ]] && \
+ [[ -e "${ROOT}"/etc/init.d/udev ]] && \
+ ! has_version ">=sys-apps/openrc-0.4.0"
+ then
+ # make sure udev is in sysinit if it was enabled before
+ local rc_devices=$(
+ [[ -f /etc/rc.conf ]] && source /etc/rc.conf
+ [[ -f /etc/conf.d/rc ]] && source /etc/conf.d/rc
+ echo "${rc_devices:-${RC_DEVICES:-auto}}"
+ )
+ case ${rc_devices} in
+ udev|auto)
+ enable_udev=1
+ ;;
+ esac
+ fi
+
# skip remaining migration if we already have openrc installed
has_version sys-apps/openrc && return 0
@@ -272,6 +291,11 @@ pkg_postinst() {
fi
fi
+ if [[ "$enable_udev" = 1 ]]; then
+ elog "Auto adding udev init script to the sysinit runlevel"
+ ln -sf /etc/init.d/udev "${ROOT}"/etc/runlevels/sysinit/udev
+ fi
+
# update the dependency tree bug #224171
[[ "${ROOT}" = "/" ]] && "${ROOT}/${LIBDIR}"/rc/bin/rc-depend -u