summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2002-10-10 12:13:18 +0000
committerMichael Imhof <tantive@gentoo.org>2002-10-10 12:13:18 +0000
commit7b8f08190a211e16b6160172ee33d03153fd285c (patch)
treed41979c54f8c38be0ca9ab717aa066a36063def7 /sys-apps/openmosix-user
parentMasked openmosix-user-0.2.4-r2 (diff)
downloadgentoo-2-7b8f08190a211e16b6160172ee33d03153fd285c.tar.gz
gentoo-2-7b8f08190a211e16b6160172ee33d03153fd285c.tar.bz2
gentoo-2-7b8f08190a211e16b6160172ee33d03153fd285c.zip
Enabled the autodiscovery daemon (omdiscd).
Diffstat (limited to 'sys-apps/openmosix-user')
-rw-r--r--sys-apps/openmosix-user/ChangeLog7
-rw-r--r--sys-apps/openmosix-user/files/digest-openmosix-user-0.2.4-r21
-rw-r--r--sys-apps/openmosix-user/openmosix-user-0.2.4-r2.ebuild87
3 files changed, 94 insertions, 1 deletions
diff --git a/sys-apps/openmosix-user/ChangeLog b/sys-apps/openmosix-user/ChangeLog
index 4d655539b767..f9ca5c2e3d38 100644
--- a/sys-apps/openmosix-user/ChangeLog
+++ b/sys-apps/openmosix-user/ChangeLog
@@ -1,8 +1,13 @@
# ChangeLog for sys-apps/openmosix-user
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openmosix-user/ChangeLog,v 1.5 2002/08/30 11:42:30 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openmosix-user/ChangeLog,v 1.6 2002/10/10 12:13:18 tantive Exp $
+* openmosix-user-0.2.4-r2 (10 Oct 2002)
+
+ 10 Oct 2002; Michael Imhof <tantive@gentoo.org>
+ Enabled the autodiscovery daemon (omdiscd).
+
* openmosix-user-0.2.4-r1 (30 Aug 2002)
30 Aug 2002; Michael Imhof <tantive@gentoo.org>
diff --git a/sys-apps/openmosix-user/files/digest-openmosix-user-0.2.4-r2 b/sys-apps/openmosix-user/files/digest-openmosix-user-0.2.4-r2
new file mode 100644
index 000000000000..85f88e730ce3
--- /dev/null
+++ b/sys-apps/openmosix-user/files/digest-openmosix-user-0.2.4-r2
@@ -0,0 +1 @@
+MD5 2e4e630a391900b331323bffea5c5547 openMosixUserland-0.2.4.tgz 65494
diff --git a/sys-apps/openmosix-user/openmosix-user-0.2.4-r2.ebuild b/sys-apps/openmosix-user/openmosix-user-0.2.4-r2.ebuild
new file mode 100644
index 000000000000..4991573a6855
--- /dev/null
+++ b/sys-apps/openmosix-user/openmosix-user-0.2.4-r2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openmosix-user/openmosix-user-0.2.4-r2.ebuild,v 1.1 2002/10/10 12:13:18 tantive Exp $
+
+S=${WORKDIR}/openMosixUserland-${PV}
+DESCRIPTION="User-land utilities for openMosix process migration (clustering) software"
+SRC_URI="mirror://sourceforge/openmosix/openMosixUserland-${PV}.tgz"
+HOMEPAGE="http://www.openmosix.com"
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-kernel/openmosix-sources-2.4.18"
+RDEPEND="${DEPEND}
+ sys-apps/findutils
+ sys-devel/perl"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 -ppc -sparc -sparc64 -alpha"
+
+
+pkg_setup() {
+ if [ -z "`readlink /usr/src/linux|grep openmosix`" ]; then
+ eerror
+ eerror "Your linux kernel sources do not appear to be openmosix,"
+ eerror "please check your /usr/src/linux symlink."
+ eerror
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cat Makefile | sed s/DIRS.*=/DIRS=autodiscovery/g > Makefile
+ cat > configuration << EOF
+
+OPENMOSIX=/usr/src/linux
+PROCDIR=/proc/hpc
+MONNAME=mmon
+CC=gcc
+INSTALLDIR=/usr
+CFLAGS=-I/m/include -I./ -I/usr/include -I\$(OPENMOSIX)/include ${CFLAGS}
+INSTALL=/usr/bin/install
+EOF
+}
+
+src_compile() {
+ cd ${S}
+ make clean build
+}
+
+src_install () {
+ dodir /usr/lib
+ dodir /usr/sbin
+ dodir /usr/include
+ dodir /usr/share/include
+ dodir /usr/bin
+ dodir /bin
+ ln -s /usr/bin/migrate ${D}/bin/migrate
+ ln -s /usr/bin/mmon ${D}/bin/mmon
+ ln -s /usr/bin/mosctl ${D}/bin/mosctl
+ ln -s /usr/bin/mosrun ${D}/bin/mosrun
+ dodir /usr/share/man/man1
+ make INSTALLBASEDIR=${D}usr \
+ INSTALLMANDIR=${D}usr/share/man \
+ INSTALLEXTRADIR=${D}usr/share \
+ DESTDIR=${D} \
+ INSTALLDIR=${D}usr \
+ install
+
+ dodoc COPYING README
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/openmosix.init openmosix
+ insinto /etc
+ #stub mosix.map file
+ doins ${FILESDIR}/mosix.map
+
+}
+
+pkg_postinst() {
+ einfo
+ einfo " To complete openMosix installation, edit /etc/mosix.map and then type:
+ einfo "# rc-update add openmosix default
+ einfo " ...to add openMosix to the default runlevel. This particular version of"
+ einfo " openmosix-user has been designed to work with the linux-2.4.18-openmosix-r1"
+ einfo " or later kernel (>=sys-kernel/openmosix-sources-2.4.18)"
+ einfo
+}