summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-04 00:13:06 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-04 00:13:06 +0000
commit33f2483d1b1731933334716f9270db1d52b17fd7 (patch)
tree1372d9327fe57e41ee5a05c194b203c2458ee9bf /sys-apps/modutils
parentuse /usr/lib/misc instead of /usr/libexec (diff)
downloadgentoo-2-33f2483d1b1731933334716f9270db1d52b17fd7.tar.gz
gentoo-2-33f2483d1b1731933334716f9270db1d52b17fd7.tar.bz2
gentoo-2-33f2483d1b1731933334716f9270db1d52b17fd7.zip
arm/hppa/ia64/s390/x86 stable
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-apps/modutils')
-rw-r--r--sys-apps/modutils/modutils-2.4.27.ebuild28
1 files changed, 7 insertions, 21 deletions
diff --git a/sys-apps/modutils/modutils-2.4.27.ebuild b/sys-apps/modutils/modutils-2.4.27.ebuild
index dcab236ceda6..8eb6c3124b6c 100644
--- a/sys-apps/modutils/modutils-2.4.27.ebuild
+++ b/sys-apps/modutils/modutils-2.4.27.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.4.27.ebuild,v 1.3 2004/12/23 23:16:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.4.27.ebuild,v 1.4 2005/02/04 00:13:06 vapier Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="mirror://kernel/linux/utils/kernel/${PN}/v2.4/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa -amd64 ~ia64 ~ppc64 ~s390"
+KEYWORDS="~alpha -amd64 arm hppa ia64 ~mips ~ppc ~ppc64 s390 sh ~sparc x86"
IUSE=""
DEPEND="virtual/libc
@@ -27,30 +27,16 @@ src_unpack() {
}
src_compile() {
- local myconf=
- local mymake=
-
- # see bug #3897 ... we need insmod static, as libz.so is in /usr/lib
- #
- # Final resolution ... dont make it link against zlib, as the static
- # version do not want to autoload modules :(
- myconf="${myconf} --disable-zlib"
-
- [ ${ARCH} = "hppa" ] && mymake="ARCH=hppa"
-
econf \
--prefix=/ \
--disable-strip \
--enable-insmod-static \
- ${myconf} || die "./configure failed"
-
- emake ${mymake} || die "emake failed"
+ --disable-zlib \
+ || die "./configure failed"
+ emake || die "emake failed"
}
src_install() {
- local mymake=
- [ ${ARCH} = "hppa" ] && mymake="ARCH=hppa"
- einstall prefix="${D}" ${mymake} || die "make install failed"
-
+ einstall prefix="${D}" || die "make install failed"
dodoc CREDITS ChangeLog NEWS README TODO
}