summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-03-13 21:40:39 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-03-13 21:40:39 +0000
commit2029db75e7157f5eba9404490e6f20d377ba6c1d (patch)
tree10467c8f3e35185e198fe4c61b3aeca8489bd166 /sys-apps/modutils/modutils-2.4.23.ebuild
parentremoved crusty ebuilds (diff)
downloadgentoo-2-2029db75e7157f5eba9404490e6f20d377ba6c1d.tar.gz
gentoo-2-2029db75e7157f5eba9404490e6f20d377ba6c1d.tar.bz2
gentoo-2-2029db75e7157f5eba9404490e6f20d377ba6c1d.zip
bump
Diffstat (limited to 'sys-apps/modutils/modutils-2.4.23.ebuild')
-rw-r--r--sys-apps/modutils/modutils-2.4.23.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-apps/modutils/modutils-2.4.23.ebuild b/sys-apps/modutils/modutils-2.4.23.ebuild
new file mode 100644
index 000000000000..82fe34eb44b7
--- /dev/null
+++ b/sys-apps/modutils/modutils-2.4.23.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.4.23.ebuild,v 1.1 2003/03/13 21:40:39 lostlogic Exp $
+
+inherit flag-o-matic
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Standard kernel module utilities"
+SRC_URI="http://www.kernel.org/pub/linux/utils/kernel/${PN}/v2.4/${P}.tar.bz2"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/modutils/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~arm"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ filter-flags -fPIC
+
+ myconf=""
+ # see bug #3897 ... we need insmod static, as libz.so is in /usr/lib
+ #
+ # Final resolution ... dont make it link against zlib, as the static
+ # version do not want to autoload modules :(
+ myconf="${myconf} --disable-zlib"
+
+ econf \
+ --prefix=/ \
+ --disable-strip \
+ --enable-insmod-static \
+ ${myconf} || die "./configure failed"
+ if [ ${ARCH} = "hppa" ]
+ then
+ mymake="ARCH=hppa"
+ fi
+
+ emake ${mymake} || die "emake failed"
+}
+
+src_install() {
+ if [ ${ARCH} = "hppa" ]
+ then
+ mymake="ARCH=hppa"
+ fi
+ einstall prefix="${D}" ${mymake} || die "make install failed"
+
+ dodoc COPYING CREDITS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ echo
+ einfo "If you get problems after update related to missing"
+ einfo "\"keybdev\" module, please recompile your kernel."
+ echo
+}
+