summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-15 04:37:22 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-15 04:37:22 +0000
commitf7f8c3b79eea0905e81ac4b4b9d5132623262351 (patch)
treef66d1f1198c6ab5e3b60fe6a3adb40f241fba52e /sys-apps/module-init-tools
parentFix description by inheriting before setting DESCRIPTION (diff)
downloadgentoo-2-f7f8c3b79eea0905e81ac4b4b9d5132623262351.tar.gz
gentoo-2-f7f8c3b79eea0905e81ac4b4b9d5132623262351.tar.bz2
gentoo-2-f7f8c3b79eea0905e81ac4b4b9d5132623262351.zip
Version bump. Add docbook2man dependency since all pre-generated man pages were removed. Set empty RDEPEND.
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/module-init-tools')
-rw-r--r--sys-apps/module-init-tools/ChangeLog8
-rw-r--r--sys-apps/module-init-tools/module-init-tools-3.16.ebuild100
2 files changed, 107 insertions, 1 deletions
diff --git a/sys-apps/module-init-tools/ChangeLog b/sys-apps/module-init-tools/ChangeLog
index d2419a669aee..b05ae4da6630 100644
--- a/sys-apps/module-init-tools/ChangeLog
+++ b/sys-apps/module-init-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/module-init-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/ChangeLog,v 1.171 2011/06/13 16:06:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/ChangeLog,v 1.172 2011/06/15 04:37:22 jer Exp $
+
+*module-init-tools-3.16 (15 Jun 2011)
+
+ 15 Jun 2011; Jeroen Roovers <jer@gentoo.org> +module-init-tools-3.16.ebuild:
+ Version bump. Add docbook2man dependency since all pre-generated man pages
+ were removed. Set empty RDEPEND.
13 Jun 2011; Raúl Porcel <armin76@gentoo.org>
module-init-tools-3.12-r1.ebuild:
diff --git a/sys-apps/module-init-tools/module-init-tools-3.16.ebuild b/sys-apps/module-init-tools/module-init-tools-3.16.ebuild
new file mode 100644
index 000000000000..00f5c75db970
--- /dev/null
+++ b/sys-apps/module-init-tools/module-init-tools-3.16.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/module-init-tools-3.16.ebuild,v 1.1 2011/06/15 04:37:22 jer Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="tools for managing linux kernel modules"
+HOMEPAGE="http://modules.wiki.kernel.org/"
+SRC_URI="mirror://kernel/linux/utils/kernel/module-init-tools/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+RESTRICT="test"
+
+DEPEND="sys-libs/zlib
+ !<sys-apps/baselayout-2.0.1
+ !sys-apps/modutils
+ app-text/docbook-sgml-utils"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -rf tests/build # punt precompiled objects
+}
+
+src_compile() {
+ mkdir build && cd build #290207
+ use static && append-ldflags -static
+ ECONF_SOURCE=.. \
+ econf \
+ --prefix=/ \
+ --enable-zlib \
+ --enable-zlib-dynamic \
+ --disable-static-utils
+ emake || die
+}
+
+src_test() {
+ # this manually runs configure and stuff, so ignore it
+ ./tests/runtests -v || die
+}
+
+src_install() {
+ emake -C build install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ into /
+ newsbin "${FILESDIR}"/update-modules-3.5.sh update-modules || die
+ doman "${FILESDIR}"/update-modules.8 || die
+
+ cat <<-EOF > "${T}"/usb-load-ehci-first.conf
+ install ohci_hcd /sbin/modprobe ehci_hcd ; /sbin/modprobe --ignore-install ohci_hcd \$CMDLINE_OPTS
+ install uhci_hcd /sbin/modprobe ehci_hcd ; /sbin/modprobe --ignore-install uhci_hcd \$CMDLINE_OPTS
+ EOF
+
+ insinto /etc/modprobe.d
+ doins "${T}"/usb-load-ehci-first.conf || die #260139
+}
+
+pkg_postinst() {
+ # cheat to keep users happy
+ if grep -qs modules-update "${ROOT}"/etc/init.d/modules ; then
+ sed -i 's:modules-update:update-modules:' "${ROOT}"/etc/init.d/modules
+ fi
+
+ # For files that were upgraded but not renamed via their ebuild to
+ # have a proper .conf extension, rename them so etc-update tools can
+ # take care of things. #274942
+ local i f cfg
+ eshopts_push -s nullglob
+ for f in "${ROOT}"etc/modprobe.d/* ; do
+ # The .conf files need no upgrading unless a non-.conf exists,
+ # so skip this until later ...
+ [[ ${f} == *.conf ]] && continue
+ # If a .conf doesn't exist, then a package needs updating, or
+ # the user created it, or it's orphaned. Either way, we don't
+ # really know, so leave it alone.
+ [[ ! -f ${f}.conf ]] && continue
+
+ i=0
+ while :; do
+ cfg=$(printf "%s/._cfg%04d_%s.conf" "${f%/*}" ${i} "${f##*/}")
+ [[ ! -e ${cfg} ]] && break
+ ((i++))
+ done
+ elog "Updating ${f}; please run 'etc-update'"
+ mv "${f}.conf" "${cfg}"
+ mv "${f}" "${f}.conf"
+ done
+ # Whine about any non-.conf files that are left
+ for f in "${ROOT}"etc/modprobe.d/* ; do
+ [[ ${f} == *.conf ]] && continue
+ ewarn "The '${f}' file needs to be upgraded to end with a '.conf'."
+ ewarn "Either upgrade the package that owns it, or manually rename it."
+ done
+ eshopts_pop
+}