summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-14 15:28:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-14 15:28:49 +0000
commit227e738f6a883f5f900e0f0b5aee11a83403cb8b (patch)
treed14f0e944ced04eb159c78ef95b247272b0c7370 /sys-apps/mkinitrd
parentLet CFLAGS be respected during src_compile rather than being set in stone. (diff)
downloadgentoo-2-227e738f6a883f5f900e0f0b5aee11a83403cb8b.tar.gz
gentoo-2-227e738f6a883f5f900e0f0b5aee11a83403cb8b.tar.bz2
gentoo-2-227e738f6a883f5f900e0f0b5aee11a83403cb8b.zip
Let CFLAGS be respected during src_compile rather than being set in stone.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'sys-apps/mkinitrd')
-rw-r--r--sys-apps/mkinitrd/ChangeLog8
-rw-r--r--sys-apps/mkinitrd/mkinitrd-4.2.0.3.ebuild17
2 files changed, 14 insertions, 11 deletions
diff --git a/sys-apps/mkinitrd/ChangeLog b/sys-apps/mkinitrd/ChangeLog
index 7f913dc3f7f7..b9bf61e6815e 100644
--- a/sys-apps/mkinitrd/ChangeLog
+++ b/sys-apps/mkinitrd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/mkinitrd
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mkinitrd/ChangeLog,v 1.22 2007/02/22 01:14:38 jokey Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mkinitrd/ChangeLog,v 1.23 2008/10/14 15:28:49 flameeyes Exp $
+
+ 14 Oct 2008; Diego Pettenò <flameeyes@gentoo.org>
+ mkinitrd-4.2.0.3.ebuild:
+ Let CFLAGS be respected during src_compile rather than being set in stone.
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sys-apps/mkinitrd/mkinitrd-4.2.0.3.ebuild b/sys-apps/mkinitrd/mkinitrd-4.2.0.3.ebuild
index f5044eb96544..83733ad1aa48 100644
--- a/sys-apps/mkinitrd/mkinitrd-4.2.0.3.ebuild
+++ b/sys-apps/mkinitrd/mkinitrd-4.2.0.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mkinitrd/mkinitrd-4.2.0.3.ebuild,v 1.2 2005/08/29 01:56:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mkinitrd/mkinitrd-4.2.0.3.ebuild,v 1.3 2008/10/14 15:28:49 flameeyes Exp $
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="Tools for creating initrd images"
HOMEPAGE="http://www.redhat.com/"
@@ -24,16 +24,15 @@ src_unpack() {
# bug 29694 -- Change vgwrapper to static vgscan and vgchange
epatch "${FILESDIR}"/mkinitrd-lvm_statics.diff
sed -i \
- -e "/^CFLAGS/s: -Werror : ${CFLAGS} :" \
- -e "/^LDFLAGS/s:$: ${LDFLAGS}:" \
+ -e '/^CFLAGS/s: -Werror::' \
+ -e '/^CFLAGS/s: -g::' \
+ -e '/^CFLAGS/s:=:+=:' \
grubby/Makefile nash/Makefile
}
src_compile() {
- cd "${S}"/nash
- emake || die "nash compile failed."
- cd "${S}"/grubby
- emake || die "grubby compile failed."
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" -C nash || die "nash compile failed."
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" -C grubby|| die "grubby compile failed."
}
src_install() {