summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-10-25 23:09:00 +0000
committerMike Frysinger <vapier@gentoo.org>2008-10-25 23:09:00 +0000
commit5ab758ce60b6cea568752a9a59b689c96954b347 (patch)
tree2aa465234fe29f4ec065677c567e4299a73d5dd4 /sys-apps/man-db
parentold (diff)
downloadgentoo-2-5ab758ce60b6cea568752a9a59b689c96954b347.tar.gz
gentoo-2-5ab758ce60b6cea568752a9a59b689c96954b347.tar.bz2
gentoo-2-5ab758ce60b6cea568752a9a59b689c96954b347.zip
Version bump.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'sys-apps/man-db')
-rw-r--r--sys-apps/man-db/ChangeLog7
-rw-r--r--sys-apps/man-db/man-db-2.5.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/sys-apps/man-db/ChangeLog b/sys-apps/man-db/ChangeLog
index edc0ff965331..5a86b2070d71 100644
--- a/sys-apps/man-db/ChangeLog
+++ b/sys-apps/man-db/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/man-db
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.4 2008/02/24 18:25:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.5 2008/10/25 23:09:00 vapier Exp $
+
+*man-db-2.5.2 (25 Oct 2008)
+
+ 25 Oct 2008; Mike Frysinger <vapier@gentoo.org> +man-db-2.5.2.ebuild:
+ Version bump.
*man-db-2.5.1 (24 Feb 2008)
diff --git a/sys-apps/man-db/man-db-2.5.2.ebuild b/sys-apps/man-db/man-db-2.5.2.ebuild
new file mode 100644
index 000000000000..e286f9b50e9d
--- /dev/null
+++ b/sys-apps/man-db/man-db-2.5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.5.2.ebuild,v 1.1 2008/10/25 23:09:00 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
+HOMEPAGE="http://www.nongnu.org/man-db/"
+SRC_URI="http://download.savannah.nongnu.org/releases/man-db/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="berkdb gdbm nls"
+
+RDEPEND="berkdb? ( sys-libs/db )
+ gdbm? ( sys-libs/gdbm )
+ !berkdb? ( !gdbm? ( sys-libs/gdbm ) )
+ !sys-apps/man"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+PROVIDE="virtual/man"
+
+pkg_setup() {
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+}
+
+src_compile() {
+ local db="gdbm"
+ use berkdb && ! use gdbm && db="db"
+ econf \
+ --with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x" \
+ $(use_enable nls) \
+ --with-db=${db} \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc README docs/{ChangeLog,HACKING,NEWS,TODO}
+}