summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-04-10 00:39:41 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-04-10 00:39:41 +0000
commitca1c421c71f14ae7bfb442774a2c23c88a8a39b7 (patch)
tree41330ee2e3b8ffda9c5df836e9a00dc81b2a7197 /sys-apps/ifd-gempc
parentRev bump for bug #265580. (diff)
downloadgentoo-2-ca1c421c71f14ae7bfb442774a2c23c88a8a39b7.tar.gz
gentoo-2-ca1c421c71f14ae7bfb442774a2c23c88a8a39b7.tar.bz2
gentoo-2-ca1c421c71f14ae7bfb442774a2c23c88a8a39b7.zip
Version bump.
(Portage version: 13308-svn/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/ifd-gempc')
-rw-r--r--sys-apps/ifd-gempc/ChangeLog11
-rw-r--r--sys-apps/ifd-gempc/files/ifd-gempc-1.0.4-respect_LDFLAGS.patch52
-rw-r--r--sys-apps/ifd-gempc/files/reader.conf2
-rw-r--r--sys-apps/ifd-gempc/ifd-gempc-1.0.3.ebuild6
-rw-r--r--sys-apps/ifd-gempc/ifd-gempc-1.0.4.ebuild57
5 files changed, 122 insertions, 6 deletions
diff --git a/sys-apps/ifd-gempc/ChangeLog b/sys-apps/ifd-gempc/ChangeLog
index 9f96f2f3a6f8..3f6c6703ff51 100644
--- a/sys-apps/ifd-gempc/ChangeLog
+++ b/sys-apps/ifd-gempc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/ifd-gempc
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ifd-gempc/ChangeLog,v 1.12 2007/11/11 06:25:53 alonbl Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ifd-gempc/ChangeLog,v 1.13 2009/04/10 00:39:41 arfrever Exp $
+
+*ifd-gempc-1.0.4 (10 Apr 2009)
+
+ 10 Apr 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +files/ifd-gempc-1.0.4-respect_LDFLAGS.patch, files/reader.conf,
+ ifd-gempc-1.0.3.ebuild, +ifd-gempc-1.0.4.ebuild:
+ Version bump.
11 Nov 2007; Alon Bar-Lev <alonbl@gentoo.org> ifd-gempc-1.0.3.ebuild:
Cleanups
diff --git a/sys-apps/ifd-gempc/files/ifd-gempc-1.0.4-respect_LDFLAGS.patch b/sys-apps/ifd-gempc/files/ifd-gempc-1.0.4-respect_LDFLAGS.patch
new file mode 100644
index 000000000000..c8f2f7ad326a
--- /dev/null
+++ b/sys-apps/ifd-gempc/files/ifd-gempc-1.0.4-respect_LDFLAGS.patch
@@ -0,0 +1,52 @@
+--- GemPC410/Makefile
++++ GemPC410/Makefile
+@@ -40,7 +40,7 @@
+
+ libGemPC410.so: common $(targets)
+ rm -f $@
+- $(CC) -shared $(targets) $(common_targets) -o $@
++ $(CC) -shared $(LDFLAGS) $(targets) $(common_targets) -o $@
+ chmod -x $@
+ mv $@ $@.$(version)
+
+--- GemPC430/Makefile
++++ GemPC430/Makefile
+@@ -5,7 +5,7 @@
+ # set these paths to where you installed pcsc-lite and libusb
+ # you can use more than one path in each variable
+ INCS = -I/usr/local/include `pkg-config libpcsclite --cflags`
+-LIBS = -L/usr/local/lib
++LIBS = -L/usr/local/lib -lusb
+ INSTALL_DIR = $(DESTDIR)`pkg-config libpcsclite --variable=usbdropdir`
+
+ # use a correct default CFLAGS
+@@ -14,7 +14,6 @@
+ else
+ CFLAGS += -Wall -fPIC -I. -I../common -DGEMPC=430 $(INCS)
+ endif
+-LDFLAGS = $(LIBS) -lusb
+
+ # /home/rousseau/sc/pcsc/i/ifd-gempc-0.5.10/GemPC410 -> 0.5.10
+ version=$(shell expr `pwd` : '.*-\([0-9.]*\)')
+@@ -27,7 +26,7 @@
+
+ check: check_stamp
+ check_stamp:
+- CFLAGS="$(INCS)" LDFLAGS="$(LIBS)" ../check 430
++ CFLAGS="$(INCS)" LIBS="$(LIBS)" ../check 430
+ touch check_stamp
+
+ expert: ifd-GemPC430 libGemPC430.so
+@@ -36,10 +35,10 @@
+ $(MAKE) -C ../common CFLAGS="$(CFLAGS) -I../GemPC430" all
+
+ ifd-GemPC430: common $(targets) main.o ../common/GCdebug.o
+- $(CC) $(LDFLAGS) -o $@ $(targets) $(common_targets) main.o ../common/GCdebug.o
++ $(CC) $(LDFLAGS) -o $@ $(targets) $(common_targets) main.o ../common/GCdebug.o $(LIBS)
+
+ libGemPC430.so: common $(targets)
+- $(CC) -shared $(LDFLAGS) -o $@ $(targets) $(common_targets)
++ $(CC) -shared $(LDFLAGS) -o $@ $(targets) $(common_targets) $(LIBS)
+
+ main.o: ../GemPC410/main.c
+ $(CC) $(CFLAGS) -c -o $@ $^
diff --git a/sys-apps/ifd-gempc/files/reader.conf b/sys-apps/ifd-gempc/files/reader.conf
index 86e99bbab795..74de4a1a60ca 100644
--- a/sys-apps/ifd-gempc/files/reader.conf
+++ b/sys-apps/ifd-gempc/files/reader.conf
@@ -5,7 +5,7 @@
FRIENDLYNAME "GemPC410"
# Update the following to the right COM port
DEVICENAME /dev/null
-LIBPATH %PCSC_DRIVERS_DIR%/serial/libGemPC410.so.1.0.1
+LIBPATH %PCSC_DRIVERS_DIR%/serial/%libGemPC410%
CHANNELID 1
# End of file
diff --git a/sys-apps/ifd-gempc/ifd-gempc-1.0.3.ebuild b/sys-apps/ifd-gempc/ifd-gempc-1.0.3.ebuild
index af58980eee9e..893d5bf3ae7f 100644
--- a/sys-apps/ifd-gempc/ifd-gempc-1.0.3.ebuild
+++ b/sys-apps/ifd-gempc/ifd-gempc-1.0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ifd-gempc/ifd-gempc-1.0.3.ebuild,v 1.2 2007/11/11 06:25:53 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ifd-gempc/ifd-gempc-1.0.3.ebuild,v 1.3 2009/04/10 00:39:41 arfrever Exp $
inherit eutils toolchain-funcs
@@ -28,7 +28,7 @@ src_install () {
dodir "$(dirname "${conf}")"
insinto "$(dirname "${conf}")"
newins "${FILESDIR}/reader.conf" "$(basename "${conf}")"
- sed -i "s#%PCSC_DRIVERS_DIR%#${pcscdir}#g" "${D}/${conf}"
+ sed -e "s:%PCSC_DRIVERS_DIR%:${pcscdir}:g" -e "s:%libGemPC410%:libGemPC410.so.${PV}:g" -i "${D}${conf}"
einfo "NOTICE:"
einfo "1. if you are using GemPC410 modify ${conf}"
diff --git a/sys-apps/ifd-gempc/ifd-gempc-1.0.4.ebuild b/sys-apps/ifd-gempc/ifd-gempc-1.0.4.ebuild
new file mode 100644
index 000000000000..b8d5f0bbfb6a
--- /dev/null
+++ b/sys-apps/ifd-gempc/ifd-gempc-1.0.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ifd-gempc/ifd-gempc-1.0.4.ebuild,v 1.1 2009/04/10 00:39:41 arfrever Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="GemCore based PC/SC reader drivers for pcsc-lite"
+HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/ifd-GemPC"
+LICENSE="GPL-2 BSD"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+SRC_URI="http://ludovic.rousseau.free.fr/softwares/ifd-GemPC/${P}.tar.gz"
+IUSE=""
+RDEPEND=">=sys-apps/pcsc-lite-1.2.9_beta7
+ >=dev-libs/libusb-0.1.10a"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-respect_LDFLAGS.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install () {
+ local pcscdir="$(pkg-config --variable=usbdropdir libpcsclite)"
+ local conf="/etc/reader.conf.d/${PN}.conf"
+ emake install CC="$(tc-getCC)" DESTDIR="${D}" || die
+ dodoc README*
+ dodir "$(dirname "${conf}")"
+ insinto "$(dirname "${conf}")"
+ newins "${FILESDIR}/reader.conf" "$(basename "${conf}")"
+ sed -e "s:%PCSC_DRIVERS_DIR%:${pcscdir}:g" -e "s:%libGemPC410%:libGemPC410.so.${PV}:g" -i "${D}${conf}"
+
+ einfo "NOTICE:"
+ einfo "1. if you are using GemPC410 modify ${conf}"
+ einfo "2. run update-reader.conf, yes this is a command..."
+ einfo "3. restart pcscd"
+}
+
+pkg_postrm() {
+ #
+ # Without this, pcscd will not start next time.
+ #
+ local conf="/etc/reader.conf.d/${PN}.conf"
+ if ! [ -f "$(grep LIBPATH "${conf}" | sed 's/LIBPATH *//' | sed 's/ *$//g' | head -n 1)" ]; then
+ rm "${conf}"
+ update-reader.conf
+ einfo "NOTICE:"
+ einfo "You need to restart pcscd"
+ fi
+}