summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-02-01 06:58:57 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-02-01 06:58:57 +0000
commitc8e333dee0635787b6af0f9de2e4e8438695e4c2 (patch)
tree92a14c7a6fb5ed23b62c1488c255fc0b8d414c01 /sys-apps/hwinfo
parentVersion bump with new functionality. (diff)
downloadgentoo-2-c8e333dee0635787b6af0f9de2e4e8438695e4c2.tar.gz
gentoo-2-c8e333dee0635787b6af0f9de2e4e8438695e4c2.tar.bz2
gentoo-2-c8e333dee0635787b6af0f9de2e4e8438695e4c2.zip
Version bump per bug #266745. Avoid kernel header issues per bug #236449. I know the last part of the build is forced non-parallel. It is not trivially fixable. Tell repoman to get lost.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/hwinfo')
-rw-r--r--sys-apps/hwinfo/ChangeLog12
-rw-r--r--sys-apps/hwinfo/files/hwinfo-16.0-parallel-fixes.patch42
-rw-r--r--sys-apps/hwinfo/hwinfo-16.0.ebuild71
3 files changed, 123 insertions, 2 deletions
diff --git a/sys-apps/hwinfo/ChangeLog b/sys-apps/hwinfo/ChangeLog
index 0c6fd6bda63c..6f430aef82af 100644
--- a/sys-apps/hwinfo/ChangeLog
+++ b/sys-apps/hwinfo/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/hwinfo
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwinfo/ChangeLog,v 1.10 2008/07/16 12:59:19 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwinfo/ChangeLog,v 1.11 2010/02/01 06:58:56 robbat2 Exp $
+
+*hwinfo-16.0 (01 Feb 2010)
+
+ 01 Feb 2010; Robin H. Johnson <robbat2@gentoo.org> +hwinfo-16.0.ebuild,
+ +files/hwinfo-16.0-parallel-fixes.patch:
+ Version bump per bug #266745. Avoid kernel header issues per bug #236449.
+ I know the last part of the build is forced non-parallel. It is not
+ trivially fixable. Tell repoman to get lost.
16 Jul 2008; nixnut <nixnut@gentoo.org> hwinfo-13.28.ebuild:
Stable on ppc wrt bug 231667
diff --git a/sys-apps/hwinfo/files/hwinfo-16.0-parallel-fixes.patch b/sys-apps/hwinfo/files/hwinfo-16.0-parallel-fixes.patch
new file mode 100644
index 000000000000..221f34ca8a9a
--- /dev/null
+++ b/sys-apps/hwinfo/files/hwinfo-16.0-parallel-fixes.patch
@@ -0,0 +1,42 @@
+diff -Nuar hwinfo-16.0.orig/src/ids/Makefile hwinfo-16.0/src/ids/Makefile
+--- hwinfo-16.0.orig/src/ids/Makefile 2009-05-12 03:10:34.000000000 -0700
++++ hwinfo-16.0/src/ids/Makefile 2009-07-03 13:55:42.522438453 -0700
+@@ -55,8 +55,11 @@
+
+ hd_ids.c: hd_ids.h hd_ids_tiny.h
+
+-hd_ids.h hd.ids: check_hd $(IDFILES)
++hd_ids.h hd.ids: build_ids
++
++build_ids: check_hd $(IDFILES)
+ ./check_hd --check --sort --cfile hd_ids.h $(IDFILES)
++ touch build_ids
+
+ hd_ids_tiny.h: check_hd hd.ids
+ ./check_hd --mini --cfile hd_ids_tiny.h --log=hd_tiny.log --out=hd_tiny.ids hd.ids
+diff -Nuar hwinfo-16.0.orig/src/isdn/cdb/Makefile hwinfo-16.0/src/isdn/cdb/Makefile
+--- hwinfo-16.0.orig/src/isdn/cdb/Makefile 2009-05-12 03:10:34.000000000 -0700
++++ hwinfo-16.0/src/isdn/cdb/Makefile 2009-07-03 14:13:54.336372459 -0700
+@@ -12,8 +12,9 @@
+ fi
+
+ isdn_cdb.h: isdn_cdb ISDN.CDB.txt
+- rm -f isdn_cdb.h
+- ./isdn_cdb ISDN.CDB.txt isdn_cdb.h
++ rm -f $@
++ ./isdn_cdb ISDN.CDB.txt $@.tmp
++ mv $@.tmp $@
+
+ lex.yy.c: isdn_cdb.lex
+ lex isdn_cdb.lex
+@@ -29,5 +30,8 @@
+ mk_isdnhwdb.o: mk_isdnhwdb.c cdb_read.h lex.yy.c
+
+ ISDN.CDB.hwdb: mk_isdnhwdb ISDN.CDB.txt
+- rm -f ISDN.CDB.hwdb
+- ./mk_isdnhwdb ISDN.CDB.txt ISDN.CDB.hwdb
++ rm -f $@
++ ./mk_isdnhwdb ISDN.CDB.txt $@.tmp
++ mv $@.tmp $@
++
++OBJS += isdn_cdb.h ISDN.CDB.hwdb
diff --git a/sys-apps/hwinfo/hwinfo-16.0.ebuild b/sys-apps/hwinfo/hwinfo-16.0.ebuild
new file mode 100644
index 000000000000..74ef918c6371
--- /dev/null
+++ b/sys-apps/hwinfo/hwinfo-16.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwinfo/hwinfo-16.0.ebuild,v 1.1 2010/02/01 06:58:56 robbat2 Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="hwinfo is the hardware detection tool used in SuSE Linux."
+HOMEPAGE="http://www.suse.com"
+DEBIAN_PV="2"
+DEBIAN_BASE_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/"
+SRC_URI="${DEBIAN_BASE_URI}/${PN}_${PV}.orig.tar.gz
+ ${DEBIAN_BASE_URI}/${PN}_${PV}-${DEBIAN_PV}.diff.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND=">=sys-fs/sysfsutils-2
+ sys-apps/hal
+ sys-apps/dbus"
+# this package won't work on *BSD
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.17"
+
+src_unpack (){
+ unpack ${PN}_${PV}.orig.tar.gz
+}
+
+src_prepare() {
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${DISTDIR}"/${PN}_${PV}-${DEBIAN_PV}.diff.gz
+ cd "${S}"
+ for i in $(<"${S}"/debian/patches/series) ; do
+ EPATCH_SUFFIX="" EPATCH_FORCE="yes" epatch "${S}"/debian/patches/${i}
+ done
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-13.11-makefile-fixes.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-16.0-parallel-fixes.patch
+ #sed -i -e "s,^LIBS[ \t]*= -lhd,LIBS = -lhd -lsysfs," ${S}/Makefile
+ #sed -i -e "s,^LIBDIR[ \t]*= /usr/lib$,LIBDIR = /usr/$(get_libdir)," ${S}/Makefile
+ sed -i -e 's,make,$(MAKE),g' "${S}"/Makefile "${S}"/Makefile.common
+ sed -i -e '/^touch:/s,$, $(LIBHD),g' "${S}"/src/Makefile
+ sed -i -e '/^hw[a-z]\+:.*$(LIBHD)/s,$, subdirs ranlib,g' "${S}"/Makefile
+ echo '$(LIBHD): subdirs' >>"${S}"/Makefile
+ for i in src/{,ids,hd,isdn,isdn/cdb,int10,smp} ; do
+ echo 'objects: $(OBJS) $(LIBHD)' >>"${S}"/${i}/Makefile
+ echo '$(OBJS): subdirs' >>"${S}"/${i}/Makefile
+ echo 'libs: $(LIBHD) subdirs $(OBJS)' >>"${S}"/${i}/Makefile
+ done
+
+ echo 'libs:' >>"${S}"/src/x86emu/Makefile
+
+ echo 'libs: subdirs' >>"${S}"/Makefile
+ echo 'ranlib: $(LIBHD) subdirs' >>"${S}"/Makefile
+ echo -e "\tranlib \$(LIBHD)" >>"${S}"/Makefile
+}
+
+src_compile(){
+ # build is NOT parallel safe, and the build system blows goats
+ einfo "ISDN CDB pass"
+ emake EXTRA_FLAGS="${CFLAGS}" -C 'src/isdn/cdb' || die "emake failed"
+ einfo "LIBS pass"
+ emake EXTRA_FLAGS="${CFLAGS}" libs || die "emake failed"
+ einfo "FINAL pass"
+ emake -j1 EXTRA_FLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ [[ "$(get_libdir)" != "lib" ]] && mv "${D}"/usr/lib "${D}/usr/$(get_libdir)"
+ dodoc VERSION README
+ doman doc/hwinfo.8
+}