summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-12-10 19:55:55 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-12-10 19:55:55 +0000
commitb51ef73ab8d2c56000475e3cbc97aa70b5008546 (patch)
tree6c4765f8f27223a72a27db2124aee94f0fde7057 /sys-apps/hwdata-knoppix/hwdata-knoppix-0.107-r1.ebuild
parenthousecleaning (Manifest recommit) (diff)
downloadgentoo-2-b51ef73ab8d2c56000475e3cbc97aa70b5008546.tar.gz
gentoo-2-b51ef73ab8d2c56000475e3cbc97aa70b5008546.tar.bz2
gentoo-2-b51ef73ab8d2c56000475e3cbc97aa70b5008546.zip
Bumping to latest revision.
Diffstat (limited to 'sys-apps/hwdata-knoppix/hwdata-knoppix-0.107-r1.ebuild')
-rw-r--r--sys-apps/hwdata-knoppix/hwdata-knoppix-0.107-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/hwdata-knoppix/hwdata-knoppix-0.107-r1.ebuild b/sys-apps/hwdata-knoppix/hwdata-knoppix-0.107-r1.ebuild
new file mode 100644
index 000000000000..0b49beb10734
--- /dev/null
+++ b/sys-apps/hwdata-knoppix/hwdata-knoppix-0.107-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwdata-knoppix/hwdata-knoppix-0.107-r1.ebuild,v 1.1 2004/12/10 19:55:55 wolf31o2 Exp $
+
+inherit eutils
+
+MY_PV=${PV}-8
+DESCRIPTION="Data for the hwsetup program"
+SRC_URI="http://developer.linuxtag.net/knoppix/sources/${PN}_${MY_PV}.tar.gz"
+HOMEPAGE="http://www.knopper.net"
+
+IUSE="opengl livecd"
+KEYWORDS="x86 ppc amd64 alpha"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ use livecd && use opengl && epatch ${FILESDIR}/${P}-binary_drivers.patch
+}
+
+src_install() {
+ dodoc debian/README.build debian/changelog debian/control debian/copyright debian/mergepcitable
+ dodir /usr/X11R6/lib/X11/
+ ln -s ../../../share/hwdata/Cards ${D}/usr/X11R6/lib/X11/Cards
+ insinto /usr/share/hwdata
+ doins debian/pcitable-knoppix CardMonitorCombos Cards MonitorsDB pci.ids pcitable upgradelist usb.ids
+}