summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Bertheau <ska-fan@gentoo.org>2003-03-18 00:00:15 +0000
committerMarkus Bertheau <ska-fan@gentoo.org>2003-03-18 00:00:15 +0000
commitedb0dd0f33136b73bd98996d1de7e4c6e52afc27 (patch)
treea9359efa5a9b9be1e36ea620de2e9d4af5a98708 /sys-apps/groff
parentupdate distcc ebuild to fix bug 17716 and add new functionality (diff)
downloadgentoo-2-edb0dd0f33136b73bd98996d1de7e4c6e52afc27.tar.gz
gentoo-2-edb0dd0f33136b73bd98996d1de7e4c6e52afc27.tar.bz2
gentoo-2-edb0dd0f33136b73bd98996d1de7e4c6e52afc27.zip
Add a patch that fixes display of man pages in UTF-8 locales
Diffstat (limited to 'sys-apps/groff')
-rw-r--r--sys-apps/groff/ChangeLog8
-rw-r--r--sys-apps/groff/files/digest-groff-1.18.1-r21
-rw-r--r--sys-apps/groff/files/groff-man-UTF-8.diff11
-rw-r--r--sys-apps/groff/groff-1.18.1-r2.ebuild94
4 files changed, 113 insertions, 1 deletions
diff --git a/sys-apps/groff/ChangeLog b/sys-apps/groff/ChangeLog
index 3f34dd0b84e7..d0c95a0ac414 100644
--- a/sys-apps/groff/ChangeLog
+++ b/sys-apps/groff/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/groff
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.19 2003/03/13 18:41:32 doctomoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.20 2003/03/18 00:00:15 ska-fan Exp $
+
+*groff-1.18.1-r2 (18 Mar 2003)
+
+ 18 Mar 2003; Markus Bertheau <ska-fan@gentoo.org> groff-1.18.1-r2.ebuild,
+ files/groff-man-UTF-8.diff:
+ Add a patch that fixes display of man pages in UTF-8 locales
13 Mar 2003; Olivier Reisch <doctomoe@gentoo.org> groff-1.18.1-r1.ebuild :
Marked ppc stable
diff --git a/sys-apps/groff/files/digest-groff-1.18.1-r2 b/sys-apps/groff/files/digest-groff-1.18.1-r2
new file mode 100644
index 000000000000..94400bd5b25d
--- /dev/null
+++ b/sys-apps/groff/files/digest-groff-1.18.1-r2
@@ -0,0 +1 @@
+MD5 4c7a1b478d230696f14743772f31639f groff-1.18.1.tar.gz 2250463
diff --git a/sys-apps/groff/files/groff-man-UTF-8.diff b/sys-apps/groff/files/groff-man-UTF-8.diff
new file mode 100644
index 000000000000..512171615c8f
--- /dev/null
+++ b/sys-apps/groff/files/groff-man-UTF-8.diff
@@ -0,0 +1,11 @@
+diff -ur groff-1.18.1.orig/tmac/man.local groff-1.18.1/tmac/man.local
+--- groff-1.18.1.orig/tmac/man.local 2000-10-26 16:15:17.000000000 +0200
++++ groff-1.18.1/tmac/man.local 2003-03-16 02:15:50.000000000 +0100
+@@ -1,2 +1,7 @@
+ .\" This file is loaded after an-old.tmac.
+ .\" Put any local modifications to an-old.tmac here.
++.if '\*[.T]'utf8' \{\
++. char \- \N'45'
++. char - \N'45'
++.\}
++
diff --git a/sys-apps/groff/groff-1.18.1-r2.ebuild b/sys-apps/groff/groff-1.18.1-r2.ebuild
new file mode 100644
index 000000000000..9a54d27171ed
--- /dev/null
+++ b/sys-apps/groff/groff-1.18.1-r2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.18.1-r2.ebuild,v 1.1 2003/03/18 00:00:15 ska-fan Exp $
+
+IUSE=""
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Text formatter used for man pages"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/groff/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/groff/groff.html"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ >=sys-apps/texinfo-4.0"
+
+PDEPEND=">=sys-apps/man-1.5k-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Fix the info pages to have .info extensions,
+ # else they do not get gzipped.
+ epatch ${FILESDIR}/groff-1.18-infoext.patch
+
+ # Do not generate example files that require us to
+ # depend on netpbm.
+ epatch ${FILESDIR}/groff-1.18-no-netpbm-depend.patch
+
+ # Do not segfault if no color is defined in input, bug #14329
+ # <azarah@gentoo.org> (08 Feb 2003)
+ epatch ${FILESDIR}/${P}-no-color-segfault.patch
+
+ # Make dashes the same as minus on the keyboard so that you
+ # can search for it. Fixes #17580 and #16108
+ # Thanks to James Cloos <cloos@jhcloos.com>
+ epatch ${FILESDIR}/${PN}-man-UTF-8.diff
+}
+
+src_compile() {
+ # Fix problems with not finding g++
+ [ -z "${CC}" ] && export CC="gcc"
+ [ -z "${CXX}" ] && export CXX="g++"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=\${inforoot} || die
+
+ # emake doesn't work
+ make || die
+
+ # Only build X stuff if we have X installed, but do
+ # not depend on it, else we get circular deps.
+ if [ -n "`use X`" ] && [ -x /usr/X11R6/bin/xmkmf ]
+ then
+ cd ${S}/src/xditview
+ xmkmf || die
+ make depend all || die
+ fi
+}
+
+src_install() {
+ dodir /usr /usr/share/doc/${PF}/{examples,html}
+ make prefix=${D}/usr \
+ manroot=${D}/usr/share/man \
+ inforoot=${D}/usr/share/info \
+ docdir=${D}/usr/share/doc/${PF} \
+ install || die
+
+ if [ -n "`use X`" ] && [ -x /usr/X11R6/bin/xmkmf ]
+ then
+ cd ${S}/src/xditview
+ make DESTDIR=${D} \
+ BINDIR=/usr/bin \
+ MANPATH=/usr/share/man \
+ install \
+ install.man || die
+ fi
+
+ #the following links are required for xman
+ dosym eqn /usr/bin/geqn
+ dosym tbl /usr/bin/gtbl
+ dosym soelim /usr/bin/zsoelim
+
+ cd ${S}
+ dodoc BUG-REPORT COPYING ChangeLog FDL MORE.STUFF NEWS \
+ PROBLEMS PROJECTS README REVISION TODO VERSION
+}
+