summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-12-21 19:33:24 +0000
committerMike Frysinger <vapier@gentoo.org>2011-12-21 19:33:24 +0000
commit2e72c27f8e2efa07283e60c83e703335cb5da385 (patch)
tree921ff920543163f062557d48540be81239e22762 /sys-apps/groff
parentStable for AMD64, wrt bug #395579 (diff)
downloadgentoo-2-2e72c27f8e2efa07283e60c83e703335cb5da385.tar.gz
gentoo-2-2e72c27f8e2efa07283e60c83e703335cb5da385.tar.bz2
gentoo-2-2e72c27f8e2efa07283e60c83e703335cb5da385.zip
Fix parallel build failure in pdfmark subdir.
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/groff')
-rw-r--r--sys-apps/groff/ChangeLog7
-rw-r--r--sys-apps/groff/files/groff-1.20.1-pdfmark-parallel.patch46
-rw-r--r--sys-apps/groff/groff-1.20.1-r3.ebuild3
-rw-r--r--sys-apps/groff/groff-1.21-r1.ebuild3
-rw-r--r--sys-apps/groff/groff-1.21.ebuild3
5 files changed, 58 insertions, 4 deletions
diff --git a/sys-apps/groff/ChangeLog b/sys-apps/groff/ChangeLog
index d847f49adcc7..6f6b7a469128 100644
--- a/sys-apps/groff/ChangeLog
+++ b/sys-apps/groff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/groff
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.121 2011/10/23 19:42:35 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.122 2011/12/21 19:33:24 vapier Exp $
+
+ 21 Dec 2011; Mike Frysinger <vapier@gentoo.org> groff-1.20.1-r3.ebuild,
+ +files/groff-1.20.1-pdfmark-parallel.patch, groff-1.21.ebuild,
+ groff-1.21-r1.ebuild:
+ Fix parallel build failure in pdfmark subdir.
*groff-1.21-r1 (23 Oct 2011)
diff --git a/sys-apps/groff/files/groff-1.20.1-pdfmark-parallel.patch b/sys-apps/groff/files/groff-1.20.1-pdfmark-parallel.patch
new file mode 100644
index 000000000000..05405a9b2e7e
--- /dev/null
+++ b/sys-apps/groff/files/groff-1.20.1-pdfmark-parallel.patch
@@ -0,0 +1,46 @@
+http://crosbug.com/24481
+https://savannah.gnu.org/bugs/index.php?35146
+
+From 324a699b3903bd7d9d248bc229ab8518fc47cbed Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Wed, 21 Dec 2011 14:15:50 -0500
+Subject: [PATCH] pdfmark: fix parallel build race failure
+
+Sometimes building in parallel will fail in the pdfmark directory:
+ make[2]: Entering directory '.../contrib/pdfmark'
+ rm -f pdfroff
+ rm -f pdfmark.pdf
+ sed -f ... ./pdfroff.sh >pdfroff
+ ...; ./pdfroff ... pdfmark.ms >pdfmark.pdf
+ /bin/sh: ./pdfroff: Permission denied
+ chmod +x pdfroff
+ make[2]: *** [pdfmark.pdf] Error 126
+
+This is because the generated pdf files use the local generated pdfroff
+helper script, but they don't depend directly upon it, so make tries to
+create the two in parallel and randomly falls over.
+
+Have all the .pdf files explicitly depend on the pdfroff helper script.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ contrib/pdfmark/Makefile.sub | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/contrib/pdfmark/Makefile.sub b/contrib/pdfmark/Makefile.sub
+index 9eb2763..36c9e0f 100644
+--- a/contrib/pdfmark/Makefile.sub
++++ b/contrib/pdfmark/Makefile.sub
+@@ -66,6 +66,9 @@ PDFROFF=\
+
+ all: pdfroff $(make_pdfdoc)
+
++# The pdf files use the local script to generate.
++$(PDFDOCFILES): pdfroff
++
+ pdfdoc: gnu.eps $(PDFDOCFILES)
+
+ gnu.eps:
+--
+1.7.6.1
+
diff --git a/sys-apps/groff/groff-1.20.1-r3.ebuild b/sys-apps/groff/groff-1.20.1-r3.ebuild
index c8e2ba1edd17..0cbb9dfb05b9 100644
--- a/sys-apps/groff/groff-1.20.1-r3.ebuild
+++ b/sys-apps/groff/groff-1.20.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.20.1-r3.ebuild,v 1.9 2011/02/24 22:13:39 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.20.1-r3.ebuild,v 1.10 2011/12/21 19:33:24 vapier Exp $
inherit autotools eutils toolchain-funcs
@@ -32,6 +32,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-tmac-ec.patch #263524
epatch "${FILESDIR}"/${P}-Thtml-mem-leak.patch #294045
epatch "${FILESDIR}"/${P}-double-frees-mem-leaks.patch #294045
+ epatch "${FILESDIR}"/${PN}-1.20.1-pdfmark-parallel.patch
# put the docs in the Gentoo-specific spot
sed -i \
diff --git a/sys-apps/groff/groff-1.21-r1.ebuild b/sys-apps/groff/groff-1.21-r1.ebuild
index a3c42f3603fe..9d88d0bb035f 100644
--- a/sys-apps/groff/groff-1.21-r1.ebuild
+++ b/sys-apps/groff/groff-1.21-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.21-r1.ebuild,v 1.1 2011/10/23 19:42:35 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.21-r1.ebuild,v 1.2 2011/12/21 19:33:24 vapier Exp $
EAPI="3"
@@ -28,6 +28,7 @@ DEPEND=">=sys-apps/texinfo-4.7-r1
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.19.2-man-unicode-dashes.patch #16108 #17580 #121502
+ epatch "${FILESDIR}"/${PN}-1.20.1-pdfmark-parallel.patch
# Make sure we can cross-compile this puppy
if tc-is-cross-compiler ; then
diff --git a/sys-apps/groff/groff-1.21.ebuild b/sys-apps/groff/groff-1.21.ebuild
index aa13a363babc..e5e927e8ddfb 100644
--- a/sys-apps/groff/groff-1.21.ebuild
+++ b/sys-apps/groff/groff-1.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.21.ebuild,v 1.8 2011/05/07 18:02:54 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.21.ebuild,v 1.9 2011/12/21 19:33:24 vapier Exp $
inherit autotools eutils toolchain-funcs
@@ -29,6 +29,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${PN}-1.19.2-man-unicode-dashes.patch #16108 #17580 #121502
+ epatch "${FILESDIR}"/${PN}-1.20.1-pdfmark-parallel.patch
# Make sure we can cross-compile this puppy
if tc-is-cross-compiler ; then