summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-03-27 04:48:51 +0000
committerMike Frysinger <vapier@gentoo.org>2010-03-27 04:48:51 +0000
commitbfc5be3a0788b7492820fcce1548bb8e2ec0a236 (patch)
treecd0d2494f5a980e37f0c6f3f9edc0601407eaac5 /sys-apps/grep
parentKeep doc installation in one place. Remove unneeded die messages. (diff)
downloadgentoo-2-bfc5be3a0788b7492820fcce1548bb8e2ec0a236.tar.gz
gentoo-2-bfc5be3a0788b7492820fcce1548bb8e2ec0a236.tar.bz2
gentoo-2-bfc5be3a0788b7492820fcce1548bb8e2ec0a236.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/grep')
-rw-r--r--sys-apps/grep/ChangeLog8
-rw-r--r--sys-apps/grep/files/grep-2.6.1-no-french.patch30
-rw-r--r--sys-apps/grep/grep-2.6.1.ebuild40
3 files changed, 77 insertions, 1 deletions
diff --git a/sys-apps/grep/ChangeLog b/sys-apps/grep/ChangeLog
index 5d5c96ead976..4029b796fc0a 100644
--- a/sys-apps/grep/ChangeLog
+++ b/sys-apps/grep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/grep
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.93 2010/03/23 21:11:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.94 2010/03/27 04:48:51 vapier Exp $
+
+*grep-2.6.1 (27 Mar 2010)
+
+ 27 Mar 2010; Mike Frysinger <vapier@gentoo.org> +grep-2.6.1.ebuild,
+ +files/grep-2.6.1-no-french.patch:
+ Version bump.
*grep-2.6 (23 Mar 2010)
diff --git a/sys-apps/grep/files/grep-2.6.1-no-french.patch b/sys-apps/grep/files/grep-2.6.1-no-french.patch
new file mode 100644
index 000000000000..b5ea2ab8c36a
--- /dev/null
+++ b/sys-apps/grep/files/grep-2.6.1-no-french.patch
@@ -0,0 +1,30 @@
+From 189913f75b39f3136c825e317bceafe28618a94d Mon Sep 17 00:00:00 2001
+From: Jim Meyering <meyering@redhat.com>
+Date: Fri, 26 Mar 2010 07:24:48 +0100
+Subject: [PATCH] tests: avoid spurious test failure due to lack of a French UTF8 locale
+
+* tests/init.cfg: New file. If either $LOCALE_FR or $LOCALE_FR_UTF8
+is set to "none", reset it to the empty string.
+Reported by Mike Frysinger and Sven Joachim.
+* tests/Makefile.am (EXTRA_DIST): Add init.cfg.
+---
+ THANKS | 2 ++
+ tests/Makefile.am | 1 +
+ tests/init.cfg | 5 +++++
+ 3 files changed, 8 insertions(+), 0 deletions(-)
+ create mode 100644 tests/init.cfg
+
+diff --git a/tests/init.cfg b/tests/init.cfg
+new file mode 100644
+index 0000000..6fec55e
+--- /dev/null
++++ tests/init.cfg
+@@ -0,0 +1,5 @@
++# This file is sourced by init.sh, *before* its initialization.
++
++# Map settings of "none" to the empty string.
++test _"$LOCALE_FR" = _none && LOCALE_FR=
++test _"$LOCALE_FR_UTF8" = _none && LOCALE_FR_UTF8=
+--
+1.7.0.2
+
diff --git a/sys-apps/grep/grep-2.6.1.ebuild b/sys-apps/grep/grep-2.6.1.ebuild
new file mode 100644
index 000000000000..8821dbd8cf71
--- /dev/null
+++ b/sys-apps/grep/grep-2.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.6.1.ebuild,v 1.1 2010/03/27 04:48:51 vapier Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="GNU regular expression matcher"
+HOMEPAGE="http://www.gnu.org/software/grep/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="nls pcre"
+
+RDEPEND="nls? ( virtual/libintl )
+ pcre? ( >=dev-libs/libpcre-7.8-r1 )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-french.patch
+}
+
+src_configure() {
+ econf \
+ --bindir=/bin \
+ $(use_enable nls) \
+ $(use_enable pcre perl-regexp) \
+ $(use elibc_FreeBSD || echo --without-included-regex) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}