summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-30 02:35:50 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-30 02:35:50 +0000
commitf7398eb25aa75ddd5b1710522c2f95e8a59adc9d (patch)
tree9a925b3e0f486d5184bd8674400fe160e26944b8 /sys-apps/gluelog
parentsync IUSE (+gnome, -gnome), trim trailing whitespace (Manifest recommit) (diff)
downloadgentoo-2-f7398eb25aa75ddd5b1710522c2f95e8a59adc9d.tar.gz
gentoo-2-f7398eb25aa75ddd5b1710522c2f95e8a59adc9d.tar.bz2
gentoo-2-f7398eb25aa75ddd5b1710522c2f95e8a59adc9d.zip
clean up and dont use glibc
Diffstat (limited to 'sys-apps/gluelog')
-rw-r--r--sys-apps/gluelog/gluelog-1.0-r2.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/sys-apps/gluelog/gluelog-1.0-r2.ebuild b/sys-apps/gluelog/gluelog-1.0-r2.ebuild
index b4a0023336cc..019d4c6ef3c1 100644
--- a/sys-apps/gluelog/gluelog-1.0-r2.ebuild
+++ b/sys-apps/gluelog/gluelog-1.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gluelog/gluelog-1.0-r2.ebuild,v 1.14 2004/06/24 22:07:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gluelog/gluelog-1.0-r2.ebuild,v 1.15 2004/06/30 02:35:50 vapier Exp $
DESCRIPTION="Pipe and socket fittings for the system and kernel logs"
HOMEPAGE="http://www.linuxuser.co.za/projects.php3"
@@ -8,22 +8,23 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 amd64 ppc sparc "
+KEYWORDS="x86 ppc sparc amd64"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
-src_compile() {
- mkdir ${S}
+S=${WORKDIR}
+
+src_unpack() {
+ cp ${FILESDIR}/{gluelog,glueklog}.c . || die
+}
- cd ${FILESDIR}
- gcc ${CFLAGS} gluelog.c -o ${S}/gluelog || die
- gcc ${CFLAGS} glueklog.c -o ${S}/glueklog || die
+src_compile() {
+ emake gluelog glueklog || die
}
src_install() {
- dodir /usr/sbin
- dosbin ${S}/gluelog ${S}/glueklog
+ dosbin gluelog glueklog || die
exeopts -m0750 -g wheel
dodir /var/log
local x