summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-02-19 15:05:08 +0000
committerMichał Górny <mgorny@gentoo.org>2014-02-19 15:05:08 +0000
commit865573de20739c0eb52639b54eee61b0120f4ba3 (patch)
tree69ee97e9314ef0e1111ba534321752b6096369e0 /sys-apps/gentoo-systemd-integration
parentQA: change quoting style wrt bug #314473, thanks to Marcin Mirosław <bug AT ... (diff)
downloadgentoo-2-865573de20739c0eb52639b54eee61b0120f4ba3.tar.gz
gentoo-2-865573de20739c0eb52639b54eee61b0120f4ba3.tar.bz2
gentoo-2-865573de20739c0eb52639b54eee61b0120f4ba3.zip
Version bump. Adds Gentoo udev rules (bug #488134) and fixes local.d *.stop support.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-apps/gentoo-systemd-integration')
-rw-r--r--sys-apps/gentoo-systemd-integration/ChangeLog9
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-3.ebuild28
2 files changed, 36 insertions, 1 deletions
diff --git a/sys-apps/gentoo-systemd-integration/ChangeLog b/sys-apps/gentoo-systemd-integration/ChangeLog
index 9442b5cf6f94..1effc3f0efbb 100644
--- a/sys-apps/gentoo-systemd-integration/ChangeLog
+++ b/sys-apps/gentoo-systemd-integration/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/gentoo-systemd-integration
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/ChangeLog,v 1.20 2014/02/02 11:27:45 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/ChangeLog,v 1.21 2014/02/19 15:05:08 mgorny Exp $
+
+*gentoo-systemd-integration-3 (19 Feb 2014)
+
+ 19 Feb 2014; Michał Górny <mgorny@gentoo.org>
+ +gentoo-systemd-integration-3.ebuild:
+ Version bump. Adds Gentoo udev rules (bug #488134) and fixes local.d *.stop
+ support.
02 Feb 2014; Pacho Ramos <pacho@gentoo.org>
gentoo-systemd-integration-2.ebuild:
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-3.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-3.ebuild
new file mode 100644
index 000000000000..2e84a289464c
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-3.ebuild,v 1.1 2014/02/19 15:05:08 mgorny Exp $
+
+EAPI=5
+
+inherit autotools-utils systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://bitbucket.org/mgorny/gentoo-systemd-integration"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207"
+
+src_configure() {
+ local myeconfargs=(
+ "$(systemd_with_unitdir)"
+ # TODO: solve it better in the eclass
+ --with-systemdsystemgeneratordir="$(systemd_get_utildir)"/system-generators
+ )
+
+ autotools-utils_src_configure
+}