summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-30 02:32:35 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-30 02:32:35 +0000
commitc5d4c0608d50f2df8b43ecf3b1211a749802d53b (patch)
tree4eb970f1f93e6eb81c987ae74f0954d01faf4b2a /sys-apps/fxload
parentsync IUSE (-nls) (diff)
downloadgentoo-2-c5d4c0608d50f2df8b43ecf3b1211a749802d53b.tar.gz
gentoo-2-c5d4c0608d50f2df8b43ecf3b1211a749802d53b.tar.bz2
gentoo-2-c5d4c0608d50f2df8b43ecf3b1211a749802d53b.zip
use libc, not glibc
Diffstat (limited to 'sys-apps/fxload')
-rw-r--r--sys-apps/fxload/fxload-20020411.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/sys-apps/fxload/fxload-20020411.ebuild b/sys-apps/fxload/fxload-20020411.ebuild
index 97dd497bb071..a9efb8dc2312 100644
--- a/sys-apps/fxload/fxload-20020411.ebuild
+++ b/sys-apps/fxload/fxload-20020411.ebuild
@@ -1,26 +1,27 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fxload/fxload-20020411.ebuild,v 1.13 2004/06/24 22:07:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fxload/fxload-20020411.ebuild,v 1.14 2004/06/30 02:27:54 vapier Exp $
# source maintainers named it fxload-YYYY_MM_DD instead of fxload-YYYYMMDD
-MY_P=`echo $P|sed 's/-\(....\)\(..\)\(..\)/-\1_\2_\3/'`
-S=${WORKDIR}/${MY_P}
+MY_P="${PN}-${PV:0:4}_${PV:4:2}_${PV:6:2}"
DESCRIPTION="USB firmware uploader"
-SRC_URI="http://unc.dl.sourceforge.net/sourceforge/linux-hotplug/fxload-2002_04_11.tar.gz"
-HOMEPAGE="http://linux-hotplug.sourceforge.net"
-KEYWORDS="x86 amd64 ppc sparc ~hppa"
-SLOT="0"
+HOMEPAGE="http://linux-hotplug.sourceforge.net/"
+SRC_URI="mirror://sourceforge/linux-hotplug/${MY_P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc ~hppa amd64"
+IUSE=""
-# fxload needs pcimodules utility provided by pcitutils-2.1.9-r1
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-apps/hotplug"
+S=${WORKDIR}/${MY_P}
+
src_compile() {
- # compile fxload program
make || die
}
src_install() {
- make install prefix=${D}
+ make install prefix=${D} || die
}