summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2005-12-24 04:53:22 +0000
committerChris PeBenito <pebenito@gentoo.org>2005-12-24 04:53:22 +0000
commita4ec332a3d5b3a41ca44100de67bfa9e09465c56 (patch)
tree893c87809d7e43937a69e469c99f094d69db865b /sys-apps/findutils
parentVersion bump #116490 by David Watzke. (diff)
downloadgentoo-2-a4ec332a3d5b3a41ca44100de67bfa9e09465c56.tar.gz
gentoo-2-a4ec332a3d5b3a41ca44100de67bfa9e09465c56.tar.bz2
gentoo-2-a4ec332a3d5b3a41ca44100de67bfa9e09465c56.zip
update selinux patch.
(Portage version: 2.0.53)
Diffstat (limited to 'sys-apps/findutils')
-rw-r--r--sys-apps/findutils/ChangeLog6
-rw-r--r--sys-apps/findutils/files/findutils-4.3.0-selinux.diff465
-rw-r--r--sys-apps/findutils/findutils-4.3.0.ebuild4
3 files changed, 472 insertions, 3 deletions
diff --git a/sys-apps/findutils/ChangeLog b/sys-apps/findutils/ChangeLog
index bc7361ec78b0..e7451d28fdf4 100644
--- a/sys-apps/findutils/ChangeLog
+++ b/sys-apps/findutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/findutils
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.60 2005/12/23 13:06:02 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.61 2005/12/24 04:53:22 pebenito Exp $
+
+ 24 Dec 2005; Chris PeBenito <pebenito@gentoo.org>
+ +files/findutils-4.3.0-selinux.diff, findutils-4.3.0.ebuild:
+ Update SELinux patch.
23 Dec 2005; Gustavo Zacarias <gustavoz@gentoo.org>
findutils-4.1.20-r2.ebuild:
diff --git a/sys-apps/findutils/files/findutils-4.3.0-selinux.diff b/sys-apps/findutils/files/findutils-4.3.0-selinux.diff
new file mode 100644
index 000000000000..38810f8d637a
--- /dev/null
+++ b/sys-apps/findutils/files/findutils-4.3.0-selinux.diff
@@ -0,0 +1,465 @@
+diff -urNp findutils-4.3.0.orig/find/Makefile.am findutils-4.3.0/find/Makefile.am
+--- findutils-4.3.0.orig/find/Makefile.am 2005-12-06 03:00:30.000000000 -0500
++++ findutils-4.3.0/find/Makefile.am 2005-12-23 23:20:29.728748962 -0500
+@@ -2,6 +2,7 @@ AUTOMAKE_OPTIONS = std-options
+ localedir = $(datadir)/locale
+ # noinst_PROGRAMS = regexprops
+ # regexprops_SOURCES = regexprops.c
++DEFS = @DEFS@ -I. -I$(srcdir) -I.. -DWITH_SELINUX
+
+ noinst_LIBRARIES = libfindtools.a
+ libfindtools_a_SOURCES = finddata.c fstype.c parser.c pred.c tree.c util.c version.c
+@@ -26,7 +27,7 @@ endif
+
+ EXTRA_DIST = defs.h $(man_MANS)
+ INCLUDES = -I../gnulib/lib -I$(top_srcdir)/lib -I$(top_srcdir)/gnulib/lib -I../intl -DLOCALEDIR=\"$(localedir)\"
+-LDADD = ./libfindtools.a ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@
++LDADD = ./libfindtools.a ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@ -lselinux
+ man_MANS = find.1
+ SUBDIRS = testsuite
+
+diff -urNp findutils-4.3.0.orig/find/Makefile.in findutils-4.3.0/find/Makefile.in
+--- findutils-4.3.0.orig/find/Makefile.in 2005-12-12 03:24:18.000000000 -0500
++++ findutils-4.3.0/find/Makefile.in 2005-12-23 23:21:24.551616866 -0500
+@@ -217,7 +217,7 @@ CPPFLAGS = @CPPFLAGS@
+ CROSS_COMPILING_FALSE = @CROSS_COMPILING_FALSE@
+ CROSS_COMPILING_TRUE = @CROSS_COMPILING_TRUE@
+ CYGPATH_W = @CYGPATH_W@
+-DEFS = @DEFS@
++DEFS = @DEFS@ -I. -I$(srcdir) -I.. -DWITH_SELINUX
+ DEPDIR = @DEPDIR@
+ ECHO_C = @ECHO_C@
+ ECHO_N = @ECHO_N@
+@@ -321,7 +321,7 @@ libfindtools_a_SOURCES = finddata.c fsty
+ @WITH_FTS_TRUE@oldfind_SOURCES = find.c
+ @WITH_FTS_FALSE@ftsfind_SOURCES = ftsfind.c
+ EXTRA_DIST = defs.h $(man_MANS)
+-LDADD = ./libfindtools.a ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@
++LDADD = ./libfindtools.a ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@ -lselinux
+ man_MANS = find.1
+ SUBDIRS = testsuite
+ all: all-recursive
+diff -urNp findutils-4.3.0.orig/find/defs.h findutils-4.3.0/find/defs.h
+--- findutils-4.3.0.orig/find/defs.h 2005-12-12 02:03:15.000000000 -0500
++++ findutils-4.3.0/find/defs.h 2005-12-23 23:18:46.679793971 -0500
+@@ -136,6 +136,10 @@ int get_statinfo PARAMS((const char *pat
+ #define MODE_RWX (S_IXUSR | S_IXGRP | S_IXOTH | MODE_RW)
+ #define MODE_ALL (S_ISUID | S_ISGID | S_ISVTX | MODE_RWX)
+
++#ifdef WITH_SELINUX
++#include <selinux/selinux.h>
++#endif /*WITH_SELINUX*/
++
+ #if 1
+ #include <stdbool.h>
+ typedef bool boolean;
+@@ -328,6 +332,9 @@ struct predicate
+ struct dir_id fileid; /* samefile */
+ mode_t type; /* type */
+ FILE *stream; /* ls fls fprint0 */
++#ifdef WITH_SELINUX
++ security_context_t scontext; /* scontext */
++#endif /*WITH_SELINUX*/
+ struct format_val printf_vec; /* printf fprintf fprint */
+ } args;
+
+@@ -491,6 +498,9 @@ boolean pred_used PARAMS((char *pathname
+ boolean pred_user PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
+ boolean pred_writable PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
+ boolean pred_xtype PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
++#ifdef WITH_SELINUX
++boolean pred_scontext PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
++#endif /* WITH_SELINUX */
+
+
+
+@@ -590,6 +600,10 @@ struct options
+ * can be changed with the positional option, -regextype.
+ */
+ int regex_options;
++
++#ifdef WITH_SELINUX
++ int (*x_getfilecon) ();
++#endif /* WITH_SELINUX */
+ };
+ extern struct options options;
+
+diff -urNp findutils-4.3.0.orig/find/find.1 findutils-4.3.0/find/find.1
+--- findutils-4.3.0.orig/find/find.1 2005-12-06 03:00:30.000000000 -0500
++++ findutils-4.3.0/find/find.1 2005-12-23 23:18:46.621804688 -0500
+@@ -494,6 +494,9 @@ links: if the \-H or \-P option was spec
+ link to a file of type \fIc\fR; if the \-L option has been given, true
+ if \fIc\fR is `l'. In other words, for symbolic links, \-xtype checks
+ the type of the file that \-type does not check.
++.IP "\-context \fIscontext\fR"
++.IP "\--context \fIscontext\fR"
++(SELinux only) File has the security context \fIscontext\fR.
+
+ .SS ACTIONS
+ .IP "\-delete\fR"
+@@ -796,6 +799,8 @@ File's numeric user ID.
+ File's type (like in ls \-l), U=unknown type (shouldn't happen)
+ .IP %Y
+ File's type (like %y), plus follow symlinks: L=loop, N=nonexistent
++.IP %Z
++(SELinux only) file's security context.
+ .PP
+ A `%' character followed by any other character is discarded (but the
+ other character is printed).
+diff -urNp findutils-4.3.0.orig/find/find.c findutils-4.3.0/find/find.c
+--- findutils-4.3.0.orig/find/find.c 2005-12-06 21:03:41.000000000 -0500
++++ findutils-4.3.0/find/find.c 2005-12-23 23:39:47.555764982 -0500
+@@ -133,7 +133,9 @@ main (int argc, char **argv)
+ struct predicate *cur_pred;
+ char *predicate_name; /* Name of predicate being parsed. */
+ int end_of_leading_options = 0; /* First arg after any -H/-L etc. */
+-
++#ifdef WITH_SELINUX
++ int is_selinux_enabled_flag = is_selinux_enabled()>0;
++#endif /* WITH_SELINUX */
+
+ program_name = argv[0];
+
+@@ -278,6 +280,14 @@ main (int argc, char **argv)
+ if (strchr ("-!(),", argv[i][0]) == NULL)
+ usage (_("paths must precede expression"));
+ predicate_name = argv[i];
++#ifdef WITH_SELINUX
++ if (! is_selinux_enabled_flag) {
++ if ((strncmp(predicate_name,"-context",strlen("-context"))==0) ||
++ (strncmp(predicate_name,"--context",strlen("--context"))==0)) {
++ error (1, 0,_("Error: invalid predicate %s: the kernel is not selinux-enabled.\n"),predicate_name);
++ }
++ }
++#endif
+ parse_entry = find_parser (predicate_name);
+ if (parse_entry == NULL)
+ {
+@@ -431,7 +441,7 @@ main (int argc, char **argv)
+ cleanup();
+ return state.exit_status;
+ }
+-
++
+ boolean is_fts_enabled()
+ {
+ /* this version of find (i.e. this main()) does not use fts. */
+@@ -1416,7 +1426,7 @@ process_path (char *pathname, char *name
+ static void
+ process_dir (char *pathname, char *name, int pathlen, struct stat *statp, char *parent)
+ {
+- int subdirs_left; /* Number of unexamined subdirs in PATHNAME. */
++ int subdirs_left=0; /* Number of unexamined subdirs in PATHNAME. */
+ boolean subdirs_unreliable; /* if true, cannot use dir link count as subdir limif (if false, it may STILL be unreliable) */
+ int idx; /* Which entry are we on? */
+ struct stat stat_buf;
+diff -urNp findutils-4.3.0.orig/find/parser.c findutils-4.3.0/find/parser.c
+--- findutils-4.3.0.orig/find/parser.c 2005-12-12 02:05:27.000000000 -0500
++++ findutils-4.3.0/find/parser.c 2005-12-23 23:38:02.688146107 -0500
+@@ -47,6 +47,10 @@
+ /* We need <unistd.h> for isatty(). */
+ #include <unistd.h>
+
++#ifdef WITH_SELINUX
++#include <selinux/selinux.h>
++#endif /*WITH_SELINUX*/
++
+ #if ENABLE_NLS
+ # include <libintl.h>
+ # define _(Text) gettext (Text)
+@@ -151,6 +155,9 @@ static boolean parse_warn PARAM
+ static boolean parse_writable PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
+ static boolean parse_xtype PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
+ static boolean parse_quit PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
++#ifdef WITH_SELINUX
++static boolean parse_scontext PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
++#endif /*WITH_SELINUX*/
+
+ boolean parse_print PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
+
+@@ -303,13 +310,102 @@ static struct parser_table const parse_t
+ {ARG_TEST, "-help", parse_help, NULL}, /* GNU */
+ {ARG_TEST, "version", parse_version, NULL}, /* GNU */
+ {ARG_TEST, "-version", parse_version, NULL}, /* GNU */
++ {ARG_TEST, "context", parse_scontext, pred_scontext}, /* SELinux */
++ {ARG_TEST, "-context", parse_scontext, pred_scontext}, /* SELinux */
+ {0, 0, 0, 0}
+ };
+
+
+ static const char *first_nonoption_arg = NULL;
+
++#ifdef WITH_SELINUX
++
++static int
++fallback_getfilecon(const char *name, security_context_t *p, int prev_rv)
++{
++ /* Our original getfilecon() call failed. Perhaps we can't follow a
++ * symbolic link. If that might be the problem, lgetfilecon() the link.
++ * Otherwise, admit defeat.
++ */
++ switch (errno)
++ {
++ case ENOENT:
++ case ENOTDIR:
++#ifdef DEBUG_STAT
++ fprintf(stderr, "fallback_getfilecon(): getfilecon(%s) failed; falling back on lgetfilecon()\n", name);
++#endif
++ return lgetfilecon(name, p);
++
++ case EACCES:
++ case EIO:
++ case ELOOP:
++ case ENAMETOOLONG:
++#ifdef EOVERFLOW
++ case EOVERFLOW: /* EOVERFLOW is not #defined on UNICOS. */
++#endif
++ default:
++ return prev_rv;
++ }
++}
+
++
++/* optionh_getfilecon() implements the getfilecon operation when the
++ * -H option is in effect.
++ *
++ * If the item to be examined is a command-line argument, we follow
++ * symbolic links. If the getfilecon() call fails on the command-line
++ * item, we fall back on the properties of the symbolic link.
++ *
++ * If the item to be examined is not a command-line argument, we
++ * examine the link itself.
++ */
++int
++optionh_getfilecon(const char *name, security_context_t *p)
++{
++ if (0 == state.curdepth)
++ {
++ /* This file is from the command line; deference the link (if it
++ * is a link).
++ */
++ int rv = getfilecon(name, p);
++ if (0 == rv)
++ return 0; /* success */
++ else
++ return fallback_getfilecon(name, p, rv);
++ }
++ else
++ {
++ /* Not a file on the command line; do not derefernce the link.
++ */
++ return lgetfilecon(name, p);
++ }
++}
++
++/* optionl_getfilecon() implements the getfilecon operation when the
++ * -L option is in effect. That option makes us examine the thing the
++ * symbolic link points to, not the symbolic link itself.
++ */
++int
++optionl_getfilecon(const char *name, security_context_t *p)
++{
++ int rv = getfilecon(name, p);
++ if (0 == rv)
++ return 0; /* normal case. */
++ else
++ return fallback_getfilecon(name, p, rv);
++}
++
++/* optionp_getfilecon() implements the stat operation when the -P
++ * option is in effect (this is also the default). That option makes
++ * us examine the symbolic link itself, not the thing it points to.
++ */
++int
++optionp_getfilecon(const char *name, security_context_t *p)
++{
++ return lgetfilecon(name, p);
++}
++#endif /* WITH_SELINUX */
++
+
+
+ void
+@@ -320,10 +416,16 @@ set_follow_state(enum SymlinkOption opt)
+ case SYMLINK_ALWAYS_DEREF: /* -L */
+ options.xstat = optionl_stat;
+ options.no_leaf_check = true;
++#ifdef WITH_SELINUX
++ options.x_getfilecon = optionl_getfilecon;
++#endif /* WITH_SELINUX */
+ break;
+
+ case SYMLINK_NEVER_DEREF: /* -P (default) */
+ options.xstat = optionp_stat;
++#ifdef WITH_SELINUX
++ options.x_getfilecon = optionp_getfilecon;
++#endif /* WITH_SELINUX */
+ /* Can't turn no_leaf_check off because the user might have specified
+ * -noleaf anyway
+ */
+@@ -332,6 +434,9 @@ set_follow_state(enum SymlinkOption opt)
+ case SYMLINK_DEREF_ARGSONLY: /* -H */
+ options.xstat = optionh_stat;
+ options.no_leaf_check = true;
++#ifdef WITH_SELINUX
++ options.x_getfilecon = optionh_getfilecon;
++#endif /* WITH_SELINUX */
+ }
+
+ options.symlink_handling = opt;
+@@ -843,6 +948,10 @@ tests (N can be +N or -N or N): -amin N
+ -readable -writable -executable\n\
+ -wholename PATTERN -size N[bcwkMG] -true -type [bcdpflsD] -uid N\n\
+ -used N -user NAME -xtype [bcdpfls]\n"));
++#ifdef WITH_SELINUX
++ puts (_("\
++ -context CONTEXT\n"));
++#endif /*WITH_SELINUX*/
+ puts (_("\
+ actions: -delete -print0 -printf FORMAT -fprintf FILE FORMAT -print \n\
+ -fprint0 FILE -fprint FILE -ls -fls FILE -prune -quit\n\
+@@ -1840,6 +1949,29 @@ parse_version (const struct parser_table
+ exit (0);
+ }
+
++#ifdef WITH_SELINUX
++
++static boolean
++parse_scontext ( const struct parser_table* entry, char **argv, int *arg_ptr)
++{
++ struct predicate *our_pred;
++
++ if ( (argv == NULL) || (argv[*arg_ptr] == NULL) )
++ return( false );
++
++ our_pred = insert_primary(entry);
++ our_pred->need_stat = false;
++#ifdef DEBUG
++ our_pred->p_name = find_pred_name (pred_scontext);
++#endif /*DEBUG*/
++ our_pred->args.scontext = argv[*arg_ptr];;
++
++ (*arg_ptr)++;
++ return( true );
++}
++
++#endif /*WITH_SELINUX*/
++
+ static boolean
+ parse_xdev (const struct parser_table* entry, char **argv, int *arg_ptr)
+ {
+@@ -2077,7 +2209,11 @@ insert_fprintf (FILE *fp, const struct p
+ if (*scan2 == '.')
+ for (scan2++; ISDIGIT (*scan2); scan2++)
+ /* Do nothing. */ ;
++#ifdef WITH_SELINUX
++ if (strchr ("abcdDfFgGhHiklmMnpPstuUyYZ", *scan2))
++#else /* WITH_SELINUX */
+ if (strchr ("abcdDfFgGhHiklmMnpPstuUyY", *scan2))
++#endif /* WITH_SELINUX */
+ {
+ segmentp = make_segment (segmentp, format, scan2 - format,
+ (int) *scan2);
+diff -urNp findutils-4.3.0.orig/find/pred.c findutils-4.3.0/find/pred.c
+--- findutils-4.3.0.orig/find/pred.c 2005-12-06 21:27:21.000000000 -0500
++++ findutils-4.3.0/find/pred.c 2005-12-23 23:18:46.658797852 -0500
+@@ -39,6 +39,14 @@
+ #include "yesno.h"
+ #include "listfile.h"
+
++#ifdef WITH_SELINUX
++#include <selinux/selinux.h>
++#endif /*WITH_SELINUX*/
++
++#ifndef FNM_CASEFOLD
++#define FNM_CASEFOLD (1<<4)
++#endif /*FNM_CASEFOLD*/
++
+ #if ENABLE_NLS
+ # include <libintl.h>
+ # define _(Text) gettext (Text)
+@@ -216,6 +224,9 @@ struct pred_assoc pred_table[] =
+ {pred_used, "used "},
+ {pred_user, "user "},
+ {pred_xtype, "xtype "},
++#ifdef WITH_SELINUX
++ {pred_scontext, "context"},
++#endif /*WITH_SELINUX*/
+ {0, "none "}
+ };
+
+@@ -905,6 +916,26 @@ pred_fprintf (char *pathname, struct sta
+ mode_to_filetype(stat_buf->st_mode & S_IFMT));
+ }
+ break;
++#ifdef WITH_SELINUX
++ case 'Z': /* SELinux security context */
++ {
++ security_context_t scontext;
++ int rv;
++ rv = (*options.x_getfilecon)(state.rel_pathname, &scontext);
++
++ if ( rv < 0 ) {
++ (void) fprintf(stderr, "getfileconf(%s): %s",
++ pathname, strerror(errno));
++ (void) fflush(stderr);
++ }
++ else {
++ segment->text[segment->text_len] = 's';
++ (void) fprintf (fp, segment->text, scontext);
++ freecon(scontext);
++ }
++ }
++ break ;
++#endif /* WITH_SELINUX */
+ }
+ }
+ return true;
+@@ -1514,6 +1545,34 @@ pred_xtype (char *pathname, struct stat
+ */
+ return (pred_type (pathname, &sbuf, pred_ptr));
+ }
++
++
++#ifdef WITH_SELINUX
++
++boolean
++pred_scontext ( pathname, stat_buf, pred_ptr )
++ char *pathname;
++ struct stat *stat_buf;
++ struct predicate *pred_ptr;
++{
++ int rv;
++ security_context_t scontext;
++
++ rv = (* options.x_getfilecon)(state.rel_pathname, &scontext);
++
++ if ( rv < 0 ) {
++ (void) fprintf(stderr, "getfilecon(%s): %s\n", pathname, strerror(errno));
++ (void) fflush(stderr);
++ return ( false );
++ }
++
++ rv = (fnmatch(pred_ptr->args.scontext, scontext,0)==0);
++ freecon(scontext);
++ return rv;
++}
++
++#endif /*WITH_SELINUX*/
++
+
+ /* 1) fork to get a child; parent remembers the child pid
+ 2) child execs the command requested
+diff -urNp findutils-4.3.0.orig/find/util.c findutils-4.3.0/find/util.c
+--- findutils-4.3.0.orig/find/util.c 2005-12-06 21:04:24.000000000 -0500
++++ findutils-4.3.0/find/util.c 2005-12-23 23:18:46.668796004 -0500
+@@ -89,6 +89,9 @@ get_new_pred (const struct parser_table
+ last_pred->need_stat = true;
+ last_pred->need_type = true;
+ last_pred->args.str = NULL;
++#ifdef WITH_SELINUX
++ last_pred->args.scontext = NULL;
++#endif
+ last_pred->pred_next = NULL;
+ last_pred->pred_left = NULL;
+ last_pred->pred_right = NULL;
diff --git a/sys-apps/findutils/findutils-4.3.0.ebuild b/sys-apps/findutils/findutils-4.3.0.ebuild
index f9586c99d19e..c7ff6b67faf4 100644
--- a/sys-apps/findutils/findutils-4.3.0.ebuild
+++ b/sys-apps/findutils/findutils-4.3.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.3.0.ebuild,v 1.3 2005/12/19 19:09:38 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.3.0.ebuild,v 1.4 2005/12/24 04:53:22 pebenito Exp $
inherit eutils flag-o-matic toolchain-funcs
-SELINUX_PATCH="findutils-4.2.24-selinux.diff"
+SELINUX_PATCH="findutils-4.3.0-selinux.diff"
DESCRIPTION="GNU utilities for finding files"
HOMEPAGE="http://www.gnu.org/software/findutils/findutils.html"