summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-08-02 16:54:14 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-08-02 16:54:14 +0000
commitf37dd443b399f6d827bb034f2ba9c8c8163f6a3c (patch)
treeb310926cdac63418810131319dc1004fcaad69c6 /sys-apps/entropy
parentDowngrade back to version 1995 which does not show compilation issues. New ve... (diff)
downloadgentoo-2-f37dd443b399f6d827bb034f2ba9c8c8163f6a3c.tar.gz
gentoo-2-f37dd443b399f6d827bb034f2ba9c8c8163f6a3c.tar.bz2
gentoo-2-f37dd443b399f6d827bb034f2ba9c8c8163f6a3c.zip
version bump
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/entropy')
-rw-r--r--sys-apps/entropy/ChangeLog7
-rw-r--r--sys-apps/entropy/entropy-1.0_rc29.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/sys-apps/entropy/ChangeLog b/sys-apps/entropy/ChangeLog
index a361a047c1d7..4f92946f6a34 100644
--- a/sys-apps/entropy/ChangeLog
+++ b/sys-apps/entropy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/entropy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/ChangeLog,v 1.2 2011/07/19 12:37:06 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/ChangeLog,v 1.3 2011/08/02 16:54:14 lxnay Exp $
+
+*entropy-1.0_rc29 (02 Aug 2011)
+
+ 02 Aug 2011; Fabio Erculiani <lxnay@gentoo.org> +entropy-1.0_rc29.ebuild:
+ version bump
19 Jul 2011; Fabio Erculiani <lxnay@gentoo.org> entropy-1.0_rc27.ebuild:
update DESCRIPTION
diff --git a/sys-apps/entropy/entropy-1.0_rc29.ebuild b/sys-apps/entropy/entropy-1.0_rc29.ebuild
new file mode 100644
index 000000000000..5d99bd09562d
--- /dev/null
+++ b/sys-apps/entropy/entropy-1.0_rc29.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/entropy-1.0_rc29.ebuild,v 1.1 2011/08/02 16:54:14 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python multilib
+
+DESCRIPTION="Entropy Package Manager foundation library"
+HOMEPAGE="http://www.sabayon.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+SRC_URI="mirror://sabayon/${CATEGORY}/${P}.tar.bz2"
+
+RDEPEND="dev-db/sqlite[soundex]
+ net-misc/rsync
+ sys-apps/diffutils
+ sys-apps/sandbox
+ >=sys-apps/portage-2.1.9
+ sys-devel/gettext"
+DEPEND="${RDEPEND}
+ dev-util/intltool"
+
+REPO_CONFPATH="${ROOT}/etc/entropy/repositories.conf"
+ENTROPY_CACHEDIR="${ROOT}/var/lib/entropy/caches"
+
+pkg_setup() {
+ # Can:
+ # - update repos
+ # - update security advisories
+ # - handle on-disk cache (atm)
+ enewgroup entropy || die "failed to create entropy group"
+ # Create unprivileged entropy user
+ enewgroup entropy-nopriv || die "failed to create entropy-nopriv group"
+ enewuser entropy-nopriv -1 -1 -1 entropy-nopriv || die "failed to create entropy-nopriv user"
+}
+
+src_compile() {
+ # TODO: move to separate package
+ cd "${S}"/misc/po || die
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/$(get_libdir)" entropy-install || die "make install failed"
+
+ # TODO: move to separate package
+ cd "${S}"/misc/po || die
+ emake DESTDIR="${D}" LIBDIR="usr/$(get_libdir)" install || die "make install failed"
+}
+
+pkg_postinst() {
+
+ # Copy config file over
+ if [ -f "${REPO_CONFPATH}.example" ] && [ ! -f "${REPO_CONFPATH}" ]; then
+ einfo "Copying ${REPO_CONFPATH}.example over to ${REPO_CONFPATH}"
+ cp "${REPO_CONFPATH}.example" "${REPO_CONFPATH}" -p
+ fi
+ if [ -d "${ENTROPY_CACHEDIR}" ]; then
+ einfo "Purging current Entropy cache"
+ rm -rf "${ENTROPY_CACHEDIR}"/*
+ fi
+
+ python_mod_optimize "/usr/$(get_libdir)/entropy/libraries/entropy"
+
+ # force python 2.x
+ eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 --ignore 3.3
+
+ echo
+ elog "If you want to enable Entropy packages delta download support, please"
+ elog "install dev-util/bsdiff."
+ echo
+
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/$(get_libdir)/entropy/libraries/entropy"
+}