summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-02 05:00:27 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-02 05:00:27 +0000
commitf14bb0e3e142ac3a2bfe9e0b45399120aa9c5d71 (patch)
treec5db87134aa28113c8b5499bde1957ea23242bc8 /sys-apps/ed
parentversion bump, bug 256386. remove old version (diff)
downloadgentoo-2-f14bb0e3e142ac3a2bfe9e0b45399120aa9c5d71.tar.gz
gentoo-2-f14bb0e3e142ac3a2bfe9e0b45399120aa9c5d71.tar.bz2
gentoo-2-f14bb0e3e142ac3a2bfe9e0b45399120aa9c5d71.zip
Version bump.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/ed')
-rw-r--r--sys-apps/ed/ChangeLog10
-rw-r--r--sys-apps/ed/ed-1.2.ebuild39
-rw-r--r--sys-apps/ed/files/ed-1.2-build.patch38
3 files changed, 85 insertions, 2 deletions
diff --git a/sys-apps/ed/ChangeLog b/sys-apps/ed/ChangeLog
index d9973d734d61..806aafb7cb5d 100644
--- a/sys-apps/ed/ChangeLog
+++ b/sys-apps/ed/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/ed
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ChangeLog,v 1.73 2008/12/31 09:38:42 vapier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ChangeLog,v 1.74 2009/02/02 05:00:27 vapier Exp $
+
+*ed-1.2 (02 Feb 2009)
+
+ 02 Feb 2009; Mike Frysinger <vapier@gentoo.org> +files/ed-1.2-build.patch,
+ +ed-1.2.ebuild:
+ Version bump.
*ed-1.1 (31 Dec 2008)
diff --git a/sys-apps/ed/ed-1.2.ebuild b/sys-apps/ed/ed-1.2.ebuild
new file mode 100644
index 000000000000..ca12b1c1bf25
--- /dev/null
+++ b/sys-apps/ed/ed-1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ed-1.2.ebuild,v 1.1 2009/02/02 05:00:27 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Your basic line editor"
+HOMEPAGE="http://www.gnu.org/software/ed/"
+SRC_URI="mirror://gnu/ed/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="sys-apps/texinfo"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.2-build.patch
+}
+
+src_compile() {
+ tc-export CC CXX
+ # custom configure script ... econf wont work
+ ./configure \
+ --prefix=/ \
+ --datadir=/usr/share \
+ ${EXTRA_ECONF} \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/sys-apps/ed/files/ed-1.2-build.patch b/sys-apps/ed/files/ed-1.2-build.patch
new file mode 100644
index 000000000000..b13702e17175
--- /dev/null
+++ b/sys-apps/ed/files/ed-1.2-build.patch
@@ -0,0 +1,38 @@
+http://lists.gnu.org/archive/html/bug-ed/2008-12/msg00001.html
+
+2007-04-16 Mike Frysinger <vapier@gentoo.org>
+
+ * Do not set CC/CXX/CPPFLAGS/LDFLAGS to "" so that user can
+ override if they so choose.
+ * Only set CFLAGS/CXXFLAGS if user did not specify any.
+
+--- ed-1.0/configure
++++ ed-1.0/configure
+@@ -24,12 +37,6 @@
+ mandir='$(datadir)/man'
+ sysconfdir='$(prefix)/etc'
+ program_prefix=
+-CC=
+-CXX=
+-CPPFLAGS=
+-CFLAGS='-Wall -W -O2'
+-CXXFLAGS='-Wall -W -O2'
+-LDFLAGS=
+
+ # Loop over all args
+ while [ x"$1" != x ] ; do
+@@ -106,6 +113,14 @@
+ esac
+ done
+
++# Defaults if the user did not select any
++if [ x"${CFLAGS+set}" != xset ] ; then
++ CFLAGS='-Wall -W -O2'
++fi
++if [ x"${CXXFLAGS+set}" != xset ] ; then
++ CXXFLAGS='-Wall -W -O2'
++fi
++
+ # Find the source files, if location was not specified.
+ srcdirtext=
+ if [ x"${srcdir}" = x ] ; then