summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-09-06 20:33:31 +0000
committerMike Frysinger <vapier@gentoo.org>2010-09-06 20:33:31 +0000
commit0c7cc675f8ac908cd3a8c6723c2a5daa234749b7 (patch)
treecc352a3d3970598de8c30c54cc80cd93f27f2aea /sys-apps/ed
parentpunt old, use xfconf_use_debug (diff)
downloadgentoo-2-0c7cc675f8ac908cd3a8c6723c2a5daa234749b7.tar.gz
gentoo-2-0c7cc675f8ac908cd3a8c6723c2a5daa234749b7.tar.bz2
gentoo-2-0c7cc675f8ac908cd3a8c6723c2a5daa234749b7.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/ed')
-rw-r--r--sys-apps/ed/ChangeLog10
-rw-r--r--sys-apps/ed/ed-1.5.ebuild39
-rw-r--r--sys-apps/ed/files/ed-1.5-build.patch32
3 files changed, 79 insertions, 2 deletions
diff --git a/sys-apps/ed/ChangeLog b/sys-apps/ed/ChangeLog
index a4af301c5827..80faba369839 100644
--- a/sys-apps/ed/ChangeLog
+++ b/sys-apps/ed/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/ed
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ChangeLog,v 1.77 2009/07/15 16:15:47 vapier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ChangeLog,v 1.78 2010/09/06 20:33:31 vapier Exp $
+
+*ed-1.5 (06 Sep 2010)
+
+ 06 Sep 2010; Mike Frysinger <vapier@gentoo.org> +ed-1.5.ebuild,
+ +files/ed-1.5-build.patch:
+ Version bump.
*ed-1.4 (15 Jul 2009)
diff --git a/sys-apps/ed/ed-1.5.ebuild b/sys-apps/ed/ed-1.5.ebuild
new file mode 100644
index 000000000000..3c6e6e009f8a
--- /dev/null
+++ b/sys-apps/ed/ed-1.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ed-1.5.ebuild,v 1.1 2010/09/06 20:33:31 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Your basic line editor"
+HOMEPAGE="http://www.gnu.org/software/ed/"
+SRC_URI="mirror://gnu/ed/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="sys-apps/texinfo"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.5-build.patch
+}
+
+src_compile() {
+ tc-export CC
+ # custom configure script ... econf wont work
+ ./configure \
+ --prefix=/ \
+ --datadir=/usr/share \
+ ${EXTRA_ECONF} \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/sys-apps/ed/files/ed-1.5-build.patch b/sys-apps/ed/files/ed-1.5-build.patch
new file mode 100644
index 000000000000..83ee9c20cfb6
--- /dev/null
+++ b/sys-apps/ed/files/ed-1.5-build.patch
@@ -0,0 +1,32 @@
+http://lists.gnu.org/archive/html/bug-ed/2008-12/msg00001.html
+
+2007-04-16 Mike Frysinger <vapier@gentoo.org>
+
+ * Do not set CC/CXX/CPPFLAGS/LDFLAGS to "" so that user can
+ override if they so choose.
+ * Only set CFLAGS/CXXFLAGS if user did not specify any.
+
+--- ed-1.0/configure
++++ ed-1.0/configure
+@@ -26,10 +26,6 @@
+ mandir='$(datadir)/man'
+ sysconfdir='$(prefix)/etc'
+ program_prefix=
+-CC=
+-CPPFLAGS=
+-CFLAGS='-Wall -W -O2'
+-LDFLAGS=
+
+ # Loop over all args
+ while [ -n "$1" ] ; do
+@@ -105,6 +101,10 @@
+ esac
+ done
+
++# Defaults if the user did not select any
++if [ x"${CFLAGS+set}" != xset ] ; then
++ CFLAGS='-Wall -W -O2'
++fi
+ # Find the source files, if location was not specified.
+ srcdirtext=
+ if [ -z "${srcdir}" ] ; then