summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-08-04 18:22:45 +0000
committerPeter Gavin <pete@gentoo.org>2001-08-04 18:22:45 +0000
commit2104e6db8dc8fa0ead9a8c4ebebe51334d118641 (patch)
treeb77f143824f93937008d0135d208ecbafe8a28ee /sys-apps/console-tools
parentweb updates (diff)
downloadgentoo-2-2104e6db8dc8fa0ead9a8c4ebebe51334d118641.tar.gz
gentoo-2-2104e6db8dc8fa0ead9a8c4ebebe51334d118641.tar.bz2
gentoo-2-2104e6db8dc8fa0ead9a8c4ebebe51334d118641.zip
*** empty log message ***
Diffstat (limited to 'sys-apps/console-tools')
-rw-r--r--sys-apps/console-tools/console-tools-0.2.3-r4.ebuild69
-rw-r--r--sys-apps/console-tools/files/digest-console-tools-0.2.3-r41
2 files changed, 70 insertions, 0 deletions
diff --git a/sys-apps/console-tools/console-tools-0.2.3-r4.ebuild b/sys-apps/console-tools/console-tools-0.2.3-r4.ebuild
new file mode 100644
index 000000000000..eb8328bee2b2
--- /dev/null
+++ b/sys-apps/console-tools/console-tools-0.2.3-r4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/console-tools/console-tools-0.2.3-r4.ebuild,v 1.1 2001/08/04 18:22:45 pete Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Console and font utilities"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/keyboards/${P}.tar.gz"
+HOMEPAGE="http://altern.org/ydirson/en/lct/"
+
+DEPEND="virtual/glibc
+ sys-devel/autoconf sys-devel/automake sys-devel/libtool
+ nls? ( sys-devel/gettext )"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${P}.patch
+
+ patch -p0 < ${FILESDIR}/${P}-po-Makefile.in.in-gentoo.diff
+ try aclocal
+ try libtoolize --force -c
+ try autoheader
+ try automake -c
+ try autoconf
+}
+
+src_compile() {
+
+ local myconf
+
+ if [ "$DEBUG" ]
+ then
+ myconf="--enable-debugging"
+ fi
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ try ./configure --prefix=/usr --mandir=/usr/share/man --target=${CHOST} ${myconf}
+ try make $MAKEOPTS all
+}
+
+src_install() {
+
+ # DESTDIR does not work correct
+ try make DESTDIR=${D} install
+
+ if [ -z "`use bootcd`" ]
+ then
+ dodoc BUGS COPYING* CREDITS ChangeLog NEWS README RELEASE TODO
+ docinto txt
+ dodoc doc/*.txt doc/README.*
+ docinto sgml
+ dodoc doc/*.sgml
+ docinto txt/contrib
+ dodoc doc/contrib/*
+ docinto txt/dvorak
+ dodoc doc/dvorak/*
+ docinto txt/file-formats
+ dodoc doc/file-formats/*
+ doman doc/man/*.[1-8]
+ else
+ rm -rf ${D}/usr/share ${D}/usr/include ${D}/usr/lib/lib*.{a,la}
+ fi
+}
diff --git a/sys-apps/console-tools/files/digest-console-tools-0.2.3-r4 b/sys-apps/console-tools/files/digest-console-tools-0.2.3-r4
new file mode 100644
index 000000000000..7c2347441144
--- /dev/null
+++ b/sys-apps/console-tools/files/digest-console-tools-0.2.3-r4
@@ -0,0 +1 @@
+MD5 983d4586a791b3fdfa0fbeff76aadf43 console-tools-0.2.3.tar.gz