summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-01-15 13:48:23 +0000
committerThilo Bangert <bangert@gentoo.org>2010-01-15 13:48:23 +0000
commit88f99e4cb12dcb942129c6e0f26b5e46d590480a (patch)
tree965a8153865108f366ad08537391f1833fb3d25c /sys-apps/915resolution
parentVersion bump. Now uses ruby-ng-gnome2 eclass. (diff)
downloadgentoo-2-88f99e4cb12dcb942129c6e0f26b5e46d590480a.tar.gz
gentoo-2-88f99e4cb12dcb942129c6e0f26b5e46d590480a.tar.bz2
gentoo-2-88f99e4cb12dcb942129c6e0f26b5e46d590480a.zip
add support for 945GME (#238349)
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'sys-apps/915resolution')
-rw-r--r--sys-apps/915resolution/915resolution-0.5.3-r3.ebuild53
-rw-r--r--sys-apps/915resolution/ChangeLog10
-rw-r--r--sys-apps/915resolution/files/915resolution-0.5.3-945GME.patch54
3 files changed, 115 insertions, 2 deletions
diff --git a/sys-apps/915resolution/915resolution-0.5.3-r3.ebuild b/sys-apps/915resolution/915resolution-0.5.3-r3.ebuild
new file mode 100644
index 000000000000..153d0f20e4b3
--- /dev/null
+++ b/sys-apps/915resolution/915resolution-0.5.3-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/915resolution/915resolution-0.5.3-r3.ebuild,v 1.1 2010/01/15 13:48:22 bangert Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Utility to patch VBIOS of Intel 855 / 865 / 915 chipsets"
+HOMEPAGE="http://915resolution.mango-lang.org/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-freebsd.patch"
+
+ # add support for 965GM (bug #186661)
+ epatch "${FILESDIR}/${P}-965GM.patch"
+ epatch "${FILESDIR}/${P}-945GME.patch"
+}
+
+src_compile() {
+ filter-flags -O*
+ emake clean
+ emake CFLAGS="${CFLAGS}" || die "Compiliation failed."
+}
+
+src_install() {
+ dosbin ${PN}
+ newconfd "${FILESDIR}/confd" ${PN}
+ newinitd "${FILESDIR}/initd-r1" ${PN}
+ dodoc README.txt changes.log chipset_info.txt dump_bios
+}
+
+pkg_postinst() {
+ elog
+ elog "${PN} alters your video BIOS in a non-permanent way, this means"
+ elog "that there is no risk of permanent damage to your video card, but"
+ elog "it also means that it must be run at every boot. To set it up, "
+ elog "edit /etc/conf.d/${PN} to add your configuration and type the"
+ elog "following command to add it the your defautl runlevel:"
+ elog
+ elog " \"rc-update add ${PN} default\""
+ elog
+}
diff --git a/sys-apps/915resolution/ChangeLog b/sys-apps/915resolution/ChangeLog
index 192a6ebd38a8..e0a089205a76 100644
--- a/sys-apps/915resolution/ChangeLog
+++ b/sys-apps/915resolution/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/915resolution
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/915resolution/ChangeLog,v 1.15 2009/12/15 18:05:58 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/915resolution/ChangeLog,v 1.16 2010/01/15 13:48:22 bangert Exp $
+
+*915resolution-0.5.3-r3 (15 Jan 2010)
+
+ 15 Jan 2010; Thilo Bangert <bangert@gentoo.org>
+ +915resolution-0.5.3-r3.ebuild, +files/915resolution-0.5.3-945GME.patch:
+ add support for 945GME (#238349)
15 Dec 2009; Samuli Suominen <ssuominen@gentoo.org>
915resolution-0.5.3-r2.ebuild:
diff --git a/sys-apps/915resolution/files/915resolution-0.5.3-945GME.patch b/sys-apps/915resolution/files/915resolution-0.5.3-945GME.patch
new file mode 100644
index 000000000000..fb10b3b800d3
--- /dev/null
+++ b/sys-apps/915resolution/files/915resolution-0.5.3-945GME.patch
@@ -0,0 +1,54 @@
+--- 915resolution-0.5.3/915resolution.c_orig 2008-09-21 22:16:05.000000000 -0400
++++ 915resolution-0.5.3/915resolution.c 2008-09-21 22:19:30.000000000 -0400
+@@ -65,12 +65,12 @@
+ typedef unsigned int cardinal;
+
+ typedef enum {
+- CT_UNKWN, CT_830, CT_845G, CT_855GM, CT_865G, CT_915G, CT_915GM, CT_945G, CT_945GM,
++ CT_UNKWN, CT_830, CT_845G, CT_855GM, CT_865G, CT_915G, CT_915GM, CT_945G, CT_945GM, CT_945GME,
+ CT_946GZ, CT_G965, CT_Q965, CT_965GM
+ } chipset_type;
+
+ char * chipset_type_names[] = {
+- "UNKNOWN", "830", "845G", "855GM", "865G", "915G", "915GM", "945G", "945GM",
++ "UNKNOWN", "830", "845G", "855GM", "865G", "915G", "915GM", "945G", "945GM", "945GME",
+ "946GZ", "G965", "Q965", "965GM"
+ };
+
+@@ -237,6 +237,10 @@
+ type = CT_945GM;
+ break;
+
++ case 0x27ac8086:
++ type = CT_945GME;
++ break;
++
+ case 0x29708086:
+ type = CT_946GZ;
+ break;
+@@ -536,6 +540,7 @@
+ case CT_915GM:
+ case CT_945G:
+ case CT_945GM:
++ case CT_945GME:
+ case CT_946GZ:
+ case CT_G965:
+ case CT_Q965:
+@@ -577,6 +582,7 @@
+ case CT_915GM:
+ case CT_945G:
+ case CT_945GM:
++ case CT_945GME:
+ case CT_946GZ:
+ case CT_G965:
+ case CT_Q965:
+@@ -833,6 +839,9 @@
+ else if (!strcmp(argv[index], "945GM")) {
+ *forced_chipset = CT_945GM;
+ }
++ else if (!strcmp(argv[index], "945GME")) {
++ *forced_chipset = CT_945GME;
++ }
+ else if (!strcmp(argv[index], "946GZ")) {
+ *forced_chipset = CT_946GZ;
+ }