summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2007-03-30 13:29:49 +0000
committerChris PeBenito <pebenito@gentoo.org>2007-03-30 13:29:49 +0000
commit97dc31ed5b4a6ab02cb6d3dfa71917b2a3f78eb3 (patch)
tree424b1357cb51caefd3b9a16492ba5092f083ac42 /sec-policy/selinux-base-policy
parentStable on sparc wrt #172722 (diff)
downloadgentoo-2-97dc31ed5b4a6ab02cb6d3dfa71917b2a3f78eb3.tar.gz
gentoo-2-97dc31ed5b4a6ab02cb6d3dfa71917b2a3f78eb3.tar.bz2
gentoo-2-97dc31ed5b4a6ab02cb6d3dfa71917b2a3f78eb3.zip
add compile fix for selinux base policy
(Portage version: 2.1.2.3)
Diffstat (limited to 'sec-policy/selinux-base-policy')
-rw-r--r--sec-policy/selinux-base-policy/ChangeLog7
-rw-r--r--sec-policy/selinux-base-policy/files/selinux-base-policy-20070329.diff96
-rw-r--r--sec-policy/selinux-base-policy/selinux-base-policy-20070329.ebuild5
3 files changed, 106 insertions, 2 deletions
diff --git a/sec-policy/selinux-base-policy/ChangeLog b/sec-policy/selinux-base-policy/ChangeLog
index 01603bc0dcd9..59d3fd039261 100644
--- a/sec-policy/selinux-base-policy/ChangeLog
+++ b/sec-policy/selinux-base-policy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sec-policy/selinux-base-policy
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.56 2007/03/29 23:37:50 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.57 2007/03/30 13:29:49 pebenito Exp $
+
+ 30 Mar 2007; Chris PeBenito <pebenito@gentoo.org>
+ +files/selinux-base-policy-20070329.diff,
+ selinux-base-policy-20070329.ebuild:
+ Compile fix.
*selinux-base-policy-20070329 (29 Mar 2007)
diff --git a/sec-policy/selinux-base-policy/files/selinux-base-policy-20070329.diff b/sec-policy/selinux-base-policy/files/selinux-base-policy-20070329.diff
new file mode 100644
index 000000000000..4a6f55cdc7df
--- /dev/null
+++ b/sec-policy/selinux-base-policy/files/selinux-base-policy-20070329.diff
@@ -0,0 +1,96 @@
+Index: policy/support/loadable_module.spt
+===================================================================
+--- policy/support/loadable_module.spt (revision 2248)
++++ policy/support/loadable_module.spt (revision 2249)
+@@ -128,10 +128,10 @@
+ # This needs to be reworked so expressions
+ # with parentheses can work.
+
+-define(`delcare_required_symbols',`
++define(`declare_required_symbols',`
+ ifelse(regexp($1, `\w'), -1, `', `dnl
+ bool regexp($1, `\(\w+\)', `\1');
+-delcare_required_symbols(regexp($1, `\w+\(.*\)', `\1'))dnl
++declare_required_symbols(regexp($1, `\w+\(.*\)', `\1'))dnl
+ ') dnl
+ ')
+
+@@ -140,16 +140,7 @@
+ # Tunable declaration
+ #
+ define(`gen_tunable',`
+- ifdef(`self_contained_policy',`
+- bool $1 dflt_or_overr(`$1'_conf,$2);
+- ',`
+- # loadable module tunable
+- # declaration will go here
+- # instead of bool when
+- # loadable modules support
+- # tunables
+- bool $1 dflt_or_overr(`$1'_conf,$2);
+- ')
++ bool $1 dflt_or_overr(`$1'_conf,$2);
+ ')
+
+ ##############################
+@@ -157,24 +148,12 @@
+ # Tunable policy handling
+ #
+ define(`tunable_policy',`
+- ifdef(`self_contained_policy',`
+- if (`$1') {
+- $2
+- ifelse(`$3',`',`',`} else {
+- $3
+- ')}
+- ',`
+- # structure for tunables
+- # will go here instead of a
+- # conditional when loadable
+- # modules support tunables
+- gen_require(`
+- delcare_required_symbols(`$1')
+- ')
+- if (`$1') {
+- $2
+- ifelse(`$3',`',`',`} else {
+- $3
+- ')}
++ gen_require(`
++ declare_required_symbols(`$1')
+ ')
++ if (`$1') {
++ $2
++ ifelse(`$3',`',`',`} else {
++ $3
++ ')}
+ ')
+Index: support/comment_move_decl.sed
+===================================================================
+--- support/comment_move_decl.sed (revision 2248)
++++ support/comment_move_decl.sed (revision 2249)
+@@ -5,9 +5,10 @@
+ /require \{/,/} # end require/b nextline
+ /optional \{/,/} # end optional/b nextline
+
+-/^[[:blank:]]*(attribute|type(alias)?) / s/^/# this line was moved by the build process: &/
++/^[[:blank:]]*(attribute|type(alias)?) /s/^/# this line was moved by the build process: &/
+ /^[[:blank:]]*(port|node|netif|genfs)con /s/^/# this line was moved by the build process: &/
+ /^[[:blank:]]*fs_use_(xattr|task|trans) /s/^/# this line was moved by the build process: &/
+ /^[[:blank:]]*sid /s/^/# this line was moved by the build process: &/
++/^[[:blank:]]*bool /s/^/# this line was moved by the build process: &/
+
+ :nextline
+Index: support/get_type_attr_decl.sed
+===================================================================
+--- support/get_type_attr_decl.sed (revision 2248)
++++ support/get_type_attr_decl.sed (revision 2249)
+@@ -5,7 +5,7 @@
+ /require \{/,/} # end require/b nextline
+ /optional \{/,/} # end optional/b nextline
+
+-/^[[:blank:]]*(attribute|type(alias)?) /{
++/^[[:blank:]]*(attribute|type(alias)?|bool) /{
+ s/^[[:blank:]]+//
+ p
+ }
diff --git a/sec-policy/selinux-base-policy/selinux-base-policy-20070329.ebuild b/sec-policy/selinux-base-policy/selinux-base-policy-20070329.ebuild
index 2e212327d399..3a754916f03a 100644
--- a/sec-policy/selinux-base-policy/selinux-base-policy-20070329.ebuild
+++ b/sec-policy/selinux-base-policy/selinux-base-policy-20070329.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/selinux-base-policy-20070329.ebuild,v 1.1 2007/03/29 23:37:50 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/selinux-base-policy-20070329.ebuild,v 1.2 2007/03/30 13:29:49 pebenito Exp $
IUSE=""
@@ -27,6 +27,9 @@ src_unpack() {
unpack ${A}
+ cd ${S}/refpolicy
+ epatch ${FILESDIR}/${PN}-${PV}.diff
+
for i in ${POLICY_TYPES}; do
mkdir -p ${S}/${i}/policy
cp ${FILESDIR}/modules.conf.${i} ${S}/${i}/policy/modules.conf