summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2015-04-10 15:23:54 +0000
committerDavide Pesavento <pesa@gentoo.org>2015-04-10 15:23:54 +0000
commitd3d8a70d9886686b24abdc8077f89a187abf7b33 (patch)
treed0300339c7083cad522b5c6e57d8ad7f405a7fdd /sci-visualization
parentApply a fix for FreeBSD-SA-15:09.ipv6. https://github.com/gentoo/gentoo-porta... (diff)
downloadgentoo-2-d3d8a70d9886686b24abdc8077f89a187abf7b33.tar.gz
gentoo-2-d3d8a70d9886686b24abdc8077f89a187abf7b33.tar.bz2
gentoo-2-d3d8a70d9886686b24abdc8077f89a187abf7b33.zip
Version bump wrt bug 541692. Also fixes bug 510152.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xDADED6B2671CB57D!)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/kst/ChangeLog8
-rw-r--r--sci-visualization/kst/files/kst-2.0.4-cfitsio-includes.patch39
-rw-r--r--sci-visualization/kst/kst-2.0.8.ebuild67
3 files changed, 74 insertions, 40 deletions
diff --git a/sci-visualization/kst/ChangeLog b/sci-visualization/kst/ChangeLog
index 5fbef1f65172..ba6c2eaaf3b0 100644
--- a/sci-visualization/kst/ChangeLog
+++ b/sci-visualization/kst/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/kst
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/kst/ChangeLog,v 1.15 2015/03/01 13:17:15 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/kst/ChangeLog,v 1.16 2015/04/10 15:23:54 pesa Exp $
+
+*kst-2.0.8 (10 Apr 2015)
+
+ 10 Apr 2015; Davide Pesavento <pesa@gentoo.org> +kst-2.0.8.ebuild,
+ -files/kst-2.0.4-cfitsio-includes.patch:
+ Version bump wrt bug 541692. Also fixes bug 510152.
01 Mar 2015; Michał Górny <mgorny@gentoo.org> -kst-2.0.6.ebuild:
Remove old version with non-solvable deps.
diff --git a/sci-visualization/kst/files/kst-2.0.4-cfitsio-includes.patch b/sci-visualization/kst/files/kst-2.0.4-cfitsio-includes.patch
deleted file mode 100644
index e9dfccf6683e..000000000000
--- a/sci-visualization/kst/files/kst-2.0.4-cfitsio-includes.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/src/datasources/healpix/healpix_tools.h b/src/datasources/healpix/healpix_tools.h
-index 28ad906..420fc7f 100644
---- a/src/datasources/healpix/healpix_tools.h
-+++ b/src/datasources/healpix/healpix_tools.h
-@@ -19,7 +19,7 @@
- #define HEALPIX_TOOLS_H
-
- #include <math.h>
--#include <libcfitsio0/fitsio.h>
-+#include <fitsio.h>
- #include <datasource.h>
-
- # ifdef HEALPIX_PI
-diff --git a/src/datasources/lfiio/lfiio.h b/src/datasources/lfiio/lfiio.h
-index bb6493c..8ed748c 100644
---- a/src/datasources/lfiio/lfiio.h
-+++ b/src/datasources/lfiio/lfiio.h
-@@ -18,7 +18,7 @@
-
- #include <datasource.h>
- #include <dataplugin.h>
--#include <libcfitsio0/fitsio.h>
-+#include <fitsio.h>
-
- class LFIIOSource : public Kst::DataSource {
- Q_OBJECT
-diff --git a/src/datasources/planckIDEF/planckIDEF.h b/src/datasources/planckIDEF/planckIDEF.h
-index 7fb226f..6e6d82f 100644
---- a/src/datasources/planckIDEF/planckIDEF.h
-+++ b/src/datasources/planckIDEF/planckIDEF.h
-@@ -16,7 +16,7 @@
-
- #include <datasource.h>
- #include <dataplugin.h>
--#include <libcfitsio0/fitsio.h>
-+#include <fitsio.h>
-
- typedef struct {
- QString file;
diff --git a/sci-visualization/kst/kst-2.0.8.ebuild b/sci-visualization/kst/kst-2.0.8.ebuild
new file mode 100644
index 000000000000..aa1dc9e5d081
--- /dev/null
+++ b/sci-visualization/kst/kst-2.0.8.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/kst/kst-2.0.8.ebuild,v 1.1 2015/04/10 15:23:54 pesa Exp $
+
+EAPI=5
+
+inherit cmake-utils multilib
+
+MY_P=Kst-${PV}
+
+DESCRIPTION="Fast real-time large-dataset viewing and plotting tool"
+HOMEPAGE="http://kst.kde.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +qt4 qt5 test"
+
+REQUIRED_USE="^^ ( qt4 qt5 )"
+
+RESTRICT="test"
+
+RDEPEND="
+ qt4? (
+ dev-qt/designer:4
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ dev-qt/qtsvg:4
+ )
+ qt5? (
+ dev-qt/designer:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ )
+ sci-libs/cfitsio
+ sci-libs/getdata
+ sci-libs/gsl
+ sci-libs/netcdf-cxx:3
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:4 )
+"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS README.kstScript )
+
+src_configure() {
+ local mycmakeargs=(
+ -Dkst_install_libdir="$(get_libdir)"
+ -Dkst_pch=OFF
+ -Dkst_release=$(usex debug OFF ON)
+ -Dkst_rpath=OFF
+ -Dkst_svnversion=OFF
+ $(cmake-utils_use test kst_test)
+ $(cmake-utils_use qt5 kst_qt5)
+ )
+ cmake-utils_src_configure
+}