summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-10-30 15:34:59 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-10-30 15:34:59 +0000
commitc7999bbe25cc5e69ed8b7c34c2c82d7c69fced29 (patch)
tree37b552f3416b748490b6583f523b901c6648d916 /sci-visualization
parentAdded www-apps/tikiwiki-2.2 (sec issue #243854). (diff)
downloadgentoo-2-c7999bbe25cc5e69ed8b7c34c2c82d7c69fced29.tar.gz
gentoo-2-c7999bbe25cc5e69ed8b7c34c2c82d7c69fced29.tar.bz2
gentoo-2-c7999bbe25cc5e69ed8b7c34c2c82d7c69fced29.zip
Fixed wrong installation path and went back to EAPI=1 to ease installation for users of the stable branch. Also rolled back the OpenFOAM patch one version since the newer seems to cause problems.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-SENTINEL-1 i686)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/paraview/ChangeLog7
-rw-r--r--sci-visualization/paraview/paraview-3.4.0.ebuild22
2 files changed, 20 insertions, 9 deletions
diff --git a/sci-visualization/paraview/ChangeLog b/sci-visualization/paraview/ChangeLog
index 9a42fe53f996..4398d161faa3 100644
--- a/sci-visualization/paraview/ChangeLog
+++ b/sci-visualization/paraview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/paraview
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/ChangeLog,v 1.27 2008/10/28 21:41:15 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/ChangeLog,v 1.28 2008/10/30 15:34:59 markusle Exp $
+
+ 30 Oct 2008; Markus Dittrich <markusle@gentoo.org> paraview-3.4.0.ebuild:
+ Fixed wrong installation path and went back to EAPI=1 to ease
+ installation for users of the stable branch. Also rolled back the
+ OpenFOAM patch one version since the newer seems to cause problems.
*paraview-3.4.0 (28 Oct 2008)
diff --git a/sci-visualization/paraview/paraview-3.4.0.ebuild b/sci-visualization/paraview/paraview-3.4.0.ebuild
index ae2463195da7..bb11f5fe82c6 100644
--- a/sci-visualization/paraview/paraview-3.4.0.ebuild
+++ b/sci-visualization/paraview/paraview-3.4.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/paraview-3.4.0.ebuild,v 1.1 2008/10/28 21:41:15 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/paraview-3.4.0.ebuild,v 1.2 2008/10/30 15:34:59 markusle Exp $
-EAPI="2"
+EAPI="1"
inherit distutils eutils flag-o-matic toolchain-funcs versionator python qt4
@@ -12,7 +12,7 @@ PATCH_V="${MY_PV}_pre20080514"
DESCRIPTION="ParaView is a powerful scientific data visualization application"
HOMEPAGE="http://www.paraview.org"
SRC_URI="mirror://gentoo/${P}.tar.gz
- mirror://gentoo/${P}-OpenFOAM.patch.bz2"
+ mirror://gentoo/${P}-OpenFOAM-20080728.patch.bz2"
LICENSE="paraview"
KEYWORDS="~x86 ~amd64"
@@ -21,7 +21,7 @@ IUSE="mpi python hdf5 doc examples threads qt4"
RDEPEND="hdf5? ( sci-libs/hdf5 )
mpi? ( || (
sys-cluster/openmpi
- sys-cluster/mpich2[cxx] ) )
+ sys-cluster/mpich2 ) )
python? ( >=dev-lang/python-2.0 )
qt4? ( || ( ( x11-libs/qt-gui:4 x11-libs/qt-qt3support:4
x11-libs/qt-assistant:4 )
@@ -42,12 +42,18 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
>=dev-util/cmake-2.4.5"
-PVLIBDIR="$(get_libdir)/${PN}-${MY_PV}"
+PVLIBDIR="$(get_libdir)/${P}"
BUILDDIR="${WORKDIR}/build"
S="${WORKDIR}"/ParaView-${PV}
+
pkg_setup() {
use qt4 && qt4_pkg_setup
+ if use mpi && has_version sys-cluster/mpich2; then
+ if ! built_with_use sys-cluster/mpich2 cxx; then
+ die "Please re-emerge sys-cluster/mpich2 with USE=\"cxx\""
+ fi
+ fi
}
src_unpack() {
@@ -56,7 +62,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${PN}-${PATCH_V}-gcc4.3.patch
epatch "${FILESDIR}"/${PN}-${PATCH_V}-qt4.4.patch
- epatch "${DISTDIR}"/${P}-OpenFOAM.patch.bz2
+ epatch "${DISTDIR}"/${P}-OpenFOAM-20080728.patch.bz2
# rename paraview's assistant wrapper
if use qt4; then
@@ -150,12 +156,12 @@ src_install() {
if use qt4; then
mv "${D}"/usr/bin/assistant "${D}"/usr/bin/paraview-assistant \
|| die "Failed to rename assistant wrapper"
- chmod 0755 "${D}"/usr/$(get_libdir)/${PN}-${MY_PV}/assistant-real \
+ chmod 0755 "${D}"/usr/${PVLIBDIR}/assistant-real \
|| die "Failed to change permissions on assistant wrapper"
fi
# add release note for the OpenFOAM-1.5 patch
- dodoc "${S}"/ReleaseNotes_OpenFOAMReader20080831
+ dodoc "${S}"/ReleaseNotes_OpenFOAMReader20080728
# set up the environment
echo "LDPATH=/usr/${PVLIBDIR}" >> "${T}"/40${PN}