summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-11-14 14:04:46 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-11-14 14:04:46 +0000
commit938ef7491ece5f4d0a82d2e8a60b70be395cc283 (patch)
treec0aae932c14c3fa72e9493e6f1a2a7f68fb74800 /sci-visualization
parentVersion bump. (diff)
downloadgentoo-2-938ef7491ece5f4d0a82d2e8a60b70be395cc283.tar.gz
gentoo-2-938ef7491ece5f4d0a82d2e8a60b70be395cc283.tar.bz2
gentoo-2-938ef7491ece5f4d0a82d2e8a60b70be395cc283.zip
Added patch to fix compile problems with python disabled (#246473).
(Portage version: 2.2_rc13/cvs/Linux 2.6.27-SENTINEL-2 i686)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/qtiplot/ChangeLog6
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.7.3-no-python.patch62
-rw-r--r--sci-visualization/qtiplot/qtiplot-0.9.7.3.ebuild3
3 files changed, 69 insertions, 2 deletions
diff --git a/sci-visualization/qtiplot/ChangeLog b/sci-visualization/qtiplot/ChangeLog
index b460868c6f1f..19bcc6cce651 100644
--- a/sci-visualization/qtiplot/ChangeLog
+++ b/sci-visualization/qtiplot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-visualization/qtiplot
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.36 2008/10/24 22:50:43 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.37 2008/11/14 14:04:46 markusle Exp $
+
+ 13 Nov 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/qtiplot-0.9.7.3-no-python.patch, qtiplot-0.9.7.3.ebuild:
+ Added patch to fix compile problems with python disabled (#246473).
*qtiplot-0.9.7.3 (24 Oct 2008)
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.7.3-no-python.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.7.3-no-python.patch
new file mode 100644
index 000000000000..841ac78df38e
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.7.3-no-python.patch
@@ -0,0 +1,62 @@
+diff -Naur qtiplot-0.9.7.3/qtiplot/src/scripting/ScriptEdit.cpp qtiplot-0.9.7.3.new/qtiplot/src/scripting/ScriptEdit.cpp
+--- qtiplot-0.9.7.3/qtiplot/src/scripting/ScriptEdit.cpp 2008-10-20 11:59:25.000000000 -0400
++++ qtiplot-0.9.7.3.new/qtiplot/src/scripting/ScriptEdit.cpp 2008-11-13 09:10:48.000000000 -0500
+@@ -28,7 +28,11 @@
+ ***************************************************************************/
+ #include "ScriptEdit.h"
+ #include "Note.h"
++
++#ifdef SCRIPTING_PYTHON
+ #include "PythonSyntaxHighlighter.h"
++#endif
++
+ #include "FindReplaceDialog.h"
+
+ #include <QAction>
+@@ -58,9 +62,11 @@
+ setTextFormat(Qt::PlainText);
+ setAcceptRichText (false);
+
++#ifdef SCRIPTING_PYTHON
+ if (scriptEnv->name() == QString("Python"))
+ d_highlighter = new PythonSyntaxHighlighter(this);
+-
++#endif
++
+ d_fmt_default.setBackground(palette().brush(QPalette::Base));
+ d_fmt_failure.setBackground(QBrush(QColor(255,128,128)));
+
+@@ -142,6 +148,7 @@
+ connect(myScript, SIGNAL(error(const QString&, const QString&, int)), this, SLOT(insertErrorMsg(const QString&)));
+ connect(myScript, SIGNAL(print(const QString&)), this, SLOT(scriptPrint(const QString&)));
+
++#ifdef SCRIPTING_PYTHON
+ if (scriptEnv->name() == QString("Python") && !d_highlighter)
+ d_highlighter = new PythonSyntaxHighlighter(this);
+ else {
+@@ -149,6 +156,7 @@
+ delete d_highlighter;
+ d_highlighter = 0;
+ }
++#endif
+ }
+ }
+
+@@ -585,13 +593,16 @@
+
+ void ScriptEdit::rehighlight()
+ {
++#ifdef SCRIPTING_PYTHON
+ if (scriptEnv->name() != QString("Python"))
+ return;
+-
++#endif
+ if (d_highlighter)
+ delete d_highlighter;
+
++#ifdef SCRIPTING_PYTHON
+ d_highlighter = new PythonSyntaxHighlighter(this);
++#endif
+ }
+
+ void ScriptEdit::showFindDialog(bool replace)
diff --git a/sci-visualization/qtiplot/qtiplot-0.9.7.3.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.7.3.ebuild
index be9b972f15da..706c7f0890aa 100644
--- a/sci-visualization/qtiplot/qtiplot-0.9.7.3.ebuild
+++ b/sci-visualization/qtiplot/qtiplot-0.9.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.7.3.ebuild,v 1.1 2008/10/24 22:50:43 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.7.3.ebuild,v 1.2 2008/11/14 14:04:46 markusle Exp $
EAPI="1"
inherit eutils multilib qt4 fdo-mime python
@@ -49,6 +49,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-qwt3d.patch
epatch "${FILESDIR}"/${PN}-0.9.7-gcc4.3.patch
epatch "${FILESDIR}"/${PN}-0.9.7.2-liborigin-gcc4.3.patch
+ epatch "${FILESDIR}"/${P}-no-python.patch
sed -i \
-e '/manual/d'\