summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-04-08 08:50:47 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-04-08 08:50:47 +0000
commit7e07d16f995db26a1f5eb7952f1a8fd66afd99e2 (patch)
treee464270b350512ee5c4e5fc5bef197c1c53dc365 /sci-visualization
parentversion bump, bug #264829 and bug #265342 (diff)
downloadgentoo-2-7e07d16f995db26a1f5eb7952f1a8fd66afd99e2.tar.gz
gentoo-2-7e07d16f995db26a1f5eb7952f1a8fd66afd99e2.tar.bz2
gentoo-2-7e07d16f995db26a1f5eb7952f1a8fd66afd99e2.zip
Initial import (and bump) to the main tree from the science overlay
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/scidavis/ChangeLog20
-rw-r--r--sci-visualization/scidavis/files/scidavis-0.2.1-profile.patch76
-rw-r--r--sci-visualization/scidavis/metadata.xml10
-rw-r--r--sci-visualization/scidavis/scidavis-0.2.1.ebuild74
4 files changed, 180 insertions, 0 deletions
diff --git a/sci-visualization/scidavis/ChangeLog b/sci-visualization/scidavis/ChangeLog
new file mode 100644
index 000000000000..62e9b9f77337
--- /dev/null
+++ b/sci-visualization/scidavis/ChangeLog
@@ -0,0 +1,20 @@
+# ChangeLog for sci-visualization/scidavis
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/scidavis/ChangeLog,v 1.1 2009/04/08 08:50:47 bicatali Exp $
+
+*scidavis-0.2.1 (08 Apr 2009)
+
+ 08 Apr 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/scidavis-0.2.1-profile.patch, +metadata.xml,
+ +scidavis-0.2.1.ebuild:
+ Initial import (and bump) to the main tree from the science overlay
+
+ 24 Aug 2008; Tim Cera <timcera@earthlink.net> scidavis-0.1.3.ebuild:
+ Indented on two lines with spaces instead of tabs.
+
+*scidavis-0.1.3 (18 May 2008)
+
+ 18 May 2008; Andrey Grozin <grozin@gentoo.org> +metadata.xml,
+ +scidavis-0.1.3.ebuild, +files/scidavis-0.1.3-profile.patch,
+ +files/scidavis-0.1.3-fitplugins.patch:
+ Initial import, closing bug #222527
diff --git a/sci-visualization/scidavis/files/scidavis-0.2.1-profile.patch b/sci-visualization/scidavis/files/scidavis-0.2.1-profile.patch
new file mode 100644
index 000000000000..6caa5664c454
--- /dev/null
+++ b/sci-visualization/scidavis/files/scidavis-0.2.1-profile.patch
@@ -0,0 +1,76 @@
+--- scidavis/scidavis.pro.orig 2009-03-31 16:56:38.000000000 +0100
++++ scidavis/scidavis.pro 2009-03-31 17:13:15.000000000 +0100
+@@ -26,8 +26,8 @@
+ LUPDATE_BIN = lupdate
+ LRELEASE_BIN = lrelease
+ } else { ### Linux (and other Unix systems)
+-LUPDATE_BIN = lupdate-qt4
+-LRELEASE_BIN = lrelease-qt4
++LUPDATE_BIN = lupdate
++LRELEASE_BIN = lrelease
+ }
+
+ ### 64 Linux only suffix
+@@ -52,7 +52,7 @@
+ ### scidavisrc.py and scidavisUtil.py, respectively. Alternatively you can also put scidavisrc.py
+ ### (or ".scidavis.py") into the users home directory. scidavisUtil.py must be either in the
+ ### directory specified here or somewhere else in the python path (sys.path) where "import" can find it
+-unix: pythonconfig.path = /etc # where scidavisrc.py is installed
++unix: pythonconfig.path = $$INSTALLBASE/share/scidavis # where scidavisrc.py is installed
+ win32: pythonconfig.path = $$INSTALLBASE
+ unix: pythonutils.path = $$INSTALLBASE/share/scidavis # where the scidavisUtil python modules is installed
+ win32: pythonutils.path = $$INSTALLBASE
+@@ -71,7 +71,8 @@
+ ### Note to packagers: If you want to use systemwide installed liborigin
+ ### instead of the one provided in "3rdparty", uncomment the following 2 lines:
+ # CONFIG += dynamic_liborigin
+-# LIBS += -lorigin
++LIBS += -lorigin2
++INCLUDEPATH += /usr/include/liborigin2
+ ### Unfortunately, due to liborigin being in alpha stage, we cannot promise
+ ### that SciDAVis works with any other version that the one in "3rdparty".
+ ################### end of liborigin block
+@@ -83,18 +84,17 @@
+ ### are compiled against Qt4), dynamically against everything else.
+ #############################################################################
+
+-unix:INCLUDEPATH += ../3rdparty/qwtplot3d/include
+-unix:LIBS += ../3rdparty/qwtplot3d/lib/libqwtplot3d.a
++unix:INCLUDEPATH += /usr/include/qwtplot3d
++unix:LIBS += -lqwtplot3d
+
+-unix:INCLUDEPATH += ../3rdparty/qwt/src
+-unix:LIBS += ../3rdparty/qwt/lib/libqwt.a
++unix:INCLUDEPATH += /usr/include/qwt5
++unix:LIBS += -lqwt
+
+-unix:LIBS += -L/usr/lib$${libsuff}
+-unix:LIBS += -lgsl -lgslcblas -lz
+-### muparser 1.30 does not compile as a shared lib on Linux
+-unix:LIBS += -L/usr/local/lib$${libsuff}
+-unix:LIBS += /usr/local/lib/libmuparser.a
+-unix:INCLUDEPATH += /usr/local/include
++unix:INCLUDEPATH += $$system(pkg-config --cflags gsl)
++unix:LIBS += $$system(pkg-config --libs gsl)
++unix:LIBS += $$system(pkg-config --libs muparser)
++unix:INCLUDEPATH += $$system(pkg-config --cflags muparser)
++unix:LIBS += -lz
+
+ #############################################################################
+ ### Link everything dynamically
+--- scidavis/sourcefiles.pri.orig 2009-03-31 17:15:04.000000000 +0100
++++ scidavis/sourcefiles.pri 2009-03-31 17:15:48.000000000 +0100
+@@ -42,12 +42,8 @@
+ ###################### DOCUMENTATION ########################################
+
+ documentation.files += ../manual/html \
+- ../INSTALL.html \
+ ../scidavis.css \
+- ../scidavis-logo.png \
+- ../README \
+- ../CHANGES \
+- ../gpl.txt
++ ../scidavis-logo.png
+
+ ###################### DESKTOP INTEGRATION ##################################
+
diff --git a/sci-visualization/scidavis/metadata.xml b/sci-visualization/scidavis/metadata.xml
new file mode 100644
index 000000000000..0b0a3a22f46b
--- /dev/null
+++ b/sci-visualization/scidavis/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ SciDAVis is a free (GPL), user-friendly, platform independent data
+ analysis and visualization application similar, based on QtiPlot,
+ and similar to the non-free Windows program Origin.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-visualization/scidavis/scidavis-0.2.1.ebuild b/sci-visualization/scidavis/scidavis-0.2.1.ebuild
new file mode 100644
index 000000000000..10c68a4f2ba3
--- /dev/null
+++ b/sci-visualization/scidavis/scidavis-0.2.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/scidavis/scidavis-0.2.1.ebuild,v 1.1 2009/04/08 08:50:47 bicatali Exp $
+
+EAPI=2
+inherit eutils qt4 fdo-mime
+
+DESCRIPTION="Scientific Data Analysis and Visualization"
+HOMEPAGE="http://scidavis.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python"
+
+LANGS="de es fr ja ru sv"
+for l in ${LANGS}; do
+ IUSE="${IUSE} linguas_${l}"
+done
+
+CDEPEND="sys-libs/zlib
+ =x11-libs/qwt-5.1*[svg]
+ >=x11-libs/qwtplot3d-0.2.7
+ >=dev-cpp/muParser-1.30
+ >=sci-libs/gsl-1.8
+ sci-libs/liborigin:2"
+
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+ python? ( >=dev-python/sip-4.7 )"
+
+RDEPEND="${CDEPEND}
+ python? ( >=dev-python/PyQt4-4.4
+ dev-python/pygsl
+ sci-libs/scipy )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-profile.patch
+ sed -i -e '/lgsl/d' fitPlugins/*/*.pro || die "sed gsl link failed"
+ sed -i \
+ -e "s:doc/${PN}:doc/${PF}:g" \
+ ${PN}/${PN}.pro || die "sed doc dir failed"
+ if use python; then
+ sed -i \
+ -e '/^include( python.pri )$/d' \
+ ${PN}/${PN}.pro || die "sed python failed"
+ fi
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die 'emake install failed'
+ dodoc README CHANGES
+ doicon scidavis/icons/hicolor-48/scidavis.png
+ cd ${PN}/translations
+ insinto /usr/share/${PN}/translations
+ for l in ${LANGS}; do
+ if use linguas_${l}; then
+ doins ${PN}_${l}.qm
+ fi
+ done
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}