summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-08-12 14:16:21 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-08-12 14:16:21 +0000
commit8f4a85995869f6706bbc6cbdaa853d7e330b511f (patch)
treeb4fafd9eed5e91be7c075802bbbfbf21ecf916e5 /sci-visualization/xgraph
parentStable on ppc64; bug #139273 (diff)
downloadgentoo-2-8f4a85995869f6706bbc6cbdaa853d7e330b511f.tar.gz
gentoo-2-8f4a85995869f6706bbc6cbdaa853d7e330b511f.tar.bz2
gentoo-2-8f4a85995869f6706bbc6cbdaa853d7e330b511f.zip
Added patch to have makefile properly honor the user's CFLAGS. See bug #143661.
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'sci-visualization/xgraph')
-rw-r--r--sci-visualization/xgraph/ChangeLog7
-rw-r--r--sci-visualization/xgraph/files/xgraph-makefile-gentoo.patch12
-rw-r--r--sci-visualization/xgraph/xgraph-12.1-r1.ebuild9
3 files changed, 26 insertions, 2 deletions
diff --git a/sci-visualization/xgraph/ChangeLog b/sci-visualization/xgraph/ChangeLog
index 7540cff02a02..fe51c2637de4 100644
--- a/sci-visualization/xgraph/ChangeLog
+++ b/sci-visualization/xgraph/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/xgraph
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xgraph/ChangeLog,v 1.5 2006/08/12 03:10:20 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xgraph/ChangeLog,v 1.6 2006/08/12 14:16:21 markusle Exp $
+
+ 12 Aug 2006; Markus Dittrich <markusle@gentoo.org>
+ +files/xgraph-makefile-gentoo.patch, xgraph-12.1-r1.ebuild:
+ Added patch to have makefile properly honor the user's CFLAGS.
+ See bug #143661.
12 Aug 2006; Michael Sterrett <mr_bones_@gentoo.org> -xgraph-12.1.ebuild:
clean out old, non-mod-X ebuild
diff --git a/sci-visualization/xgraph/files/xgraph-makefile-gentoo.patch b/sci-visualization/xgraph/files/xgraph-makefile-gentoo.patch
new file mode 100644
index 000000000000..e863742994d7
--- /dev/null
+++ b/sci-visualization/xgraph/files/xgraph-makefile-gentoo.patch
@@ -0,0 +1,12 @@
+diff -Naur xgraph-12.1/Makefile.in xgraph-12.1-new/Makefile.in
+--- xgraph-12.1/Makefile.in 1999-12-20 16:40:32.000000000 -0500
++++ xgraph-12.1-new/Makefile.in 2006-08-12 10:04:18.000000000 -0400
+@@ -80,7 +80,7 @@
+
+ # C_WARNINGS = -Wall
+ C_WARNINGS =
+-CFLAGS = $(ADDITIONAL_INCLUDES) $(C_WARNINGS) -g $(X_CFLAGS)
++CFLAGS = $(ADDITIONAL_INCLUDES) $(C_WARNINGS) @CFLAGS@ $(X_CFLAGS)
+
+ xgraph_LDADD = $(ADDITIONAL_LIBS) $(X_LIBS) $(X_PRE_LIBS) $(X_EXTRA_LIBS) -lX11 -lm
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/sci-visualization/xgraph/xgraph-12.1-r1.ebuild b/sci-visualization/xgraph/xgraph-12.1-r1.ebuild
index 80d629ddb79d..b8a9d94f0558 100644
--- a/sci-visualization/xgraph/xgraph-12.1-r1.ebuild
+++ b/sci-visualization/xgraph/xgraph-12.1-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xgraph/xgraph-12.1-r1.ebuild,v 1.2 2006/08/12 03:08:09 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xgraph/xgraph-12.1-r1.ebuild,v 1.3 2006/08/12 14:16:21 markusle Exp $
+
+inherit eutils
DESCRIPTION="X11 Plotting Utility"
HOMEPAGE="http://www.isi.edu/nsnam/xgraph/"
@@ -14,6 +16,11 @@ DEPEND="|| ( ( x11-libs/libSM
)
virtual/x11 )"
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-makefile-gentoo.patch
+}
+
src_install() {
make DESTDIR="${D}" install || die "Compilation failed."