summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-08-29 10:54:57 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-08-29 10:54:57 +0000
commitb257e5f282168588c75afd2c7606e50a39ab17e3 (patch)
treeed173401e171e53c3da379c167b32ae6a74ca4b3 /sci-visualization/quickplot
parentVersion bump, thanks to Àngel Díaz in bug #235447. (diff)
downloadgentoo-2-b257e5f282168588c75afd2c7606e50a39ab17e3.tar.gz
gentoo-2-b257e5f282168588c75afd2c7606e50a39ab17e3.tar.bz2
gentoo-2-b257e5f282168588c75afd2c7606e50a39ab17e3.zip
Fixed linking, some cosmetics.
(Portage version: 2.2_rc8/cvs/Linux 2.6.23-gentoo-r9 x86_64)
Diffstat (limited to 'sci-visualization/quickplot')
-rw-r--r--sci-visualization/quickplot/ChangeLog7
-rw-r--r--sci-visualization/quickplot/files/quickplot-0.8.13-linking.patch20
-rw-r--r--sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild21
-rw-r--r--sci-visualization/quickplot/quickplot-0.8.5.ebuild50
4 files changed, 38 insertions, 60 deletions
diff --git a/sci-visualization/quickplot/ChangeLog b/sci-visualization/quickplot/ChangeLog
index d099f2fb634d..7c9c4d9bbe7a 100644
--- a/sci-visualization/quickplot/ChangeLog
+++ b/sci-visualization/quickplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/quickplot
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/ChangeLog,v 1.6 2008/05/06 14:17:17 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/ChangeLog,v 1.7 2008/08/29 10:54:56 bicatali Exp $
+
+ 29 Aug 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/quickplot-0.8.13-linking.patch, -quickplot-0.8.5.ebuild,
+ quickplot-0.8.13-r1.ebuild:
+ Fixed linking, some cosmetics.
*quickplot-0.8.13-r1 (06 May 2008)
diff --git a/sci-visualization/quickplot/files/quickplot-0.8.13-linking.patch b/sci-visualization/quickplot/files/quickplot-0.8.13-linking.patch
new file mode 100644
index 000000000000..578c4b8be99b
--- /dev/null
+++ b/sci-visualization/quickplot/files/quickplot-0.8.13-linking.patch
@@ -0,0 +1,20 @@
+--- Makefile.in.orig 2008-08-29 11:26:41.000000000 +0100
++++ Makefile.in 2008-08-29 11:32:32.000000000 +0100
+@@ -173,7 +173,7 @@
+
+ quickplot_CXXFLAGS = -Wall $(GTKMM_CXXFLAGS) $(SNDFILE_CFLAGS) -DHTMLDIR=\"$(htmldir)\"
+
+-quickplot_LDFLAGS = -Wall $(GTKMM_LIBS) $(SNDFILE_LIBS)
++quickplot_LDFLAGS = -Wall
+ # -lefence
+
+ # require automake 1.7
+@@ -252,7 +252,7 @@
+ quickplot-main.$(OBJEXT) quickplot-parseGeometry.$(OBJEXT) \
+ quickplot-usage.$(OBJEXT)
+ quickplot_OBJECTS = $(am_quickplot_OBJECTS)
+-quickplot_LDADD = $(LDADD)
++quickplot_LDADD = $(GTKMM_LIBS) $(SNDFILE_LIBS)
+ quickplot_DEPENDENCIES =
+
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I.
diff --git a/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild b/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild
index 96384e6c2fa5..6484e230bb20 100644
--- a/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild
+++ b/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild,v 1.1 2008/05/06 14:17:17 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild,v 1.2 2008/08/29 10:54:57 bicatali Exp $
inherit eutils
@@ -14,11 +14,10 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~x86"
RDEPEND=">=dev-cpp/gtkmm-2.4.5
- sndfile? ( >=media-libs/libsndfile-1.0.5 )
- >=dev-libs/libsigc++-2"
+ sndfile? ( media-libs/libsndfile )"
DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.15"
+ dev-util/pkgconfig"
src_unpack() {
unpack ${A}
@@ -26,23 +25,27 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-libsigc++-2.2.patch
epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-linking.patch
# Some files have been moved around to more appropriate locations
- sed -i -e 's|quickplot_icon.png|/usr/share/pixmaps/quickplot.png|' \
+ sed -i \
+ -e 's|quickplot_icon.png|/usr/share/pixmaps/quickplot.png|' \
+ -e 's|href="ChangeLog"|href="../ChangeLog.gz"|' \
index.html.in
- sed -i -e 's|href="ChangeLog"|href="../ChangeLog.gz"|' index.html.in
sed -i -e 's|href="COPYING"|href="/usr/portage/licenses/GPL-2"|' \
about.html.in
}
src_compile() {
- econf `use_with sndfile libsndfile` || die "econf step failed."
+ econf $(use_with sndfile libsndfile) || die "econf step failed."
emake htmldir=/usr/share/doc/${PF}/html || die "emake step failed."
}
src_install () {
- make install DESTDIR="${D}" htmldir=/usr/share/doc/${PF}/html \
- || die "make install step failed."
+ emake \
+ DESTDIR="${D}" \
+ htmldir=/usr/share/doc/${PF}/html \
+ install || die "make install step failed."
dodoc AUTHORS ChangeLog README README.devel TODO
# Remove COPYING as it is specified in LICENCE. Move other stuff.
cd "${D}"/usr/share/doc/${PF}/html
diff --git a/sci-visualization/quickplot/quickplot-0.8.5.ebuild b/sci-visualization/quickplot/quickplot-0.8.5.ebuild
deleted file mode 100644
index d8e8c9a47056..000000000000
--- a/sci-visualization/quickplot/quickplot-0.8.5.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/quickplot-0.8.5.ebuild,v 1.3 2008/05/06 14:17:17 markusle Exp $
-
-inherit eutils
-
-DESCRIPTION="A fast interactive 2D plotter."
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-HOMEPAGE="http://quickplot.sourceforge.net/"
-
-IUSE="sndfile"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~ppc x86"
-
-RDEPEND=">=dev-cpp/gtkmm-2.4.5
- sndfile? ( >=media-libs/libsndfile-1.0.5 )"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.15"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # Some files have been moved around to more appropriate locations
- sed -i -e 's|quickplot_icon.png|/usr/share/pixmaps/quickplot.png|' \
- index.html.in
- sed -i -e 's|href="ChangeLog"|href="../ChangeLog.gz"|' index.html.in
- sed -i -e 's|href="COPYING"|href="/usr/portage/licenses/GPL-2"|' \
- about.html.in
-}
-
-src_compile() {
- econf `use_with sndfile libsndfile` || die "econf step failed."
- emake htmldir=/usr/share/doc/${PF}/html || die "emake step failed."
-}
-
-src_install () {
- make install DESTDIR="${D}" htmldir=/usr/share/doc/${PF}/html \
- || die "make install step failed."
- dodoc AUTHORS ChangeLog README README.devel TODO
- # Remove COPYING as it is specified in LICENCE. Move other stuff.
- cd "${D}"/usr/share/doc/${PF}/html
- rm COPYING quickplot_icon.png ChangeLog
- mv "${D}"/usr/share/pixmaps/quickplot_icon.png \
- "${D}"/usr/share/pixmaps/quickplot.png
- make_desktop_entry 'quickplot --no-pipe' Quickplot quickplot Graphics
- mv "${D}"/usr/share/applications/quickplot\ --no-pipe.desktop \
- "${D}"/usr/share/applications/quickplot.desktop
-}