summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-03-31 22:28:22 +0000
committerUlrich Müller <ulm@gentoo.org>2009-03-31 22:28:22 +0000
commit9976271e0f263452410606d6aeec340fdc5774f3 (patch)
tree98286d110520b3dda5a7e8c9b484d30a460d3a1e /sci-visualization/gnuplot
parentMask sci-visualization/gnuplot-4.2.5 for testing. (diff)
downloadgentoo-2-9976271e0f263452410606d6aeec340fdc5774f3.tar.gz
gentoo-2-9976271e0f263452410606d6aeec340fdc5774f3.tar.bz2
gentoo-2-9976271e0f263452410606d6aeec340fdc5774f3.zip
Version bump. Add support for PGF/TikZ terminal with USE=lua, bug 233475. Other minor changes.
(Portage version: 2.2_rc27/cvs/Linux i686)
Diffstat (limited to 'sci-visualization/gnuplot')
-rw-r--r--sci-visualization/gnuplot/ChangeLog14
-rw-r--r--sci-visualization/gnuplot/files/gnuplot-gentoo-version.patch76
-rw-r--r--sci-visualization/gnuplot/gnuplot-4.2.5.ebuild203
3 files changed, 292 insertions, 1 deletions
diff --git a/sci-visualization/gnuplot/ChangeLog b/sci-visualization/gnuplot/ChangeLog
index c671a612fd37..5e82ab6f5a85 100644
--- a/sci-visualization/gnuplot/ChangeLog
+++ b/sci-visualization/gnuplot/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for sci-visualization/gnuplot
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/ChangeLog,v 1.98 2009/03/27 23:19:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/ChangeLog,v 1.99 2009/03/31 22:28:22 ulm Exp $
+
+*gnuplot-4.2.5 (31 Mar 2009)
+
+ 31 Mar 2009; Ulrich Mueller <ulm@gentoo.org>
+ +files/gnuplot-gentoo-version.patch, +gnuplot-4.2.5.ebuild:
+ Version bump. Add support for PGF/TikZ terminal with USE=lua, bug 233475;
+ thanks to Thomas Fischer <fischer@unix-ag.uni-kl.de>. Add Gentoo version
+ identification and contact information, in order to fulfil provisions 2
+ through 4 of the gnuplot licence for redistribution of binaries. Remove
+ the built_with_use test for media-libs/gd from src_unpack and replace it
+ by a USE dependency; therefore bump EAPI to 2. latex_rehash is not needed
+ any more, replace it by texmf-update.
27 Mar 2009; Jeroen Roovers <jer@gentoo.org> gnuplot-4.2.4-r1.ebuild:
Stable for HPPA (bug #262327).
diff --git a/sci-visualization/gnuplot/files/gnuplot-gentoo-version.patch b/sci-visualization/gnuplot/files/gnuplot-gentoo-version.patch
new file mode 100644
index 000000000000..b1a530a7dfe7
--- /dev/null
+++ b/sci-visualization/gnuplot/files/gnuplot-gentoo-version.patch
@@ -0,0 +1,76 @@
+Add special version identification and Gentoo contact information,
+in order to fulfil provisions 2 through 4 of the gnuplot licence.
+
+--- gnuplot-orig/src/plot.c
++++ gnuplot/src/plot.c
+@@ -383,9 +383,11 @@
+ " -V, --version\n"
+ " -h, --help\n"
+ " -e \"command1; command2; ...\"\n"
+- "gnuplot %s patchlevel %s\n"
+- "Report bugs to %s\n",
+- gnuplot_version, gnuplot_patchlevel, bug_email);
++ "gnuplot %s patchlevel %s (Gentoo revision %s)\n"
++ "Report bugs to <%s>\n"
++ "or to <%s>\n",
++ gnuplot_version, gnuplot_patchlevel, gentoo_revision,
++ gentoo_bugtracker, bug_email);
+ return 0;
+ }
+ }
+--- gnuplot-orig/src/show.c
++++ gnuplot/src/show.c
+@@ -1052,7 +1052,7 @@
+
+ fprintf(fp, "%s\n\
+ %s\t%s\n\
+-%s\tVersion %s patchlevel %s\n\
++%s\tVersion %s patchlevel %s (Gentoo revision %s)\n\
+ %s\tlast modified %s\n\
+ %s\tSystem: %s %s\n\
+ %s\n\
+@@ -1063,10 +1063,11 @@
+ %s\tThe gnuplot FAQ is available from %s\n\
+ %s\n\
+ %s\tSend bug reports and suggestions to <%s>\n\
++%s\tor to <%s>\n\
+ %s\n",
+ p, /* empty line */
+ p, PROGRAM,
+- p, gnuplot_version, gnuplot_patchlevel,
++ p, gnuplot_version, gnuplot_patchlevel, gentoo_revision,
+ p, gnuplot_date,
+ p, os_name, os_rel,
+ p, /* empty line */
+@@ -1076,6 +1077,7 @@
+ p, /* Type `help` */
+ p, faq_location,
+ p, /* empty line */
++ p, gentoo_bugtracker,
+ p, bug_email,
+ p); /* empty line */
+
+--- gnuplot-orig/src/version.c
++++ gnuplot/src/version.c
+@@ -46,6 +46,9 @@
+
+ const char faq_location[] = FAQ_LOCATION;
+
++const char gentoo_revision[] = GENTOO_REVISION;
++const char gentoo_bugtracker[] = "http://bugs.gentoo.org/";
++
+ char *compile_options = (void *)0; /* Will be loaded at runtime */
+
+ #define RELEASE_VERSION 1
+--- gnuplot-orig/src/version.h
++++ gnuplot/src/version.h
+@@ -47,6 +47,9 @@
+ extern const char bug_email[];
+ extern const char help_email[];
+
++extern const char gentoo_revision[];
++extern const char gentoo_bugtracker[];
++
+ extern char os_name[];
+ extern char os_rel[];
+
diff --git a/sci-visualization/gnuplot/gnuplot-4.2.5.ebuild b/sci-visualization/gnuplot/gnuplot-4.2.5.ebuild
new file mode 100644
index 000000000000..72ec286e9ecf
--- /dev/null
+++ b/sci-visualization/gnuplot/gnuplot-4.2.5.ebuild
@@ -0,0 +1,203 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.2.5.ebuild,v 1.1 2009/03/31 22:28:22 ulm Exp $
+
+EAPI=2
+WX_GTK_VER="2.8"
+
+inherit autotools elisp-common eutils multilib wxwidgets
+
+MY_P="${P/_/.}"
+
+DESCRIPTION="Command-line driven interactive plotting program"
+HOMEPAGE="http://www.gnuplot.info/"
+SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz
+ mirror://gentoo/${P}-lua-term.patch.bz2"
+
+LICENSE="gnuplot"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc emacs gd ggi latex lua pdf plotutils readline svga wxwindows X xemacs"
+RESTRICT="wxwindows? ( test )"
+
+RDEPEND="
+ xemacs? ( virtual/xemacs app-xemacs/texinfo app-xemacs/xemacs-base )
+ emacs? ( virtual/emacs !app-emacs/gnuplot-mode )
+ pdf? ( media-libs/pdflib )
+ lua? ( >=dev-lang/lua-5.1 )
+ ggi? ( media-libs/libggi )
+ gd? ( >=media-libs/gd-2[png] )
+ doc? ( virtual/latex-base
+ virtual/ghostscript )
+ latex? ( virtual/latex-base
+ lua? ( dev-tex/pgf ) )
+ X? ( x11-libs/libXaw )
+ svga? ( media-libs/svgalib )
+ readline? ( >=sys-libs/readline-4.2 )
+ plotutils? ( media-libs/plotutils )
+ wxwindows? ( =x11-libs/wxGTK-2.8*
+ >=x11-libs/cairo-0.9
+ >=x11-libs/pango-1.10.3
+ >=x11-libs/gtk+-2.8 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+E_SITEFILE="50${PN}-gentoo.el"
+TEXMF="/usr/share/texmf-site"
+
+pkg_setup() {
+ use wxwindows && wxwidgets_pkg_setup
+}
+
+src_prepare() {
+ # Texinfo source is already shipped, so separate preparation not needed
+ # and error-prone, see bug 194216
+ epatch "${FILESDIR}"/${PN}-4.2.2-disable_texi_generation.patch
+ # Don't store resource files in deprecated location, reported upstream:
+ # http://sourceforge.net/tracker/index.php?func=detail&aid=1953742&group_id=2055&atid=102055
+ epatch "${FILESDIR}"/${PN}-4.2.3-app-defaults.patch
+ # Disable texhash to prevent sandbox violation, bug 201871
+ epatch "${FILESDIR}"/${PN}-4.2.3-disable-texhash.patch
+ # Support for lua/TikZ terminal
+ epatch "${WORKDIR}"/${P}-lua-term.patch
+ # Add Gentoo version identification since the licence requires it
+ epatch "${FILESDIR}"/${PN}-gentoo-version.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ # See bug #156427.
+ if use latex ; then
+ sed -i -e "s:\`kpsexpand.*\`:${TEXMF}/tex/latex/${PN}:" \
+ share/LaTeX/Makefile.in || die
+ else
+ sed -i \
+ -e '/^SUBDIRS/ s/LaTeX//' share/LaTeX/Makefile.in || die
+ fi
+
+ local myconf="--with-gihdir=/usr/share/${PN}/gih"
+
+ myconf="${myconf} $(use_with X x)"
+ myconf="${myconf} $(use_with svga linux-vga)"
+ myconf="${myconf} $(use_with gd)"
+ myconf="${myconf} $(use_enable wxwindows wxwidgets)"
+ myconf="${myconf} $(use_with plotutils plot /usr/$(get_libdir))"
+ myconf="${myconf} $(use_with pdf pdf /usr/$(get_libdir))"
+ myconf="${myconf} $(use_with lua)"
+ myconf="${myconf} $(use_with doc tutorial)"
+
+ use ggi \
+ && myconf="${myconf} --with-ggi=/usr/$(get_libdir)
+ --with-xmi=/usr/$(get_libdir)" \
+ || myconf="${myconf} --without-ggi"
+
+ use readline \
+ && myconf="${myconf} --with-readline=gnu --enable-history-file" \
+ || myconf="${myconf} --with-readline"
+
+ myconf="${myconf} --without-lisp-files"
+
+ TEMACS=no
+ use xemacs && TEMACS=xemacs
+ use emacs && TEMACS=emacs
+
+ CFLAGS="${CFLAGS} -DGENTOO_REVISION=\\\"${PR}\\\"" \
+ EMACS=${TEMACS} \
+ econf ${myconf} || die
+}
+
+src_compile() {
+ # Prevent access violations, see bug 201871
+ VARTEXFONTS="${T}/fonts"
+
+ # This is a hack to avoid sandbox violations when using the Linux console.
+ # Creating the DVI and PDF tutorials require /dev/svga to build the
+ # example plots.
+ addwrite /dev/svga:/dev/mouse:/dev/tts/0
+
+ emake || die
+
+ if use doc ; then
+ cd docs
+ emake pdf || die
+ cd ../tutorial
+ emake pdf || die
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+
+ if use emacs; then
+ cd lisp
+ einfo "Configuring gnuplot-mode for GNU Emacs..."
+ EMACS="emacs" econf --with-lispdir="${SITELISP}/${PN}" || die
+ emake DESTDIR="${D}" install || die
+ emake clean
+ cd ..
+
+ # Gentoo emacs site-lisp configuration
+ echo -e "\n;;; ${PN} site-lisp configuration\n" > ${E_SITEFILE}
+ echo -e "(add-to-list 'load-path \"@SITELISP@\")\n" >> ${E_SITEFILE}
+ sed '/^;; move/,+3 d' lisp/dotemacs >> ${E_SITEFILE}
+ elisp-site-file-install ${E_SITEFILE}
+ fi
+
+ if use xemacs; then
+ cd lisp
+ einfo "Configuring gnuplot-mode for XEmacs..."
+ EMACS="xemacs" \
+ econf --with-lispdir="/usr/lib/xemacs/site-packages/${PN}" || die
+ emake DESTDIR="${D}" install || die
+ cd ..
+ fi
+
+ if use latex && use lua; then
+ # install style file in an (additional) place where TeX can find it
+ insinto "${TEXMF}/tex/latex/${PN}"
+ doins term/lua/gnuplot-lua-tikz.sty || die
+ fi
+
+ dodoc BUGS ChangeLog FAQ NEWS PATCHLEVEL PGPKEYS PORTING README* \
+ TODO VERSION
+ use lua && newdoc term/lua/README README-lua
+
+ if use doc; then
+ # Demo files
+ insinto /usr/share/${PN}/demo
+ doins demo/*
+ # Manual
+ insinto /usr/share/doc/${PF}/manual
+ doins docs/gnuplot.pdf
+ # Tutorial
+ insinto /usr/share/doc/${PF}/tutorial
+ doins tutorial/{tutorial.dvi,tutorial.pdf}
+ # Documentation for making PostScript files
+ insinto /usr/share/doc/${PF}/psdoc
+ doins docs/psdoc/{*.doc,*.tex,*.ps,*.gpi,README}
+ fi
+
+ if ! use X; then
+ # see bug 194527
+ rm -rf "${D}/usr/$(get_libdir)/X11"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ use latex && texmf-update
+
+ if use svga ; then
+ einfo "In order to enable ordinary users to use SVGA console graphics"
+ einfo "gnuplot needs to be set up as setuid root. Please note that"
+ einfo "this is usually considered to be a security hazard."
+ einfo "As root, manually \"chmod u+s /usr/bin/gnuplot\"."
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+ use latex && texmf-update
+}