summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-21 14:06:22 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-21 14:06:22 +0000
commit5e90a04640ccb1897d09217612237c596d5f6bc2 (patch)
tree1259c3691ff6916c391f0452f39372166be75a6e /sci-visualization/gfsview/gfsview-20100407.ebuild
parentVersion Bump, remove python which is only needed for the restricted test (diff)
downloadgentoo-2-5e90a04640ccb1897d09217612237c596d5f6bc2.tar.gz
gentoo-2-5e90a04640ccb1897d09217612237c596d5f6bc2.tar.bz2
gentoo-2-5e90a04640ccb1897d09217612237c596d5f6bc2.zip
Version Bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization/gfsview/gfsview-20100407.ebuild')
-rw-r--r--sci-visualization/gfsview/gfsview-20100407.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-visualization/gfsview/gfsview-20100407.ebuild b/sci-visualization/gfsview/gfsview-20100407.ebuild
new file mode 100644
index 000000000000..ab6ed2ce0df4
--- /dev/null
+++ b/sci-visualization/gfsview/gfsview-20100407.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gfsview/gfsview-20100407.ebuild,v 1.1 2010/05/21 14:06:22 jlec Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Graphical viewer for Gerris simulation files."
+HOMEPAGE="http://gfs.sourceforge.net/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=x11-libs/gtkglext-1.0.6
+ >=x11-libs/gtk+-2.4.0
+ x11-libs/startup-notification
+ >=sci-libs/gerris-${PV}"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${PN}-snapshot-100407"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
+}