summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-11-15 04:06:12 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-11-15 04:06:12 +0000
commitc3cc47e89b796ceb9d6303f94bc57d5db8c8a8f3 (patch)
treeda7ccce47d9559b4a64f795207074a2b3a792c08 /sci-physics
parentDev channel bump. Use system libsrtp (bug #348600 by jlec). Back to bundled o... (diff)
downloadgentoo-2-c3cc47e89b796ceb9d6303f94bc57d5db8c8a8f3.tar.gz
gentoo-2-c3cc47e89b796ceb9d6303f94bc57d5db8c8a8f3.tar.bz2
gentoo-2-c3cc47e89b796ceb9d6303f94bc57d5db8c8a8f3.zip
Version bump
(Portage version: 2.2.01.21313-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/pythia/ChangeLog7
-rw-r--r--sci-physics/pythia/pythia-8.1.70.ebuild87
2 files changed, 93 insertions, 1 deletions
diff --git a/sci-physics/pythia/ChangeLog b/sci-physics/pythia/ChangeLog
index 1a3a2eadf337..6b90a641e25d 100644
--- a/sci-physics/pythia/ChangeLog
+++ b/sci-physics/pythia/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/pythia
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.47 2012/10/16 18:54:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.48 2012/11/15 04:06:12 bicatali Exp $
+
+*pythia-8.1.70 (15 Nov 2012)
+
+ 15 Nov 2012; Sébastien Fabbro <bicatali@gentoo.org> +pythia-8.1.70.ebuild:
+ Version bump
16 Oct 2012; Justin Lecher <jlec@gentoo.org> pythia-6.4.24.ebuild,
pythia-6.4.26.ebuild, pythia-8.1.45.ebuild, pythia-8.1.65.ebuild,
diff --git a/sci-physics/pythia/pythia-8.1.70.ebuild b/sci-physics/pythia/pythia-8.1.70.ebuild
new file mode 100644
index 000000000000..c321094580ca
--- /dev/null
+++ b/sci-physics/pythia/pythia-8.1.70.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-8.1.70.ebuild,v 1.1 2012/11/15 04:06:12 bicatali Exp $
+
+EAPI=4
+
+inherit eutils fortran-2 versionator
+
+MV=$(get_major_version)
+MY_P=${PN}$(replace_all_version_separators "" ${PV})
+
+DESCRIPTION="Lund Monte Carlo high-energy physics event generator"
+HOMEPAGE="http://home.thep.lu.se/~torbjorn/Pythia.html"
+SRC_URI="http://home.thep.lu.se/~torbjorn/${PN}${MV}/${MY_P}.tgz"
+
+SLOT="8"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples +hepmc static-libs"
+
+DEPEND="hepmc? ( sci-physics/hepmc )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ use hepmc && export HEPMCVERSION=2 HEPMCLOCATION="${EPREFIX}/usr"
+ # homemade configure script creates a useless config.mk
+ rm -f config.mk
+ cat > config.mk <<-EOF
+ SHAREDLIBS = yes
+ LDFLAGSSHARED = -shared ${LDFLAGS}
+ LDFLAGLIBNAME = -Wl,-soname
+ SHAREDSUFFIX = so
+ EOF
+ if ! use static-libs; then
+ sed -i \
+ -e '/targets.*\.a/d' \
+ -e 's/+=\(.*libpythia8\)/=\1/' \
+ Makefile || die
+ sed -i \
+ -e 's:\.a:\.so:g' \
+ -e 's:$(LIBDIRARCH):$(LIBDIR):g' \
+ examples/Makefile || die
+ fi
+}
+
+src_test() {
+ cd examples
+ # use emake for parallel instead of long runmains
+ emake main0{1..9}
+ for i in main0{1..9}*.exe; do
+ LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}" \
+ ./${i} > ${i}.out || die "test ${i} failed"
+ done
+ if use hepmc; then
+ emake main31
+ LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}" \
+ ./main31.exe > main31.exe.out || die
+ fi
+ emake clean && rm -f main*out
+}
+
+src_install() {
+ dolib.so lib/*so
+ use static-libs && dolib.a lib/archive/*
+
+ insinto /usr/include/${PN}
+ doins include/*
+
+ # xmldoc needed by root
+ insinto /usr/share/${PN}
+ doins -r xmldoc
+
+ echo "PYTHIA8DATA=${EROOT}usr/share/${PN}/xmldoc" >> 99pythia8
+ doenvd 99pythia8
+
+ dodoc GUIDELINES AUTHORS README
+ if use doc; then
+ dodoc worksheet.pdf
+ dohtml -r htmldoc/*
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}