summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-26 10:53:30 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-26 10:53:30 +0000
commit9c4f2188bd32a2dd092e182ac56b9032762c7fcd (patch)
treefc5ad935cbb7bdcfdae322648ed4edd8e8b22a66 /sci-physics
parentx11-drivers/xf86-video-intel: bump to 2.12.0 (diff)
downloadgentoo-2-9c4f2188bd32a2dd092e182ac56b9032762c7fcd.tar.gz
gentoo-2-9c4f2188bd32a2dd092e182ac56b9032762c7fcd.tar.bz2
gentoo-2-9c4f2188bd32a2dd092e182ac56b9032762c7fcd.zip
Version Bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/abinit/ChangeLog11
-rw-r--r--sci-physics/abinit/abinit-6.0.4.ebuild106
-rw-r--r--sci-physics/abinit/files/6.0.4-change-default-directories.patch29
-rw-r--r--sci-physics/abinit/files/6.0.4-test.patch26
-rw-r--r--sci-physics/abinit/metadata.xml3
5 files changed, 173 insertions, 2 deletions
diff --git a/sci-physics/abinit/ChangeLog b/sci-physics/abinit/ChangeLog
index c976b6c98c9c..9b3fc95a62d3 100644
--- a/sci-physics/abinit/ChangeLog
+++ b/sci-physics/abinit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/abinit
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/abinit/ChangeLog,v 1.10 2009/12/18 01:26:24 markusle Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/abinit/ChangeLog,v 1.11 2010/06/26 10:53:30 jlec Exp $
+
+*abinit-6.0.4 (26 Jun 2010)
+
+ 26 Jun 2010; Justin Lecher <jlec@gentoo.org>
+ +files/6.0.4-change-default-directories.patch, +files/6.0.4-test.patch,
+ +abinit-6.0.4.ebuild, metadata.xml:
+ Version Bump
*abinit-5.4.4-r1 (18 Dec 2009)
diff --git a/sci-physics/abinit/abinit-6.0.4.ebuild b/sci-physics/abinit/abinit-6.0.4.ebuild
new file mode 100644
index 000000000000..6047a3845735
--- /dev/null
+++ b/sci-physics/abinit/abinit-6.0.4.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/abinit/abinit-6.0.4.ebuild,v 1.1 2010/06/26 10:53:30 jlec Exp $
+
+EAPI="3"
+
+inherit fortran toolchain-funcs
+
+DESCRIPTION="Find total energy, charge density and electronic structure using density functional theory"
+HOMEPAGE="http://www.abinit.org/"
+SRC_URI="http://ftp.abinit.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug mpi plugins test"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+# F90 code, g77 won't work
+FORTRAN="gfortran ifc"
+
+pkg_setup() {
+ fortran_pkg_setup
+
+ # Doesn't compile with gcc-4.0, only >=4.1
+ local diemsg="Requires gcc-4.1 or newer"
+ if [[ "${FORTRANC}" = "gfortran" ]]; then
+ if [[ $(gcc-major-version) -eq 4 ]] \
+ && [[ $(gcc-minor-version) -lt 1 ]]; then
+ die "${diemsg}"
+ fi
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-change-default-directories.patch
+# epatch "${FILESDIR}"/5.2.3-fix-64bit-detection.patch
+ epatch "${FILESDIR}"/${PV}-test.patch
+
+ # bug #223111: Our eautoreconf directory detection breaks
+ sed -i -e "s:@abinit_srcdir@/::" Makefile.am
+
+ # bug #223111: libtool 2.2 fix (taken from bug #230271)
+ if [ -f "${EPREFIX}/usr/share/aclocal/ltsugar.m4" ]; then
+ cat "${EPREFIX}/usr/share/aclocal/ltsugar.m4" >> config/m4/libtool.m4
+ cat "${EPREFIX}/usr/share/aclocal/ltversion.m4" >> config/m4/libtool.m4
+ cat "${EPREFIX}/usr/share/aclocal/lt~obsolete.m4" >> config/m4/libtool.m4
+ cat "${EPREFIX}/usr/share/aclocal/ltoptions.m4" >> config/m4/libtool.m4
+ fi
+
+ # Yea for breaking compatibility with no ChangeLog entry in 2.60
+ if has_version '>=sys-devel/autoconf-2.60'; then
+ sed -i -e "s:_AC_SRCPATHS:_AC_SRCDIRS:g" config/scripts/make-macros-autotools
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-config-file \
+ $(use_enable mpi) \
+ $(use_enable plugins all-plugins) \
+ $(use_enable netcdf) \
+ $(use_enable debug) \
+ --with-cc-optflags="${CFLAGS}" \
+ --with-fc-optflags="${FFLAGS}" \
+ FC="${FORTRANC}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)"
+}
+
+src_test() {
+ einfo "The tests take quite a while, on the order of 2-3 hours"
+ einfo "on a dual Athlon 2000+."
+ cd "${S}"/tests
+ emake tests_min || die
+
+ local REPORT
+ for REPORT in $(find . -name *fl*); do
+ elog "Results for ${REPORT%%/*} tests"
+ while read line; do
+ elog "${line}"
+ done \
+ < <(cat ${REPORT} )
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc KNOWN_PROBLEMS README || die
+
+ mv "${ED}"usr/share/doc/abinit/manpages/abinit.1 "${ED}"/usr/share/man/man1/
+ mv "${ED}"usr/share/doc/abinit{,-${PVR}}
+}
+
+pkg_postinst() {
+ if use test; then
+ elog "The test results will be installed as summary_tests.tar.gz."
+ fi
+}
diff --git a/sci-physics/abinit/files/6.0.4-change-default-directories.patch b/sci-physics/abinit/files/6.0.4-change-default-directories.patch
new file mode 100644
index 000000000000..938edbffad20
--- /dev/null
+++ b/sci-physics/abinit/files/6.0.4-change-default-directories.patch
@@ -0,0 +1,29 @@
+diff --git a/config/m4/conf-init.m4 b/config/m4/conf-init.m4
+index 3a20c30..8e84730 100644
+--- a/config/m4/conf-init.m4
++++ b/config/m4/conf-init.m4
+@@ -315,15 +315,15 @@ AC_DEFUN([ABI_INIT_INSTALL_DIRS],[
+ fi
+
+ dnl Set-up all directory names
+- abinit_bindir="${abinit_prefix}/abinit/${ABINIT_VERSION_BASE}/bin"
+- abinit_chkdir="${abinit_prefix}/abinit/${ABINIT_VERSION_BASE}/tests"
+- abinit_datdir="${abinit_prefix}/abinit"
+- abinit_docdir="${abinit_prefix}/abinit/${ABINIT_VERSION_BASE}/doc"
+- abinit_incdir="${abinit_prefix}/abinit/${ABINIT_VERSION_BASE}/include"
+- abinit_libdir="${abinit_prefix}/abinit/${ABINIT_VERSION_BASE}/lib"
+- abinit_mandir="${abinit_prefix}/abinit/man"
+- abinit_rundir="${abinit_prefix}/abinit/bin"
+- abinit_wwwdir="${abinit_prefix}/abinit/${ABINIT_VERSION_BASE}/www"
++ abinit_bindir="${abinit_prefix}/bin"
++ abinit_chkdir="${abinit_prefix}/share/abinit/tests"
++ abinit_datdir="${abinit_prefix}/share/abinit"
++ abinit_docdir="${abinit_prefix}/share/doc/abinit-${ABINIT_VERSION_BASE}"
++ abinit_incdir="${includedir}/abinit"
++ abinit_libdir="${libdir}"
++ abinit_mandir="${abinit_prefix}/share/man/man"
++ abinit_rundir="${abinit_prefix}/bin"
++ abinit_wwwdir="${abinit_prefix}/share/abinit/www"
+
+ dnl Substitute all variables
+ AC_SUBST(abinit_prefix)
diff --git a/sci-physics/abinit/files/6.0.4-test.patch b/sci-physics/abinit/files/6.0.4-test.patch
new file mode 100644
index 000000000000..aaa7f9eb76f3
--- /dev/null
+++ b/sci-physics/abinit/files/6.0.4-test.patch
@@ -0,0 +1,26 @@
+diff --git a/tests/Scripts/wrap-parallel-tests.sh b/tests/Scripts/wrap-parallel-tests.sh
+index 91d1ef9..b199627 100755
+--- a/tests/Scripts/wrap-parallel-tests.sh
++++ b/tests/Scripts/wrap-parallel-tests.sh
+@@ -22,7 +22,7 @@ set -e
+
+ # Init
+ my_name="wrap-parallel-tests"
+-my_cnffile="./tests.env"
++my_cnffile="../tests/tests.env"
+ paral_sets="A B C D E F G H I J K L M N O P R T U V X Y"
+ #mpiio_sets="A"
+ mpiio_sets="A P Q R T X Y"
+diff --git a/tests/Scripts/wrap-standard-tests.sh b/tests/Scripts/wrap-standard-tests.sh
+index 1b9fd72..26caff6 100755
+--- a/tests/Scripts/wrap-standard-tests.sh
++++ b/tests/Scripts/wrap-standard-tests.sh
+@@ -3,7 +3,7 @@
+ #
+
+ my_name="wrap-standard-tests"
+-my_cnffile="tests.env"
++my_cnffile="../tests/tests.env"
+
+ # Check arguments
+ if test "${#}" -lt "1"; then
diff --git a/sci-physics/abinit/metadata.xml b/sci-physics/abinit/metadata.xml
index 56668dc0efbd..d7c16aaf672b 100644
--- a/sci-physics/abinit/metadata.xml
+++ b/sci-physics/abinit/metadata.xml
@@ -6,4 +6,7 @@
<email>dberkholz@gentoo.org</email>
<name>Donnie Berkholz</name>
</maintainer>
+<use>
+ <flag name='plugins'>Build all plugins</flag>
+</use>
</pkgmetadata>