summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-03-23 02:32:49 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-03-23 02:32:49 +0000
commit10c91b82ed6c1388c9ed9566a2f2862835a3a0a8 (patch)
treec1c94d4def45bac69e378796f9e786d75404258b /sci-physics
parentAdd fix from upstream for `set` heredoc output #310197 by Doktor Notor. (diff)
downloadgentoo-2-10c91b82ed6c1388c9ed9566a2f2862835a3a0a8.tar.gz
gentoo-2-10c91b82ed6c1388c9ed9566a2f2862835a3a0a8.tar.bz2
gentoo-2-10c91b82ed6c1388c9ed9566a2f2862835a3a0a8.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/clhep/ChangeLog8
-rw-r--r--sci-physics/clhep/clhep-2.0.4.2.ebuild47
-rw-r--r--sci-physics/clhep/clhep-2.0.4.6.ebuild (renamed from sci-physics/clhep/clhep-2.0.4.3.ebuild)21
3 files changed, 20 insertions, 56 deletions
diff --git a/sci-physics/clhep/ChangeLog b/sci-physics/clhep/ChangeLog
index 29b5be02df3d..d27880724c50 100644
--- a/sci-physics/clhep/ChangeLog
+++ b/sci-physics/clhep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/clhep
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.20 2010/01/31 15:37:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.21 2010/03/23 02:32:49 bicatali Exp $
+
+*clhep-2.0.4.6 (23 Mar 2010)
+
+ 23 Mar 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ -clhep-2.0.4.2.ebuild, -clhep-2.0.4.3.ebuild, +clhep-2.0.4.6.ebuild:
+ Version bump
31 Jan 2010; Raúl Porcel <armin76@gentoo.org> clhep-2.0.4.5.ebuild:
sparc stable wrt #301491
diff --git a/sci-physics/clhep/clhep-2.0.4.2.ebuild b/sci-physics/clhep/clhep-2.0.4.2.ebuild
deleted file mode 100644
index 9b0b1bc919cd..000000000000
--- a/sci-physics/clhep/clhep-2.0.4.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/clhep-2.0.4.2.ebuild,v 1.5 2009/05/05 19:39:02 fauli Exp $
-
-inherit autotools
-
-DESCRIPTION="High Energy Physics C++ library"
-HOMEPAGE="http://www.cern.ch/clhep"
-SRC_URI="http://wwwasd.web.cern.ch/wwwasd/lhc++/clhep/DISTRIBUTION/distributions/${P}.tgz"
-
-LICENSE="public-domain"
-SLOT="2"
-KEYWORDS="amd64 ~hppa ~ppc sparc x86"
-
-IUSE="exceptions"
-RDEPEND=""
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${PV}/CLHEP"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- for d in $(find . -name configure.in); do
- pushd ${d/configure.in/}
- # respect user flags and fix some compilers stuff
- sed -i \
- -e 's:^g++):*g++):g' \
- -e 's:^icc):icc|icpc):g' \
- -e '/AM_CXXFLAGS=/s:-O ::g' \
- configure.in || die
- # need to rebuild because original configurations
- # have buggy detection
- eautoreconf
- popd
- done
-}
-
-src_compile() {
- econf $(use_enable exceptions)
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README ChangeLog || die
-}
diff --git a/sci-physics/clhep/clhep-2.0.4.3.ebuild b/sci-physics/clhep/clhep-2.0.4.6.ebuild
index 308d0d85d676..a96819ae989e 100644
--- a/sci-physics/clhep/clhep-2.0.4.3.ebuild
+++ b/sci-physics/clhep/clhep-2.0.4.6.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/clhep-2.0.4.3.ebuild,v 1.2 2009/12/07 18:16:11 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/clhep-2.0.4.6.ebuild,v 1.1 2010/03/23 02:32:49 bicatali Exp $
EAPI=2
-inherit autotools
+inherit autotools eutils
DESCRIPTION="High Energy Physics C++ library"
HOMEPAGE="http://www.cern.ch/clhep"
SRC_URI="http://proj-clhep.web.cern.ch/proj-clhep/DISTRIBUTION/tarFiles/${P}.tgz"
LICENSE="public-domain"
SLOT="2"
-KEYWORDS="~amd64 hppa ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
IUSE="exceptions"
RDEPEND=""
@@ -20,18 +20,23 @@ S="${WORKDIR}/${PV}/CLHEP"
src_prepare() {
for d in $(find . -name configure.in); do
- pushd ${d/configure.in/}
# respect user flags and fix some compilers stuff
sed -i \
-e 's:^g++):*g++):g' \
-e 's:^icc):icc|icpc):g' \
-e '/AM_CXXFLAGS=/s:-O ::g' \
- configure.in || die
+ ${d} || die
# need to rebuild because original configurations
# have buggy detection
- eautoreconf
- popd
done
+ for d in $(find . -name Makefile.am | xargs grep -l ": %\.cc"); do
+ sed -i \
+ -e 's|: %\.cc|: %\.cc \$(shareddir)|' \
+ -e 's|all-local: \$(shareddir)|all-local: |' \
+ ${d} || die
+ # fixing parallel build
+ done
+ eautoreconf
}
src_configure() {