summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2015-07-18 09:40:19 +0000
committerAndrew Savchenko <bircoph@gentoo.org>2015-07-18 09:40:19 +0000
commite2358639bc582b01f0f5c0f7a1d878cf022f974f (patch)
treee290360343e6bb06135dc6431bee39b2f29796f9 /sci-physics/root
parentFix typo in dependencies (#555130 by Brendan Jurd) (diff)
downloadgentoo-2-e2358639bc582b01f0f5c0f7a1d878cf022f974f.tar.gz
gentoo-2-e2358639bc582b01f0f5c0f7a1d878cf022f974f.tar.bz2
gentoo-2-e2358639bc582b01f0f5c0f7a1d878cf022f974f.zip
avoid unconditional pg_config sourcing by usex
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org> (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 565953B95372756C)
Diffstat (limited to 'sci-physics/root')
-rw-r--r--sci-physics/root/ChangeLog7
-rw-r--r--sci-physics/root/root-5.34.26.ebuild7
-rw-r--r--sci-physics/root/root-5.34.28-r1.ebuild7
3 files changed, 16 insertions, 5 deletions
diff --git a/sci-physics/root/ChangeLog b/sci-physics/root/ChangeLog
index a0872eef593b..6f52ac7f6cde 100644
--- a/sci-physics/root/ChangeLog
+++ b/sci-physics/root/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/root
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.149 2015/07/16 22:16:37 bircoph Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.150 2015/07/18 09:40:19 bircoph Exp $
+
+ 18 Jul 2015; Andrew Savchenko <bircoph@gentoo.org> root-5.34.26.ebuild,
+ root-5.34.28-r1.ebuild:
+ Do not use usex for postgres to avoid pg_config unconditional
+ sourcing. See bug 555246.
16 Jul 2015; Andrew Savchenko <bircoph@gentoo.org> root-5.34.28-r1.ebuild:
root-5.34.xx can't be used with >=pythia-8.2, see
diff --git a/sci-physics/root/root-5.34.26.ebuild b/sci-physics/root/root-5.34.26.ebuild
index da4549a48082..a0efccc812ba 100644
--- a/sci-physics/root/root-5.34.26.ebuild
+++ b/sci-physics/root/root-5.34.26.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.34.26.ebuild,v 1.5 2015/07/16 21:22:10 bircoph Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.34.26.ebuild,v 1.6 2015/07/18 09:40:19 bircoph Exp $
EAPI=5
@@ -327,7 +327,6 @@ src_configure() {
$(use_enable opengl)
$(use_enable oracle)
$(use_enable postgres pgsql)
- $(usex postgres "--with-pgsql-incdir=$(pg_config --includedir)" "")
$(use_enable prefix rpath)
$(use_enable pythia6)
$(use_enable pythia8)
@@ -345,6 +344,10 @@ src_configure() {
)
fi
+ # usex can't be used here, because pg_config may be not
+ # installed with USE="-postgres"
+ use postgres && myconf+=( --with-pgsql-incdir=$(pg_config --includedir) )
+
./configure ${myconf[@]} || die "configure failed"
}
diff --git a/sci-physics/root/root-5.34.28-r1.ebuild b/sci-physics/root/root-5.34.28-r1.ebuild
index 62ee744bf319..be6716ee823f 100644
--- a/sci-physics/root/root-5.34.28-r1.ebuild
+++ b/sci-physics/root/root-5.34.28-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.34.28-r1.ebuild,v 1.3 2015/07/16 22:16:37 bircoph Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.34.28-r1.ebuild,v 1.4 2015/07/18 09:40:19 bircoph Exp $
EAPI=5
@@ -311,7 +311,6 @@ src_configure() {
$(use_enable opengl)
$(use_enable oracle)
$(use_enable postgres pgsql)
- $(usex postgres "--with-pgsql-incdir=$(pg_config --includedir)" "")
$(use_enable prefix rpath)
$(use_enable pythia6)
$(use_enable pythia8)
@@ -331,6 +330,10 @@ src_configure() {
${EXTRA_ECONF}
)
+ # usex can't be used here, because pg_config may be not
+ # installed with USE="-postgres"
+ use postgres && myconf+=( --with-pgsql-incdir=$(pg_config --includedir) )
+
./configure ${myconf[@]} || die "configure failed"
}