summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-22 21:24:44 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-22 21:24:44 +0000
commit5945ed26338f7e7b0574aee54377f45777fa7bfc (patch)
treecb6a560ceee7aec1f139e7a9f2b20793c6c667b1 /sci-physics/herwig
parentBackport xen vs. xen-tools depend to older ebuilds. Fixes bug #389727 by Ian ... (diff)
downloadgentoo-2-5945ed26338f7e7b0574aee54377f45777fa7bfc.tar.gz
gentoo-2-5945ed26338f7e7b0574aee54377f45777fa7bfc.tar.bz2
gentoo-2-5945ed26338f7e7b0574aee54377f45777fa7bfc.zip
Version bump
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/herwig')
-rw-r--r--sci-physics/herwig/ChangeLog9
-rw-r--r--sci-physics/herwig/herwig-6.5.20.ebuild67
2 files changed, 74 insertions, 2 deletions
diff --git a/sci-physics/herwig/ChangeLog b/sci-physics/herwig/ChangeLog
index c3302450e414..f4f6f8695e60 100644
--- a/sci-physics/herwig/ChangeLog
+++ b/sci-physics/herwig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/herwig
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/herwig/ChangeLog,v 1.3 2009/11/25 22:11:29 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/herwig/ChangeLog,v 1.4 2012/01/22 21:24:44 bicatali Exp $
+
+*herwig-6.5.20 (22 Jan 2012)
+
+ 22 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +herwig-6.5.20.ebuild:
+ Version bump
25 Nov 2009; Markus Meier <maekke@gentoo.org> herwig-6.5.10.ebuild:
amd64/x86 stable, bug #294445
diff --git a/sci-physics/herwig/herwig-6.5.20.ebuild b/sci-physics/herwig/herwig-6.5.20.ebuild
new file mode 100644
index 000000000000..4cb818dbf1a6
--- /dev/null
+++ b/sci-physics/herwig/herwig-6.5.20.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/herwig/herwig-6.5.20.ebuild,v 1.1 2012/01/22 21:24:44 bicatali Exp $
+
+EAPI=4
+inherit versionator autotools fortran-2
+
+PV1=$(get_version_component_range 1 ${PV})
+PV2=$(get_version_component_range 2 ${PV})
+PV3=$(get_version_component_range 3 ${PV})
+MY_P=${PN}${PV1}${PV2}${PV3}
+MY_PINC="$(echo ${PN}|tr '[:lower:]' '[:upper:]')${PV1}${PV2}.INC"
+
+DESCRIPTION="High Energy Physics Event Generator"
+HOMEPAGE="http://www.hep.phy.cam.ac.uk/theory/webber/Herwig/"
+COM_URI="http://www.hep.phy.cam.ac.uk/theory/webber/Herwig"
+SRC_URI="${COM_URI}/${MY_P}.f
+ ${COM_URI}/${MY_P}.inc
+ ${COM_URI}/${MY_PINC}
+ doc? ( ${COM_URI}/hw65_manual.pdf )"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="!sci-physics/cernlib-montecarlo[herwig]"
+DEPEND="${RDEPEND}
+ virtual/fortran"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}"/* "${S}"
+}
+
+src_prepare() {
+ sed -i \
+ -e "s/${PN}.*.inc/${MY_P}.inc/" \
+ ${MY_PINC} || die
+ cat > configure.ac <<-EOF
+ AC_INIT(${PN},${PV})
+ AM_INIT_AUTOMAKE
+ AC_PROG_F77
+ AC_PROG_LIBTOOL
+ AC_CONFIG_FILES(Makefile)
+ AC_OUTPUT
+ EOF
+ cat > Makefile.am <<-EOF
+ lib_LTLIBRARIES = lib${PN}.la
+ lib${PN}_la_SOURCES = ${MY_P}.f
+ pkginclude_HEADERS = \
+ ${MY_PINC} \
+ ${MY_P}.inc
+
+ EOF
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use doc && dodoc "${DISTDIR}"/hw65_manual.pdf
+}