summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-05-14 12:29:51 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-05-14 12:29:51 +0000
commit9e0103756945273e1c921414612862e4f0b54755 (patch)
tree38e1e0b6702819f01d566424436b29eb27f0dad2 /sci-misc
parentstable x86, bug 268973 (diff)
downloadgentoo-2-9e0103756945273e1c921414612862e4f0b54755.tar.gz
gentoo-2-9e0103756945273e1c921414612862e4f0b54755.tar.bz2
gentoo-2-9e0103756945273e1c921414612862e4f0b54755.zip
Fix stripping issue per bug #257297. Again big thanks to Victor Ostroga.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/ChangeLog9
-rw-r--r--sci-misc/boinc/boinc-6.4.5-r2.ebuild (renamed from sci-misc/boinc/boinc-6.4.5-r1.ebuild)8
-rw-r--r--sci-misc/boinc/files/6.4.5-nostrip.patch30
3 files changed, 42 insertions, 5 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index e44047b08780..e50ffd559272 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.62 2009/05/13 21:04:22 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.63 2009/05/14 12:29:51 scarabeus Exp $
+
+*boinc-6.4.5-r2 (14 May 2009)
+
+ 14 May 2009; Tomas Chvatal <scarabeus@gentoo.org>
+ +files/6.4.5-nostrip.patch, -boinc-6.4.5-r1.ebuild,
+ +boinc-6.4.5-r2.ebuild:
+ Fix stripping issue per bug #257297. Again big thanks to Victor Ostroga.
13 May 2009; Tomas Chvatal <scarabeus@gentoo.org>
+files/6.4.5-gcc44.patch, boinc-6.4.5-r1.ebuild:
diff --git a/sci-misc/boinc/boinc-6.4.5-r1.ebuild b/sci-misc/boinc/boinc-6.4.5-r2.ebuild
index db34712a498c..17e63ca61284 100644
--- a/sci-misc/boinc/boinc-6.4.5-r1.ebuild
+++ b/sci-misc/boinc/boinc-6.4.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-6.4.5-r1.ebuild,v 1.7 2009/05/13 21:04:22 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-6.4.5-r2.ebuild,v 1.1 2009/05/14 12:29:51 scarabeus Exp $
#
# Don't forget to keep things in sync with binary boinc package!
@@ -54,11 +54,11 @@ src_prepare() {
cp "${S}"/sea/*.png "${S}"/clientgui/res/
# RSA Security bug fix. Per bug #258011
# GCC 4.4 Compilation issue. Per bug #269618
+ # Fix stripping. Per bug #257297
epatch \
"${FILESDIR}"/${PV}-RSA_security.patch \
- "${FILESDIR}"/${PV}-gcc44.patch
- # fix stripping
- ## TODO
+ "${FILESDIR}"/${PV}-gcc44.patch \
+ "${FILESDIR}"/${PV}-nostrip.patch
}
src_configure() {
diff --git a/sci-misc/boinc/files/6.4.5-nostrip.patch b/sci-misc/boinc/files/6.4.5-nostrip.patch
new file mode 100644
index 000000000000..cc9da4cef949
--- /dev/null
+++ b/sci-misc/boinc/files/6.4.5-nostrip.patch
@@ -0,0 +1,30 @@
+diff -NrU5 boinc-6.4.5.orig/client/Makefile.in boinc-6.4.5/client/Makefile.in
+--- boinc-6.4.5.orig/client/Makefile.in 2009-05-14 00:59:41.000000000 -0600
++++ boinc-6.4.5/client/Makefile.in 2009-05-14 01:01:10.000000000 -0600
+@@ -1330,11 +1330,10 @@
+ @CLIENT_BIN_FILENAME@: boinc_client
+ rm -f $@
+ rm -f $@.unmodified
+ cp $? $@.unmodified
+ @LN@ $? $@
+- @STRIP@ $@
+
+ clean-local:
+ rm -f @CLIENT_BIN_FILENAME@
+ rm -f @CLIENT_BIN_FILENAME@.unmodified
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+diff -NrU5 boinc-6.4.5.orig/lib/Makefile.in boinc-6.4.5/lib/Makefile.in
+--- boinc-6.4.5.orig/lib/Makefile.in 2009-05-14 00:59:41.000000000 -0600
++++ boinc-6.4.5/lib/Makefile.in 2009-05-14 01:00:31.000000000 -0600
+@@ -950,11 +950,10 @@
+ @CLIENT_CMD_BIN_FILENAME@: boinc_cmd$(EXEEXT)
+ rm -f $@
+ rm -f $@.unmodified
+ cp $? $@.unmodified
+ @LN@ $? $@
+- @STRIP@ $@
+
+ clean-local:
+ rm -f @CLIENT_CMD_BIN_FILENAME@
+ rm -f @CLIENT_CMD_BIN_FILENAME@.unmodified
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.